aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-13 14:45:08 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-13 14:45:08 +0000
commite99ceadaf6c77b80c19e16d91306e944305b1c88 (patch)
treee8a8f4dac51e148717ae07e2de0c635ec5d58833 /editors
parent3a5afbdcc87c8da2cc12bd67ec501257e48bc034 (diff)
downloadports-e99ceadaf6c77b80c19e16d91306e944305b1c88.tar.gz
ports-e99ceadaf6c77b80c19e16d91306e944305b1c88.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/AbiWord2/Makefile2
-rw-r--r--editors/abiword-devel/Makefile2
-rw-r--r--editors/abiword/Makefile2
-rw-r--r--editors/dedit/Makefile2
-rw-r--r--editors/mule-common/Makefile2
-rw-r--r--editors/mule/Makefile2
-rw-r--r--editors/ooodict-all/Makefile13
-rw-r--r--editors/xemacs-devel-mule/Makefile3
-rw-r--r--editors/xemacs21-mule/Makefile3
9 files changed, 17 insertions, 14 deletions
diff --git a/editors/AbiWord2/Makefile b/editors/AbiWord2/Makefile
index 31ca636302fd..6a383be58953 100644
--- a/editors/AbiWord2/Makefile
+++ b/editors/AbiWord2/Makefile
@@ -83,7 +83,7 @@ pre-configure:
@cd ${WRKSRC}/ac-helpers && ${RM} -f install-sh mkinstalldirs missing
@${RM} -f ${WRKSRC}/configure.ac
@cd ${WRKSRC} && ./autogen.sh && ${TRUE}
- @${FIND} ${WRKSRC} -name GNUmakefile.in | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name GNUmakefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|[(]libdir[)]/@PACKAGE@|(datadir)/@PACKAGE@|g ; \
s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g; \
s|@DEFS@|-I${WRKSRC}/../libiconv/include @DEFS@|g' && ${TRUE}
diff --git a/editors/abiword-devel/Makefile b/editors/abiword-devel/Makefile
index 31ca636302fd..6a383be58953 100644
--- a/editors/abiword-devel/Makefile
+++ b/editors/abiword-devel/Makefile
@@ -83,7 +83,7 @@ pre-configure:
@cd ${WRKSRC}/ac-helpers && ${RM} -f install-sh mkinstalldirs missing
@${RM} -f ${WRKSRC}/configure.ac
@cd ${WRKSRC} && ./autogen.sh && ${TRUE}
- @${FIND} ${WRKSRC} -name GNUmakefile.in | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name GNUmakefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|[(]libdir[)]/@PACKAGE@|(datadir)/@PACKAGE@|g ; \
s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g; \
s|@DEFS@|-I${WRKSRC}/../libiconv/include @DEFS@|g' && ${TRUE}
diff --git a/editors/abiword/Makefile b/editors/abiword/Makefile
index 31ca636302fd..6a383be58953 100644
--- a/editors/abiword/Makefile
+++ b/editors/abiword/Makefile
@@ -83,7 +83,7 @@ pre-configure:
@cd ${WRKSRC}/ac-helpers && ${RM} -f install-sh mkinstalldirs missing
@${RM} -f ${WRKSRC}/configure.ac
@cd ${WRKSRC} && ./autogen.sh && ${TRUE}
- @${FIND} ${WRKSRC} -name GNUmakefile.in | xargs ${REINPLACE_CMD} -e \
+ @${FIND} ${WRKSRC} -name GNUmakefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|[(]libdir[)]/@PACKAGE@|(datadir)/@PACKAGE@|g ; \
s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g; \
s|@DEFS@|-I${WRKSRC}/../libiconv/include @DEFS@|g' && ${TRUE}
diff --git a/editors/dedit/Makefile b/editors/dedit/Makefile
index 4f7f2066a622..8fa191c7837a 100644
--- a/editors/dedit/Makefile
+++ b/editors/dedit/Makefile
@@ -29,7 +29,7 @@ MAN1= dedit.1
MANLANG= "" ja
pre-patch:
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|dedit.ja.1||'
diff --git a/editors/mule-common/Makefile b/editors/mule-common/Makefile
index 378b98f4d298..4b98cd8d041e 100644
--- a/editors/mule-common/Makefile
+++ b/editors/mule-common/Makefile
@@ -118,7 +118,7 @@ BROKEN= First you should build install a port for mule except mule-common
.endif
pre-build::
- find ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
+ ${FIND} ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
${RM} -f ${WRKSRC}/etc/DOC* ${WRKSRC}/src/emacs ${WRKSRC}/src/emacs-${EMACS_VERSION}.*
post-build:
diff --git a/editors/mule/Makefile b/editors/mule/Makefile
index ab77d663ecd0..37acb4dea0fe 100644
--- a/editors/mule/Makefile
+++ b/editors/mule/Makefile
@@ -141,7 +141,7 @@ post-patch:
.endif
pre-build:
- find ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
+ ${FIND} ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
${RM} -f ${WRKSRC}/etc/DOC* ${WRKSRC}/src/emacs ${WRKSRC}/src/emacs-${EMACS_VERSION}.*
post-build:
diff --git a/editors/ooodict-all/Makefile b/editors/ooodict-all/Makefile
index 79ad65810a00..327698a01211 100644
--- a/editors/ooodict-all/Makefile
+++ b/editors/ooodict-all/Makefile
@@ -106,7 +106,8 @@ post-install:
cd ${PREFIX} && ${FIND} -s ${DICT_DIR} -type f | \
${GREP} $${LANGUAGE}_$${COUNTRY} >> ${TMPPLIST} ; \
cd ${PREFIX} && ${FIND} -s ${DICT_DIR} -type f | \
- ${GREP} $${LANGUAGE}_$${COUNTRY} | xargs chmod 755 ; \
+ ${GREP} $${LANGUAGE}_$${COUNTRY} | \
+ ${XARGS} chmod 755 ; \
${ECHO} "@unexec ${CP} ${DICT_LIST} \
${DICT_LIST}.$${LANGUAGE}_$${COUNTRY}" >> ${TMPPLIST} ; \
${ECHO} "@unexec \
@@ -123,10 +124,10 @@ post-install:
${ECHO} "@exec ${ECHO} \"DICT $${LANGUAGE} AT de_AT\" \
>> ${DICT_LIST}" >> ${TMPPLIST} ; \
${ECHO_CMD} "DICT $$LANGUAGE AT $${ABRV}" >> ${DICT_LIST_INST} ; \
- cd ${PREFIX} && ${FIND} -s ${DICT_DIR} -type f | \
- ${GREP} $${LANGUAGE}_AT >> ${TMPPLIST} ; \
- cd ${PREFIX} && ${FIND} -s ${DICT_DIR} -type l | \
- ${GREP} $${LANGUAGE}_AT >> ${TMPPLIST} ; \
+ cd ${PREFIX} && ${FIND} -s ${DICT_DIR} -type f \
+ | ${GREP} $${LANGUAGE}_AT >> ${TMPPLIST} ; \
+ cd ${PREFIX} && ${FIND} -s ${DICT_DIR} -type l \
+ | ${GREP} $${LANGUAGE}_AT >> ${TMPPLIST} ; \
${ECHO} "@unexec ${CP} ${DICT_LIST} \
${DICT_LIST}.$${LANGUAGE}_AT" >> ${TMPPLIST} ; \
${ECHO} "@unexec \
@@ -165,7 +166,7 @@ post-install:
cd ${PREFIX} && ${FIND} -s ${DICT_DIR} -type f | \
${GREP} hyph_$${ABRV}.dic >> ${TMPPLIST} ; \
cd ${PREFIX} && ${FIND} -s ${DICT_DIR} -type f | \
- ${GREP} hyph_$${ABRV}.dic | xargs chmod 755 ; \
+ ${GREP} hyph_$${ABRV}.dic | ${XARGS} chmod 755 ; \
${ECHO} "@unexec ${CP} ${DICT_LIST} \
${DICT_LIST}.hyph_$${LANGUAGE}_$${COUNTRY}" >> ${TMPPLIST} ; \
${ECHO} "@unexec \
diff --git a/editors/xemacs-devel-mule/Makefile b/editors/xemacs-devel-mule/Makefile
index 05e3256232f1..47d18908968b 100644
--- a/editors/xemacs-devel-mule/Makefile
+++ b/editors/xemacs-devel-mule/Makefile
@@ -159,7 +159,8 @@ pre-configure::
.endfor
pre-build:
- @find ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
+ @${FIND} ${WRKSRC} \( -name \*.orig -o -name \*~ \) \
+ -exec ${RM} -f \{} \;
@${RM} -f ${WRKSRC}/lib-src/DOC* ${WRKSRC}/src/xemacs
post-install::
diff --git a/editors/xemacs21-mule/Makefile b/editors/xemacs21-mule/Makefile
index bb0562ab1e9a..824b9cc2e7fc 100644
--- a/editors/xemacs21-mule/Makefile
+++ b/editors/xemacs21-mule/Makefile
@@ -169,7 +169,8 @@ pre-configure::
.endfor
pre-build:
- @find ${WRKSRC} \( -name \*.orig -o -name \*~ \) -exec ${RM} -f \{} \;
+ @${FIND} ${WRKSRC} \( -name \*.orig -o -name \*~ \) \
+ -exec ${RM} -f \{} \;
@${RM} -f ${WRKSRC}/lib-src/DOC* ${WRKSRC}/src/xemacs
post-install::