aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2010-11-18 03:39:12 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2010-11-18 03:39:12 +0000
commit5c37bd26b0dbb902c948f0f16bbf365d3e2b8582 (patch)
treeb135d07583e5763212ee17dd00d7950d5062ee2d /editors
parent138a45847e022f2a342b4f75d1b48dea9c729992 (diff)
downloadports-5c37bd26b0dbb902c948f0f16bbf365d3e2b8582.tar.gz
ports-5c37bd26b0dbb902c948f0f16bbf365d3e2b8582.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/emacs-devel/Makefile35
-rw-r--r--editors/emacs-devel/distinfo5
-rw-r--r--editors/emacs-devel/files/patch-configure2
-rw-r--r--editors/emacs-devel/files/patch-doc-emacs-Makefile.in26
-rw-r--r--editors/emacs-devel/files/patch-doc-lispintro-Makefile.in30
-rw-r--r--editors/emacs-devel/files/patch-doc-lispref-Makefile.in21
-rw-r--r--editors/emacs-devel/files/patch-doc-misc-Makefile.in13
-rw-r--r--editors/emacs-devel/files/patch-src_config.in14
-rw-r--r--editors/emacs-devel/pkg-plist4
9 files changed, 88 insertions, 62 deletions
diff --git a/editors/emacs-devel/Makefile b/editors/emacs-devel/Makefile
index 3a0ddeae78eb..24bd1609f5df 100644
--- a/editors/emacs-devel/Makefile
+++ b/editors/emacs-devel/Makefile
@@ -26,7 +26,7 @@ CONFLICTS= emacs-19.* emacs-21.* emacs-22.* emacs-23.* \
INSTALLS_ICONS= yes
EMACS_VER= 24.0.50
-EMACS_REV= 101606
+EMACS_REV= 102364
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_XZ= yes
@@ -36,16 +36,17 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --localstatedir=/var
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+EMACS_DIRS= ${DATADIR}/${EMACS_VER}/leim ${DATADIR}/${EMACS_VER}/lisp ${DATADIR}/${EMACS_VER}/src \
+ ${PREFIX}/libexec/${PORTNAME}
+
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-MAN1= b2m.1 ctags.1 ebrowse.1 emacs.1 emacsclient.1 etags.1 \
+MAN1= ctags.1 ebrowse.1 emacs.1 emacsclient.1 etags.1 \
grep-changelog.1 rcs-checkin.1
MANCOMPRESSED= yes
PLIST_SUB= EMACS_VER=${EMACS_VER}
-EMACS_DIRS= ${DATADIR}/${EMACS_VER} ${PREFIX}/libexec/${PORTNAME}
-
MAKE_ENV= LC_ALL=C
INFO= ada-mode auth autotype calc ccmode cl dbus dired-x \
@@ -59,6 +60,7 @@ LATEST_LINK= emacs-devel
OPTIONS= DBUS "DBus support" ON \
GCONF "GConf support" ON \
GIF "GIF Images support" ON \
+ GTK2 "Use GTK+ widgets" ON \
JPEG "JPEG images support" ON \
M17N "M17N support for text-shaping" ON \
MOTIF "Use Motif widgets" OFF \
@@ -76,7 +78,8 @@ OPTIONS= DBUS "DBus support" ON \
XIM "X Input Method support" ON \
XML "XML Parser support" ON \
XPM "XPM images support" ON \
- IMAGEMAGICK "ImageMagick support" OFF
+ IMAGEMAGICK "ImageMagick support" ON \
+ GNUTLS "GNUTLS support" ON
.include <bsd.port.options.mk>
@@ -210,8 +213,9 @@ CONFIGURE_ARGS+= --without-dbus
LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
.endif
-.if defined(WITH_IMAGEMAGICK)
-CONFIGURE_ARGS+= --with-imagemagick
+.if defined(WITHOUT_IMAGEMAGICK)
+CONFIGURE_ARGS+= --without-imagemagick
+.else
LIB_DEPENDS+= MagickCore.4:${PORTSDIR}/graphics/ImageMagick
.endif
@@ -221,6 +225,12 @@ CONFIGURE_ARGS+= --without-xml2
USE_GNOME+= libxml2
.endif
+.if defined(WITHOUT_GNUTLS)
+CONFIGURE_ARGS+= --without-gnutls
+.else
+LIB_DEPENDS+= gnutls.40:${PORTSDIR}/security/gnutls
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64"
@@ -236,17 +246,24 @@ post-configure:
add-plist-data:
.for i in ${EMACS_DIRS}
- @${FIND} ${i} -type f |${SED} -e 's,${PREFIX}/,,g' >>${TMPPLIST}
+ @${FIND} ${i} -type f |${SED} -E -e 's,^${PREFIX}/,,g' >>${TMPPLIST}
.endfor
+ @${FIND} ${WRKSRC}/etc -type f |${SED} -E -e 's,^${WRKSRC},${DATADIR_REL}/${EMACS_VER},g' -e '/etc\/(\..*|ChangeLog|DOC)$$/d' >>${TMPPLIST}
+ @${FIND} ${WRKSRC}/etc -type d -depth |${SED} -E -e 's,^${WRKSRC},@dirrm ${DATADIR_REL}/${EMACS_VER},g' >>${TMPPLIST}
.for i in ${EMACS_DIRS}
- @${FIND} ${i} -type d -depth |${SED} -e 's,^${PREFIX}/,@dirrm ,g' >>${TMPPLIST}
+ @${FIND} ${i} -type d -depth |${SED} -E -e 's,^${PREFIX}/,@dirrm ,g' >>${TMPPLIST}
.endfor
+ @${ECHO} "@unexec rmdir %D/${DATADIR_REL}/${EMACS_VER} 2>/dev/null || true" >>${TMPPLIST}
.if defined(WITH_SOURCES)
+PLIST_SUB+= SOURCES=""
+
post-install:
@${MKDIR} ${DATADIR}/${EMACS_VER}/src
@${INSTALL_DATA} ${WRKSRC}/src/*.[ch] ${DATADIR}/${EMACS_VER}/src
@${INSTALL_DATA} ${WRKSRC}/sources.el ${DATADIR}/${EMACS_VER}/site-lisp/site-start.el
+.else
+PLIST_SUB+= SOURCES="@comment "
.endif
.if !defined(WITHOUT_X11)
diff --git a/editors/emacs-devel/distinfo b/editors/emacs-devel/distinfo
index cf7cab8f262b..0bad985a270f 100644
--- a/editors/emacs-devel/distinfo
+++ b/editors/emacs-devel/distinfo
@@ -1,3 +1,2 @@
-MD5 (emacs-24.0.50.101606.tar.xz) = f84afaf4824c7d3226eb2030fd08015c
-SHA256 (emacs-24.0.50.101606.tar.xz) = 3f8a6550f3cea73b3f45af0f9a64b4e4d0067ce30cc5e63caf2a883e81f119da
-SIZE (emacs-24.0.50.101606.tar.xz) = 22709448
+SHA256 (emacs-24.0.50.102364.tar.xz) = 7eb2e31c8aabbd130b8e8df03ef1892455cc7a97be6601f62322104e8bec546c
+SIZE (emacs-24.0.50.102364.tar.xz) = 22792292
diff --git a/editors/emacs-devel/files/patch-configure b/editors/emacs-devel/files/patch-configure
index cc5d025d98a5..ba34920b61f0 100644
--- a/editors/emacs-devel/files/patch-configure
+++ b/editors/emacs-devel/files/patch-configure
@@ -3,7 +3,7 @@ $FreeBSD$
--- configure.orig
+++ configure
-@@ -6041,170 +6041,6 @@
+@@ -6055,170 +6055,6 @@
LIBSOUND=
fi
diff --git a/editors/emacs-devel/files/patch-doc-emacs-Makefile.in b/editors/emacs-devel/files/patch-doc-emacs-Makefile.in
index da2f5b8506b8..5faf9ad9aa7e 100644
--- a/editors/emacs-devel/files/patch-doc-emacs-Makefile.in
+++ b/editors/emacs-devel/files/patch-doc-emacs-Makefile.in
@@ -1,20 +1,14 @@
---- doc/emacs/Makefile.in.orig 2008-12-09 19:27:59.000000000 +0200
-+++ doc/emacs/Makefile.in 2008-12-09 19:25:19.000000000 +0200
-@@ -34,7 +34,7 @@
+
+$FreeBSD$
+
+--- doc/emacs/Makefile.in.orig
++++ doc/emacs/Makefile.in
+@@ -39,7 +39,7 @@
# The makeinfo program is part of the Texinfo distribution.
# Use --force so that it generates output even if there are errors.
--MAKEINFO = makeinfo --force
-+MAKEINFO = makeinfo --force --no-split
+-MAKEINFO = makeinfo --force -I $(srcdir)
++MAKEINFO = makeinfo --force --no-split -I $(srcdir)
- INFO_TARGETS = $(infodir)/emacs
- DVI_TARGETS = emacs.dvi
-@@ -144,7 +144,7 @@
- # rm -f Makefile
-
- maintainer-clean: distclean
-- for file in $(INFO_TARGETS); do rm -f $${file}*; done
-+ for file in $(INFO_TARGETS); do rm -f $${file}; done
-
-
- # Formerly this directory had texindex.c and getopt.c in it
+ TEXI2DVI = texi2dvi
+ TEXI2PDF = texi2pdf
diff --git a/editors/emacs-devel/files/patch-doc-lispintro-Makefile.in b/editors/emacs-devel/files/patch-doc-lispintro-Makefile.in
index a6266c3bef95..86c190ca927a 100644
--- a/editors/emacs-devel/files/patch-doc-lispintro-Makefile.in
+++ b/editors/emacs-devel/files/patch-doc-lispintro-Makefile.in
@@ -1,20 +1,14 @@
---- doc/lispintro/Makefile.in.orig 2008-12-09 19:27:59.000000000 +0200
-+++ doc/lispintro/Makefile.in 2008-12-09 19:25:20.000000000 +0200
-@@ -33,7 +33,7 @@
- INFO_TARGETS = ${infodir}/eintr
- DVI_TARGETS = emacs-lisp-intro.dvi
-
--MAKEINFO = makeinfo
-+MAKEINFO = makeinfo --no-split
+
+$FreeBSD$
+
+--- doc/lispintro/Makefile.in.orig
++++ doc/lispintro/Makefile.in
+@@ -28,7 +28,7 @@
+ # Directory with the (customized) texinfo.tex file.
+ texinfodir = $(srcdir)/../misc
+
+-MAKEINFO = makeinfo --force -I $(srcdir)
++MAKEINFO = makeinfo --no-split --force -I $(srcdir)
TEXI2DVI = texi2dvi
+ TEXI2PDF = texi2pdf
DVIPS = dvips
-
-@@ -65,7 +65,7 @@
-
- maintainer-clean: distclean
- rm -f *.aux *.cps *.fns *.kys *.pgs *.vrs *.toc
-- cd $(infodir); rm -f eintr eintr-[1-9]
-+ cd $(infodir); rm -f eintr
-
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/editors/emacs-devel/files/patch-doc-lispref-Makefile.in b/editors/emacs-devel/files/patch-doc-lispref-Makefile.in
index 6d069939164d..9ce0624ce29a 100644
--- a/editors/emacs-devel/files/patch-doc-lispref-Makefile.in
+++ b/editors/emacs-devel/files/patch-doc-lispref-Makefile.in
@@ -1,11 +1,14 @@
---- doc/lispref/Makefile.in.orig 2008-12-09 19:27:59.000000000 +0200
-+++ doc/lispref/Makefile.in 2008-12-09 19:25:20.000000000 +0200
+
+$FreeBSD$
+
+--- doc/lispref/Makefile.in.orig
++++ doc/lispref/Makefile.in
@@ -32,7 +32,7 @@
- TEXI2DVI = texi2dvi
- SHELL = /bin/sh
- INSTALL_INFO = install-info
--MAKEINFO = makeinfo --force
-+MAKEINFO = makeinfo --force --no-split
-
- # List of all the texinfo files in the manual:
+ # Directory with emacsver.texi.
+ emacsdir = $(srcdir)/../emacs
+-MAKEINFO = makeinfo --force -I $(emacsdir) -I $(srcdir)
++MAKEINFO = makeinfo --no-split --force -I $(emacsdir) -I $(srcdir)
+ TEXI2DVI = texi2dvi
+ TEXI2PDF = texi2pdf
+ DVIPS = dvips
diff --git a/editors/emacs-devel/files/patch-doc-misc-Makefile.in b/editors/emacs-devel/files/patch-doc-misc-Makefile.in
index 8626784b0f4e..02c821e5f3c9 100644
--- a/editors/emacs-devel/files/patch-doc-misc-Makefile.in
+++ b/editors/emacs-devel/files/patch-doc-misc-Makefile.in
@@ -1,11 +1,14 @@
---- doc/misc/Makefile.in.orig Tue Jun 23 07:39:39 2009 +0300
-+++ doc/misc/Makefile.in Tue Jun 23 07:39:41 2009 +0300
-@@ -34,7 +34,7 @@
+
+$FreeBSD$
+
+--- doc/misc/Makefile.in.orig
++++ doc/misc/Makefile.in
+@@ -42,7 +42,7 @@
# The makeinfo program is part of the Texinfo distribution.
# Use --force so that it generates output even if there are errors.
--MAKEINFO = makeinfo --force
-+MAKEINFO = makeinfo --force --no-split
+-MAKEINFO = makeinfo --force -I$(emacsdir)
++MAKEINFO = makeinfo --force --no-split -I$(emacsdir)
# Also add new entries to INFO_FILES in the top-level Makefile.in.
INFO_TARGETS = \
diff --git a/editors/emacs-devel/files/patch-src_config.in b/editors/emacs-devel/files/patch-src_config.in
new file mode 100644
index 000000000000..b8fee6cc07d1
--- /dev/null
+++ b/editors/emacs-devel/files/patch-src_config.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- src/config.in.orig
++++ src/config.in
+@@ -1171,6 +1171,8 @@
+
+ #ifdef HAVE_ALLOCA_H
+ # include <alloca.h>
++#elif __FreeBSD__
++#include <stdlib.h>
+ #elif defined __GNUC__
+ # define alloca __builtin_alloca
+ #elif defined _AIX
diff --git a/editors/emacs-devel/pkg-plist b/editors/emacs-devel/pkg-plist
index 09d22670d234..4c0884921402 100644
--- a/editors/emacs-devel/pkg-plist
+++ b/editors/emacs-devel/pkg-plist
@@ -1,4 +1,3 @@
-bin/b2m
bin/ctags
bin/ebrowse
bin/emacs
@@ -8,6 +7,8 @@ bin/etags
bin/grep-changelog
bin/rcs-checkin
share/applications/emacs.desktop
+%%SOURCES%%%%DATADIR%%/%%EMACS_VER%%/site-lisp/site-start.el
+%%DATADIR%%/%%EMACS_VER%%/site-lisp/subdirs.el
%%DATADIR%%/site-lisp/subdirs.el
share/icons/hicolor/128x128/apps/emacs.png
share/icons/hicolor/16x16/apps/emacs.png
@@ -20,6 +21,7 @@ share/icons/hicolor/48x48/apps/emacs.png
share/icons/hicolor/48x48/apps/emacs22.png
share/icons/hicolor/scalable/apps/emacs.svg
share/icons/hicolor/scalable/mimetypes/emacs-document.svg
+@dirrmtry %%DATADIR%%/%%EMACS_VER%%/site-lisp
@dirrmtry share/icons/hicolor/scalable/mimetypes
@dirrmtry share/icons/hicolor/scalable/apps
@dirrmtry share/icons/hicolor/scalable