aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-08-26 14:06:08 +0000
commit216b5a285fdcc1456a307fcc60f3507c20d613eb (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /editors
parentb829518a7d432b7cc2546fde7f032238d1db13dc (diff)
downloadports-216b5a285fdcc1456a307fcc60f3507c20d613eb.tar.gz
ports-216b5a285fdcc1456a307fcc60f3507c20d613eb.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/codelite/files/patch-sdk_codelite_indexer_CMakeLists.txt11
-rw-r--r--editors/ghex/Makefile3
-rw-r--r--editors/madedit/Makefile14
3 files changed, 19 insertions, 9 deletions
diff --git a/editors/codelite/files/patch-sdk_codelite_indexer_CMakeLists.txt b/editors/codelite/files/patch-sdk_codelite_indexer_CMakeLists.txt
new file mode 100644
index 000000000000..aed26e91dd3d
--- /dev/null
+++ b/editors/codelite/files/patch-sdk_codelite_indexer_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- sdk/codelite_indexer/CMakeLists.txt.orig
++++ sdk/codelite_indexer/CMakeLists.txt
+@@ -33,7 +33,7 @@
+
+ # Define the output
+ add_executable(codelite_indexer ${SRCS})
+-target_link_libraries(codelite_indexer ${LINKER_OPTIONS} ${wxWidgets_LIBRARIES})
++target_link_libraries(codelite_indexer ${LINKER_OPTIONS} ${wxWidgets_LIBRARIES} -pthread)
+
+ install(TARGETS codelite_indexer DESTINATION ${CL_PREFIX}/bin)
+
diff --git a/editors/ghex/Makefile b/editors/ghex/Makefile
index 0c5d604febe7..d60c52eb33f9 100644
--- a/editors/ghex/Makefile
+++ b/editors/ghex/Makefile
@@ -23,4 +23,7 @@ LDFLAGS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= ghex2.schemas
+post-patch:
+ @${REINPLACE_CMD} '/^ghex2_LDADD =/s/$$/ -lm/' ${WRKSRC}/src/Makefile.in
+
.include <bsd.port.mk>
diff --git a/editors/madedit/Makefile b/editors/madedit/Makefile
index 5177c2a1896d..c25705f655a5 100644
--- a/editors/madedit/Makefile
+++ b/editors/madedit/Makefile
@@ -12,20 +12,16 @@ COMMENT= Open-source and cross-platform text/hex editor
LICENSE= GPLv2
+LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs
+
USES= gettext pkgconfig dos2unix desktop-file-utils
USE_WX= 2.8+
WANT_UNICODE= yes
-
-LIB_DEPENDS+= libboost_regex.so:${PORTSDIR}/devel/boost-libs
+USE_XORG= x11
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-wx-config=${WX_CONFIG}
-CONFIGURE_ENV+= PKG_CONFIG="${PKG_CONFIG}" glib_gtk2_CFLAGS="${glib_gtk2_CFLAGS}" glib_gtk2_LIBS="${glib_gtk2_LIBS}"
-CXXFLAGS+= ${glib_gtk2_CFLAGS}
-
-PKG_CONFIG?= ${LOCALBASE}/bin/pkgconf
-glib_gtk2_CFLAGS=`${PKG_CONFIG} --cflags gtk+-2.0`
-glib_gtk2_LIBS= `${PKG_CONFIG} --libs gtk+-2.0`
+CONFIGURE_ARGS= --with-wx-config=${WX_CONFIG}
+LIBS+= -L${LOCALBASE}/lib -lX11
BROKEN_sparc64= yes