aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-01-02 22:23:28 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-01-02 22:23:28 +0000
commit499d5c44c2c30db374a9a12f4c25246ae7f0174d (patch)
tree276cdcd9ad29869b0c529be3020beb0984908943 /editors
parent565d57af66cd2fee1abe5fde71b108383d7a70ec (diff)
downloadports-499d5c44c2c30db374a9a12f4c25246ae7f0174d.tar.gz
ports-499d5c44c2c30db374a9a12f4c25246ae7f0174d.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/Makefile1
-rw-r--r--editors/xmlcopyeditor/Makefile41
-rw-r--r--editors/xmlcopyeditor/distinfo3
-rw-r--r--editors/xmlcopyeditor/files/patch-aclocal.m4.diff83
-rw-r--r--editors/xmlcopyeditor/files/patch-configure.in.diff12
-rw-r--r--editors/xmlcopyeditor/files/patch-src_Makefile.am.diff45
-rw-r--r--editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.cpp.diff26
-rw-r--r--editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.h.diff10
-rw-r--r--editors/xmlcopyeditor/files/pkg-message.in8
-rw-r--r--editors/xmlcopyeditor/pkg-descr17
-rw-r--r--editors/xmlcopyeditor/pkg-plist231
11 files changed, 477 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 7c633ea47c2f..50b826bcb1b9 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -181,6 +181,7 @@
SUBDIR += xemacs21-mule
SUBDIR += xenon
SUBDIR += xml2rfc-xxe
+ SUBDIR += xmlcopyeditor
SUBDIR += xmleditor
SUBDIR += xvile
SUBDIR += xxe
diff --git a/editors/xmlcopyeditor/Makefile b/editors/xmlcopyeditor/Makefile
new file mode 100644
index 000000000000..33b339dc53c7
--- /dev/null
+++ b/editors/xmlcopyeditor/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: xmlcopyeditor
+# Date created: 6 December 2007
+# Whom: José García Juanino <jjuanino@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmlcopyeditor
+PORTVERSION= 1.1.0.3
+CATEGORIES= editors
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR=xml-copy-editor
+
+MAINTAINER= jjuanino@gmail.com
+COMMENT= Fast validating XML editor
+
+USE_WX= 2.8+
+WX_COMPS= wx contrib
+WX_CONF_ARGS= absolute
+WX_UNICODE= yes
+USE_GETTEXT= yes
+USE_DOS2UNIX= src/mynotebook.cpp src/mynotebook.h \
+ src/xmlcopyeditor.cpp src/xmlcopyeditor.h
+SUB_FILES= pkg-message
+
+BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost
+LIB_DEPENDS+= xerces-c.27:${PORTSDIR}/textproc/xerces-c2 \
+ xslt.2:${PORTSDIR}/textproc/libxslt
+
+USE_AUTOTOOLS= autoconf:261 automake:19
+
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/libxml2 ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/editors/xmlcopyeditor/distinfo b/editors/xmlcopyeditor/distinfo
new file mode 100644
index 000000000000..80b9bfc839ab
--- /dev/null
+++ b/editors/xmlcopyeditor/distinfo
@@ -0,0 +1,3 @@
+MD5 (xmlcopyeditor-1.1.0.3.tar.gz) = 95d422fcf9f5a924374780372df8099c
+SHA256 (xmlcopyeditor-1.1.0.3.tar.gz) = 1df5b9b24e9fba2870bce07fbb70bdeece4856d1ea70e417a0d1cfc2f1356960
+SIZE (xmlcopyeditor-1.1.0.3.tar.gz) = 2601213
diff --git a/editors/xmlcopyeditor/files/patch-aclocal.m4.diff b/editors/xmlcopyeditor/files/patch-aclocal.m4.diff
new file mode 100644
index 000000000000..050d19fb31f8
--- /dev/null
+++ b/editors/xmlcopyeditor/files/patch-aclocal.m4.diff
@@ -0,0 +1,83 @@
+--- aclocal.m4.orig Thu Dec 20 19:29:53 2007
++++ aclocal.m4 Thu Dec 20 19:30:48 2007
+@@ -7243,3 +7243,80 @@
+ ]) # _AM_PROG_TAR
+
+
++# ---------------------------------------------------------------------------
++# test for availability of iconv()
++# ---------------------------------------------------------------------------
++
++# From Bruno Haible.
++
++AC_DEFUN([AM_ICONV],
++[
++ # Some systems have iconv in libc, some have it in libiconv (OSF/1 and
++ # those with the standalone portable GNU libiconv installed).
++
++ AC_ARG_WITH([libiconv-prefix],
++[ --with-libiconv-prefix=DIR search for libiconv in DIR/include and DIR/lib], [
++ for dir in `echo "$withval" | tr : ' '`; do
++ if test -d $dir/include; then CPPFLAGS="$CPPFLAGS -I$dir/include"; fi
++ if test -d $dir/lib; then LDFLAGS="$LDFLAGS -L$dir/lib"; fi
++ done
++ ])
++
++ AC_CACHE_CHECK(for iconv, am_cv_func_iconv, [
++ am_cv_func_iconv="no, consider installing GNU libiconv"
++ am_cv_lib_iconv=no
++ AC_TRY_LINK([#include <stdlib.h>
++#include <iconv.h>],
++ [iconv_t cd = iconv_open("","");
++ iconv(cd,NULL,NULL,NULL,NULL);
++ iconv_close(cd);],
++ am_cv_func_iconv=yes)
++ if test "$am_cv_func_iconv" != yes; then
++ am_save_LIBS="$LIBS"
++ LIBS="$LIBS -liconv"
++ AC_TRY_LINK([#include <stdlib.h>
++#include <iconv.h>],
++ [iconv_t cd = iconv_open("","");
++ iconv(cd,NULL,NULL,NULL,NULL);
++ iconv_close(cd);],
++ am_cv_lib_iconv=yes
++ am_cv_func_iconv=yes)
++ LIBS="$am_save_LIBS"
++ fi
++ ])
++ if test "$am_cv_func_iconv" = yes; then
++ AC_DEFINE(HAVE_ICONV, 1, [Define if you have the iconv() function.])
++ AC_CACHE_CHECK([if iconv needs const], wx_cv_func_iconv_const,
++ AC_TRY_COMPILE([
++#include <stdlib.h>
++#include <iconv.h>
++extern
++#ifdef __cplusplus
++"C"
++#endif
++#if defined(__STDC__) || defined(__cplusplus)
++size_t iconv (iconv_t cd, char * *inbuf, size_t *inbytesleft, char * *outbuf, size_t *outbytesleft);
++#else
++size_t iconv();
++#endif
++ ],
++ [],
++ wx_cv_func_iconv_const="no",
++ wx_cv_func_iconv_const="yes"
++ )
++ )
++
++ iconv_const=
++ if test "x$wx_cv_func_iconv_const" = "xyes"; then
++ iconv_const="const"
++ fi
++
++ AC_DEFINE_UNQUOTED(ICONV_CONST, $iconv_const,
++ [Define as const if the declaration of iconv() needs const.])
++ fi
++ LIBICONV=
++ if test "$am_cv_lib_iconv" = yes; then
++ LIBICONV="-liconv"
++ fi
++ AC_SUBST(LIBICONV)
++])
diff --git a/editors/xmlcopyeditor/files/patch-configure.in.diff b/editors/xmlcopyeditor/files/patch-configure.in.diff
new file mode 100644
index 000000000000..014784eba2da
--- /dev/null
+++ b/editors/xmlcopyeditor/files/patch-configure.in.diff
@@ -0,0 +1,12 @@
+--- configure.in.orig Thu Dec 20 16:54:28 2007
++++ configure.in Thu Dec 20 16:56:11 2007
+@@ -35,6 +35,9 @@
+ # Call WXTEST func
+ WXTEST
+
++# Call iconv checks
++AM_ICONV
++
+ # Verify minimus requires
+ vers=`echo $wxversion | $AWK 'BEGIN { FS = "."; } { printf "% d", ($1 * 1000 + $2) * 1000 + $3;}'`
+ if test -n "$vers" && test "$vers" -ge 2008000; then
diff --git a/editors/xmlcopyeditor/files/patch-src_Makefile.am.diff b/editors/xmlcopyeditor/files/patch-src_Makefile.am.diff
new file mode 100644
index 000000000000..8d5fd7a97148
--- /dev/null
+++ b/editors/xmlcopyeditor/files/patch-src_Makefile.am.diff
@@ -0,0 +1,45 @@
+--- src/Makefile.am.orig Tue Jan 1 12:20:45 2008
++++ src/Makefile.am Tue Jan 1 12:21:28 2008
+@@ -9,8 +9,8 @@
+ bin_PROGRAMS = xmlcopyeditor
+ bindir = ${prefix}/bin
+ xmlcopyeditordir = ${prefix}/share/xmlcopyeditor
+-pixmapdir = /usr/share/pixmaps
+-applicationsdir = /usr/share/applications
++pixmapdir = ${prefix}/share/pixmaps
++applicationsdir = ${prefix}/share/applications
+
+ # the application source, library search path, and link libraries
+ xmlcopyeditor_SOURCES = xmlcopyeditor.cpp associatedialog.cpp casehandler.cpp \
+@@ -41,15 +41,13 @@
+ xpm/*.xpm \
+ templates/*.* \
+ help/*.* help/html/*.* \
+- copying/*.txt copying/boost_shared_ptr/* \
+- copying/Expat/* copying/libxml2/* copying/libxslt/* \
+- copying/PCRE/* copying/Scintilla/* \
+- copying/scowl/* \
+- copying/wxStyledTextCtrl/* copying/ximian/* \
+- copying/wxStEditor/* \
+- copying/xmlcopyeditor/* \
+- copying/Apache/LICENSE-2.0 \
+- copying/Apache/LICENSE-2_files/* \
++ copying/boost_license_1_0.txt copying/boost_shared_ptr/* \
++ copying/scowl/copying.txt \
++ copying/mit.txt \
++ copying/libxslt/libxslt-lic.txt \
++ copying/libxml2/libxml2-lic.txt \
++ copying/Scintilla/scintilla-lic.txt \
++ copying/Expat/copying.txt \
+ po/sk/messages.mo \
+ po/sv/messages.mo \
+ po/fr/messages.mo \
+@@ -58,7 +56,7 @@
+ po/zh_TW/messages.mo \
+ po/uk_UA/messages.mo \
+ po/uk_UA/messages.mo \
+- po/en_us/messages.po \
++ po/en_us/messages.po
+
+ pixmap_DATA = xmlcopyeditor.png
+
diff --git a/editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.cpp.diff b/editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.cpp.diff
new file mode 100644
index 000000000000..7c072324ad38
--- /dev/null
+++ b/editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.cpp.diff
@@ -0,0 +1,26 @@
+--- src/xmlcopyeditor.cpp.orig Thu Dec 20 19:39:44 2007
++++ src/xmlcopyeditor.cpp Thu Dec 20 19:42:26 2007
+@@ -2977,10 +2977,7 @@
+
+ nconv = iconv (
+ cd,
+-#ifdef __WXMSW__
+- ( const char ** )
+-#endif
+- &docBuffer,
++ ICONV_CHAR_CAST(&docBuffer),
+ &docBufferLeft,
+ &iconvBuffer,
+ &iconvBufferLeft );
+@@ -4685,10 +4682,7 @@
+
+ nconv = iconv (
+ cd,
+-#ifdef __WXMSW__
+- ( const char ** )
+-#endif
+- &utf8BufferPtr,
++ ICONV_CHAR_CAST(&utf8BufferPtr),
+ &utf8BufferLeft,
+ &iconvBuffer,
+ &iconvBufferLeft );
diff --git a/editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.h.diff b/editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.h.diff
new file mode 100644
index 000000000000..15e95cf2ca24
--- /dev/null
+++ b/editors/xmlcopyeditor/files/patch-src_xmlcopyeditor.h.diff
@@ -0,0 +1,10 @@
+--- src/xmlcopyeditor.h.orig Thu Dec 20 19:39:44 2007
++++ src/xmlcopyeditor.h Thu Dec 20 19:40:47 2007
+@@ -21,6 +21,7 @@
+ #define XMLCOPYEDITOR_H
+
+ #define NEWFINDREPLACE 1
++#define ICONV_CHAR_CAST(x) ((ICONV_CONST char **)(x))
+
+ #include <wx/wx.h>
+ #include <wx/fdrepdlg.h>
diff --git a/editors/xmlcopyeditor/files/pkg-message.in b/editors/xmlcopyeditor/files/pkg-message.in
new file mode 100644
index 000000000000..bb829a351842
--- /dev/null
+++ b/editors/xmlcopyeditor/files/pkg-message.in
@@ -0,0 +1,8 @@
+************************************************************************
+Note for XML docbook users:
+
+ 1) In Edit->Preferences menu change "Application directory" text box to
+ "%%LOCALBASE%%/share/xsl".
+
+ 2) Install textproc/docbook-xml port.
+************************************************************************
diff --git a/editors/xmlcopyeditor/pkg-descr b/editors/xmlcopyeditor/pkg-descr
new file mode 100644
index 000000000000..48ed5d7529cd
--- /dev/null
+++ b/editors/xmlcopyeditor/pkg-descr
@@ -0,0 +1,17 @@
+XML Copy Editor is a fast validating XML editor.
+
+Features:
+
+ * DTD/XML Schema/RELAX NG validation
+ * XSLT
+ * XPath
+ * Pretty-printing
+ * Syntax highlighting
+ * Folding
+ * Tag completion
+ * Tag locking
+ * Tag-free editing
+ * Spelling and style check
+ * Built-in support for XHTML, XSL, DocBook and TEI
+
+WWW: http://xml-copy-editor.sourceforge.net/
diff --git a/editors/xmlcopyeditor/pkg-plist b/editors/xmlcopyeditor/pkg-plist
new file mode 100644
index 000000000000..245b42e12367
--- /dev/null
+++ b/editors/xmlcopyeditor/pkg-plist
@@ -0,0 +1,231 @@
+bin/xmlcopyeditor
+%%DATADIR%%/copying/Expat/copying.txt
+%%DATADIR%%/copying/Scintilla/scintilla-lic.txt
+%%DATADIR%%/copying/boost_license_1_0.txt
+%%DATADIR%%/copying/boost_shared_ptr/copying.txt
+%%DATADIR%%/copying/libxml2/libxml2-lic.txt
+%%DATADIR%%/copying/libxslt/libxslt-lic.txt
+%%DATADIR%%/copying/mit.txt
+%%DATADIR%%/copying/scowl/copying.txt
+%%DATADIR%%/filters/OpenDocument.xml
+%%DATADIR%%/filters/WordprocessingML.xml
+%%DATADIR%%/filters/filter.xsd
+%%DATADIR%%/help/Table of Contents.hhc
+%%DATADIR%%/help/html/appendix.html
+%%DATADIR%%/help/html/association.html
+%%DATADIR%%/help/html/attribute_hiding.html
+%%DATADIR%%/help/html/completion.html
+%%DATADIR%%/help/html/creating_filters.html
+%%DATADIR%%/help/html/creating_rulesets.html
+%%DATADIR%%/help/html/default_rulesets.html
+%%DATADIR%%/help/html/editor.html
+%%DATADIR%%/help/html/features.html
+%%DATADIR%%/help/html/folding.html
+%%DATADIR%%/help/html/font_size.html
+%%DATADIR%%/help/html/general.html
+%%DATADIR%%/help/html/generic.css
+%%DATADIR%%/help/html/getting_started.html
+%%DATADIR%%/help/html/large_documents.html
+%%DATADIR%%/help/html/printing.html
+%%DATADIR%%/help/html/processing.html
+%%DATADIR%%/help/html/spelling.html
+%%DATADIR%%/help/html/spelling_intro.html
+%%DATADIR%%/help/html/syntax.html
+%%DATADIR%%/help/html/tag_locking.html
+%%DATADIR%%/help/html/templates.html
+%%DATADIR%%/help/html/validation.html
+%%DATADIR%%/help/html/word.html
+%%DATADIR%%/help/html/word_integration.html
+%%DATADIR%%/help/html/xml.html
+%%DATADIR%%/help/html/xmlcopyeditor.html
+%%DATADIR%%/help/xmlcopyeditor.chm
+%%DATADIR%%/help/xmlcopyeditor.hhp
+%%DATADIR%%/png/stock_calc-accept.png
+%%DATADIR%%/png/stock_close.png
+%%DATADIR%%/png/stock_copy-16.png
+%%DATADIR%%/png/stock_cut-16.png
+%%DATADIR%%/png/stock_dialog-info-32.png
+%%DATADIR%%/png/stock_dialog-question-32.png
+%%DATADIR%%/png/stock_dialog-stop-32.png
+%%DATADIR%%/png/stock_dialog-warning-32.png
+%%DATADIR%%/png/stock_filters.png
+%%DATADIR%%/png/stock_help-16.png
+%%DATADIR%%/png/stock_hyperlink.png
+%%DATADIR%%/png/stock_internet-16.png
+%%DATADIR%%/png/stock_internet.png
+%%DATADIR%%/png/stock_new-16.png
+%%DATADIR%%/png/stock_new.png
+%%DATADIR%%/png/stock_open-16.png
+%%DATADIR%%/png/stock_open.png
+%%DATADIR%%/png/stock_paste-16.png
+%%DATADIR%%/png/stock_print-16.png
+%%DATADIR%%/png/stock_print-preview-16.png
+%%DATADIR%%/png/stock_print.png
+%%DATADIR%%/png/stock_redo-16.png
+%%DATADIR%%/png/stock_redo.png
+%%DATADIR%%/png/stock_save-16.png
+%%DATADIR%%/png/stock_save.png
+%%DATADIR%%/png/stock_search-16.png
+%%DATADIR%%/png/stock_spellcheck-16.png
+%%DATADIR%%/png/stock_spellcheck.png
+%%DATADIR%%/png/stock_undo-16.png
+%%DATADIR%%/png/stock_undo.png
+%%DATADIR%%/po/de/messages.mo
+%%DATADIR%%/po/en_us/messages.po
+%%DATADIR%%/po/fr/messages.mo
+%%DATADIR%%/po/sk/messages.mo
+%%DATADIR%%/po/sv/messages.mo
+%%DATADIR%%/po/uk_UA/messages.mo
+%%DATADIR%%/po/zh_CN/messages.mo
+%%DATADIR%%/po/zh_TW/messages.mo
+%%DATADIR%%/rng/docbook.rnc
+%%DATADIR%%/rng/docbook.rng
+%%DATADIR%%/rng/docbookxi.rnc
+%%DATADIR%%/rng/docbookxi.rng
+%%DATADIR%%/rng/exclude/basic-table.rng
+%%DATADIR%%/rng/exclude/basic.rng
+%%DATADIR%%/rng/exclude/form.rng
+%%DATADIR%%/rng/modules/applet.rng
+%%DATADIR%%/rng/modules/attribs.rng
+%%DATADIR%%/rng/modules/base.rng
+%%DATADIR%%/rng/modules/basic-form.rng
+%%DATADIR%%/rng/modules/basic-table.rng
+%%DATADIR%%/rng/modules/bdo.rng
+%%DATADIR%%/rng/modules/csismap.rng
+%%DATADIR%%/rng/modules/datatypes.rng
+%%DATADIR%%/rng/modules/edit.rng
+%%DATADIR%%/rng/modules/events.rng
+%%DATADIR%%/rng/modules/form.rng
+%%DATADIR%%/rng/modules/frames.rng
+%%DATADIR%%/rng/modules/hypertext.rng
+%%DATADIR%%/rng/modules/iframe.rng
+%%DATADIR%%/rng/modules/image.rng
+%%DATADIR%%/rng/modules/inlstyle.rng
+%%DATADIR%%/rng/modules/legacy.rng
+%%DATADIR%%/rng/modules/link.rng
+%%DATADIR%%/rng/modules/list.rng
+%%DATADIR%%/rng/modules/meta.rng
+%%DATADIR%%/rng/modules/nameident.rng
+%%DATADIR%%/rng/modules/object.rng
+%%DATADIR%%/rng/modules/param.rng
+%%DATADIR%%/rng/modules/pres.rng
+%%DATADIR%%/rng/modules/ruby.rng
+%%DATADIR%%/rng/modules/script.rng
+%%DATADIR%%/rng/modules/ssismap.rng
+%%DATADIR%%/rng/modules/struct.rng
+%%DATADIR%%/rng/modules/style.rng
+%%DATADIR%%/rng/modules/table.rng
+%%DATADIR%%/rng/modules/target.rng
+%%DATADIR%%/rng/modules/text.rng
+%%DATADIR%%/rng/relaxng.rng
+%%DATADIR%%/rng/tei_all.rnc
+%%DATADIR%%/rng/tei_all.rng
+%%DATADIR%%/rng/tei_minimal.rnc
+%%DATADIR%%/rng/tei_minimal.rng
+%%DATADIR%%/rng/xhtml-strict.rng
+%%DATADIR%%/rng/xhtml.rng
+%%DATADIR%%/rng/xmlschema.rng
+%%DATADIR%%/rng/xslt.rng
+%%DATADIR%%/rulesets/American.xml
+%%DATADIR%%/rulesets/Commonwealth.xml
+%%DATADIR%%/rulesets/Contractions.xml
+%%DATADIR%%/rulesets/Default dictionary and style.xml
+%%DATADIR%%/rulesets/Default dictionary.xml
+%%DATADIR%%/rulesets/Default style.xml
+%%DATADIR%%/rulesets/Disability.xml
+%%DATADIR%%/rulesets/Diversity.xml
+%%DATADIR%%/rulesets/Ethnicity.xml
+%%DATADIR%%/rulesets/Gender.xml
+%%DATADIR%%/rulesets/Hyphenation.xml
+%%DATADIR%%/rulesets/Ise.xml
+%%DATADIR%%/rulesets/Ize and yse.xml
+%%DATADIR%%/rulesets/Ize.xml
+%%DATADIR%%/rulesets/Postcolonial.xml
+%%DATADIR%%/rulesets/Punctuation.xml
+%%DATADIR%%/rulesets/Query.xml
+%%DATADIR%%/rulesets/Religion.xml
+%%DATADIR%%/rulesets/Repetition.xml
+%%DATADIR%%/rulesets/White space.xml
+%%DATADIR%%/rulesets/ruleset.css
+%%DATADIR%%/rulesets/ruleset.ctm
+%%DATADIR%%/rulesets/ruleset.rld
+%%DATADIR%%/rulesets/ruleset.xsd
+%%DATADIR%%/templates/Custom rule set.xml
+%%DATADIR%%/templates/DITA Concept.xml
+%%DATADIR%%/templates/DITA Map.xml
+%%DATADIR%%/templates/DITA Task.xml
+%%DATADIR%%/templates/DITA Topic.xml
+%%DATADIR%%/templates/DTD.dtd
+%%DATADIR%%/templates/DocBook 4.4 article.xml
+%%DATADIR%%/templates/DocBook 4.4 book.xml
+%%DATADIR%%/templates/DocBook 5.0b article.xml
+%%DATADIR%%/templates/DocBook 5.0b book.xml
+%%DATADIR%%/templates/Moodle glossary.xml
+%%DATADIR%%/templates/Moodle quiz.xml
+%%DATADIR%%/templates/NewsML 1.2.xml
+%%DATADIR%%/templates/OpenLaszlo.lzx
+%%DATADIR%%/templates/OpenLearn document.xml
+%%DATADIR%%/templates/RELAX NG grammar.rng
+%%DATADIR%%/templates/RSS 2.0.rss
+%%DATADIR%%/templates/TEI document.xml
+%%DATADIR%%/templates/WordprocessingML document.xml
+%%DATADIR%%/templates/XHTML 1.0 Strict document.html
+%%DATADIR%%/templates/XLIFF document.xlf
+%%DATADIR%%/templates/XML Schema.xsd
+%%DATADIR%%/templates/XML Topic Map 1.0.xtm
+%%DATADIR%%/templates/XML Topic Map 2.0.xtm
+%%DATADIR%%/templates/XSL stylesheet.xsl
+%%DATADIR%%/xpm/appicon.xpm
+%%DATADIR%%/xpm/stock_copy_16.xpm
+%%DATADIR%%/xpm/stock_cut_16.xpm
+%%DATADIR%%/xpm/stock_help_16.xpm
+%%DATADIR%%/xpm/stock_hyperlink.xpm
+%%DATADIR%%/xpm/stock_internet.xpm
+%%DATADIR%%/xpm/stock_internet_16.xpm
+%%DATADIR%%/xpm/stock_new.xpm
+%%DATADIR%%/xpm/stock_new_16.xpm
+%%DATADIR%%/xpm/stock_open.xpm
+%%DATADIR%%/xpm/stock_open_16.xpm
+%%DATADIR%%/xpm/stock_paste_16.xpm
+%%DATADIR%%/xpm/stock_print-preview_16.xpm
+%%DATADIR%%/xpm/stock_print.xpm
+%%DATADIR%%/xpm/stock_print_16.xpm
+%%DATADIR%%/xpm/stock_print_preview_16.xpm
+%%DATADIR%%/xpm/stock_redo_16.xpm
+%%DATADIR%%/xpm/stock_save.xpm
+%%DATADIR%%/xpm/stock_save_16.xpm
+%%DATADIR%%/xpm/stock_search_16.xpm
+%%DATADIR%%/xpm/stock_spellcheck.xpm
+%%DATADIR%%/xpm/stock_spellcheck_16.xpm
+%%DATADIR%%/xpm/stock_undo_16.xpm
+share/pixmaps/xmlcopyeditor.png
+share/applications/xmlcopyeditor.desktop
+@dirrm %%DATADIR%%/xpm
+@dirrm %%DATADIR%%/templates
+@dirrm %%DATADIR%%/rulesets
+@dirrm %%DATADIR%%/rng/modules
+@dirrm %%DATADIR%%/rng/exclude
+@dirrm %%DATADIR%%/rng
+@dirrm %%DATADIR%%/po/zh_TW
+@dirrm %%DATADIR%%/po/zh_CN
+@dirrm %%DATADIR%%/po/uk_UA
+@dirrm %%DATADIR%%/po/sv
+@dirrm %%DATADIR%%/po/sk
+@dirrm %%DATADIR%%/po/fr
+@dirrm %%DATADIR%%/po/en_us
+@dirrm %%DATADIR%%/po/de
+@dirrm %%DATADIR%%/po
+@dirrm %%DATADIR%%/png
+@dirrm %%DATADIR%%/help/html
+@dirrm %%DATADIR%%/help
+@dirrm %%DATADIR%%/filters
+@dirrm %%DATADIR%%/copying/scowl
+@dirrm %%DATADIR%%/copying/libxslt
+@dirrm %%DATADIR%%/copying/libxml2
+@dirrm %%DATADIR%%/copying/boost_shared_ptr
+@dirrm %%DATADIR%%/copying/Scintilla
+@dirrm %%DATADIR%%/copying/Expat
+@dirrm %%DATADIR%%/copying
+@dirrm %%DATADIR%%
+@dirrmtry share/pixmaps
+@dirrmtry share/applications