aboutsummaryrefslogtreecommitdiff
path: root/editors
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1997-05-28 10:04:37 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1997-05-28 10:04:37 +0000
commit5ab6e335b7151f85fdcb587b507bfde47fdb44f3 (patch)
treef1d8ede5102864980440a7523f4891b1e34f468e /editors
parent61ca8e3285b924803b4c51487c8439a9f5892cab (diff)
downloadports-5ab6e335b7151f85fdcb587b507bfde47fdb44f3.tar.gz
ports-5ab6e335b7151f85fdcb587b507bfde47fdb44f3.zip
Notes
Diffstat (limited to 'editors')
-rw-r--r--editors/vim/Makefile4
-rw-r--r--editors/vim/distinfo2
-rw-r--r--editors/vim/files/patch-0258
-rw-r--r--editors/vim5/Makefile4
-rw-r--r--editors/vim5/distinfo2
-rw-r--r--editors/vim5/files/patch-0258
-rw-r--r--editors/vim6/Makefile4
-rw-r--r--editors/vim6/distinfo2
-rw-r--r--editors/vim6/files/patch-0258
9 files changed, 183 insertions, 9 deletions
diff --git a/editors/vim/Makefile b/editors/vim/Makefile
index 5169d230467b..6596d9a994f3 100644
--- a/editors/vim/Makefile
+++ b/editors/vim/Makefile
@@ -4,10 +4,10 @@
# Date created: Sat June 29, 1996
# Whom: David O'Brien (obrien@cs.ucdavis.edu)
#
-# $Id: Makefile,v 1.7 1997/03/27 05:42:13 obrien Exp $
+# $Id: Makefile,v 1.1.1.1 1997/05/25 02:59:06 obrien Exp $
#
-DISTNAME= vim-5.0h
+DISTNAME= vim-5.0i
CATEGORIES= editors
MASTER_SITES= ftp://nuxi.ucdavis.edu/pub/vim/beta-test/unix/ \
ftp://ftp.nuxi.com/pub/vim/beta-test/unix/ \
diff --git a/editors/vim/distinfo b/editors/vim/distinfo
index b6b58540a68d..cf29563571be 100644
--- a/editors/vim/distinfo
+++ b/editors/vim/distinfo
@@ -1 +1 @@
-MD5 (vim-5.0h.tar.gz) = 2c0cd382c33041f55760b93ef5392e3b
+MD5 (vim-5.0i.tar.gz) = 86e4d31d2513291a2344938a08ef8414
diff --git a/editors/vim/files/patch-02 b/editors/vim/files/patch-02
new file mode 100644
index 000000000000..e49fa2894977
--- /dev/null
+++ b/editors/vim/files/patch-02
@@ -0,0 +1,58 @@
+--- configure.orig Mon May 26 14:22:58 1997
++++ configure Wed May 28 02:51:36 1997
+@@ -2424,16 +2424,16 @@
+ fi
+ rm -f conftest*
+
+-ac_safe=`echo "elf.h" | sed 'y%./+-%__p_%'`
+-echo $ac_n "checking for elf.h""... $ac_c" 1>&6
+-echo "configure:2430: checking for elf.h" >&5
++ac_safe=`echo "DONT_DO_IT_elf.h" | sed 'y%./+-%__p_%'`
++echo $ac_n "checking for DONT_DO_IT_elf.h""... $ac_c" 1>&6
++echo "configure:2430: checking for DONT_DO_IT_elf.h" >&5
+ if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ cat > conftest.$ac_ext <<EOF
+ #line 2435 "configure"
+ #include "confdefs.h"
+-#include <elf.h>
++#include <DONT_DO_IT_elf.h>
+ EOF
+ ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
+ { (eval echo configure:2440: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+@@ -2460,14 +2460,14 @@
+ if test "$SVR4" = 1; then cat >> confdefs.h <<\EOF
+ #define SVR4 1
+ EOF
+- echo $ac_n "checking for main in -lelf""... $ac_c" 1>&6
+-echo "configure:2465: checking for main in -lelf" >&5
+-ac_lib_var=`echo elf'_'main | sed 'y%./+-%__p_%'`
++ echo $ac_n "checking for main in -lDONT_DO_IT_elf""... $ac_c" 1>&6
++echo "configure:2465: checking for main in -lDONT_DO_IT_elf" >&5
++ac_lib_var=`echo DONT_DO_IT_elf'_'main | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lelf $LIBS"
++LIBS="-lDONT_DO_IT_elf $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 2473 "configure"
+ #include "confdefs.h"
+@@ -2491,13 +2491,13 @@
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+- ac_tr_lib=HAVE_LIB`echo elf | sed -e 's/[^a-zA-Z0-9_]/_/g' \
++ ac_tr_lib=HAVE_LIB`echo DONT_DO_IT_elf | sed -e 's/[^a-zA-Z0-9_]/_/g' \
+ -e 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
+ cat >> confdefs.h <<EOF
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lelf $LIBS"
++ LIBS="-lDONT_DO_IT_elf $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
diff --git a/editors/vim5/Makefile b/editors/vim5/Makefile
index 5169d230467b..6596d9a994f3 100644
--- a/editors/vim5/Makefile
+++ b/editors/vim5/Makefile
@@ -4,10 +4,10 @@
# Date created: Sat June 29, 1996
# Whom: David O'Brien (obrien@cs.ucdavis.edu)
#
-# $Id: Makefile,v 1.7 1997/03/27 05:42:13 obrien Exp $
+# $Id: Makefile,v 1.1.1.1 1997/05/25 02:59:06 obrien Exp $
#
-DISTNAME= vim-5.0h
+DISTNAME= vim-5.0i
CATEGORIES= editors
MASTER_SITES= ftp://nuxi.ucdavis.edu/pub/vim/beta-test/unix/ \
ftp://ftp.nuxi.com/pub/vim/beta-test/unix/ \
diff --git a/editors/vim5/distinfo b/editors/vim5/distinfo
index b6b58540a68d..cf29563571be 100644
--- a/editors/vim5/distinfo
+++ b/editors/vim5/distinfo
@@ -1 +1 @@
-MD5 (vim-5.0h.tar.gz) = 2c0cd382c33041f55760b93ef5392e3b
+MD5 (vim-5.0i.tar.gz) = 86e4d31d2513291a2344938a08ef8414
diff --git a/editors/vim5/files/patch-02 b/editors/vim5/files/patch-02
new file mode 100644
index 000000000000..e49fa2894977
--- /dev/null
+++ b/editors/vim5/files/patch-02
@@ -0,0 +1,58 @@
+--- configure.orig Mon May 26 14:22:58 1997
++++ configure Wed May 28 02:51:36 1997
+@@ -2424,16 +2424,16 @@
+ fi
+ rm -f conftest*
+
+-ac_safe=`echo "elf.h" | sed 'y%./+-%__p_%'`
+-echo $ac_n "checking for elf.h""... $ac_c" 1>&6
+-echo "configure:2430: checking for elf.h" >&5
++ac_safe=`echo "DONT_DO_IT_elf.h" | sed 'y%./+-%__p_%'`
++echo $ac_n "checking for DONT_DO_IT_elf.h""... $ac_c" 1>&6
++echo "configure:2430: checking for DONT_DO_IT_elf.h" >&5
+ if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ cat > conftest.$ac_ext <<EOF
+ #line 2435 "configure"
+ #include "confdefs.h"
+-#include <elf.h>
++#include <DONT_DO_IT_elf.h>
+ EOF
+ ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
+ { (eval echo configure:2440: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+@@ -2460,14 +2460,14 @@
+ if test "$SVR4" = 1; then cat >> confdefs.h <<\EOF
+ #define SVR4 1
+ EOF
+- echo $ac_n "checking for main in -lelf""... $ac_c" 1>&6
+-echo "configure:2465: checking for main in -lelf" >&5
+-ac_lib_var=`echo elf'_'main | sed 'y%./+-%__p_%'`
++ echo $ac_n "checking for main in -lDONT_DO_IT_elf""... $ac_c" 1>&6
++echo "configure:2465: checking for main in -lDONT_DO_IT_elf" >&5
++ac_lib_var=`echo DONT_DO_IT_elf'_'main | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lelf $LIBS"
++LIBS="-lDONT_DO_IT_elf $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 2473 "configure"
+ #include "confdefs.h"
+@@ -2491,13 +2491,13 @@
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+- ac_tr_lib=HAVE_LIB`echo elf | sed -e 's/[^a-zA-Z0-9_]/_/g' \
++ ac_tr_lib=HAVE_LIB`echo DONT_DO_IT_elf | sed -e 's/[^a-zA-Z0-9_]/_/g' \
+ -e 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
+ cat >> confdefs.h <<EOF
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lelf $LIBS"
++ LIBS="-lDONT_DO_IT_elf $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
diff --git a/editors/vim6/Makefile b/editors/vim6/Makefile
index 5169d230467b..6596d9a994f3 100644
--- a/editors/vim6/Makefile
+++ b/editors/vim6/Makefile
@@ -4,10 +4,10 @@
# Date created: Sat June 29, 1996
# Whom: David O'Brien (obrien@cs.ucdavis.edu)
#
-# $Id: Makefile,v 1.7 1997/03/27 05:42:13 obrien Exp $
+# $Id: Makefile,v 1.1.1.1 1997/05/25 02:59:06 obrien Exp $
#
-DISTNAME= vim-5.0h
+DISTNAME= vim-5.0i
CATEGORIES= editors
MASTER_SITES= ftp://nuxi.ucdavis.edu/pub/vim/beta-test/unix/ \
ftp://ftp.nuxi.com/pub/vim/beta-test/unix/ \
diff --git a/editors/vim6/distinfo b/editors/vim6/distinfo
index b6b58540a68d..cf29563571be 100644
--- a/editors/vim6/distinfo
+++ b/editors/vim6/distinfo
@@ -1 +1 @@
-MD5 (vim-5.0h.tar.gz) = 2c0cd382c33041f55760b93ef5392e3b
+MD5 (vim-5.0i.tar.gz) = 86e4d31d2513291a2344938a08ef8414
diff --git a/editors/vim6/files/patch-02 b/editors/vim6/files/patch-02
new file mode 100644
index 000000000000..e49fa2894977
--- /dev/null
+++ b/editors/vim6/files/patch-02
@@ -0,0 +1,58 @@
+--- configure.orig Mon May 26 14:22:58 1997
++++ configure Wed May 28 02:51:36 1997
+@@ -2424,16 +2424,16 @@
+ fi
+ rm -f conftest*
+
+-ac_safe=`echo "elf.h" | sed 'y%./+-%__p_%'`
+-echo $ac_n "checking for elf.h""... $ac_c" 1>&6
+-echo "configure:2430: checking for elf.h" >&5
++ac_safe=`echo "DONT_DO_IT_elf.h" | sed 'y%./+-%__p_%'`
++echo $ac_n "checking for DONT_DO_IT_elf.h""... $ac_c" 1>&6
++echo "configure:2430: checking for DONT_DO_IT_elf.h" >&5
+ if eval "test \"`echo '$''{'ac_cv_header_$ac_safe'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ cat > conftest.$ac_ext <<EOF
+ #line 2435 "configure"
+ #include "confdefs.h"
+-#include <elf.h>
++#include <DONT_DO_IT_elf.h>
+ EOF
+ ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
+ { (eval echo configure:2440: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
+@@ -2460,14 +2460,14 @@
+ if test "$SVR4" = 1; then cat >> confdefs.h <<\EOF
+ #define SVR4 1
+ EOF
+- echo $ac_n "checking for main in -lelf""... $ac_c" 1>&6
+-echo "configure:2465: checking for main in -lelf" >&5
+-ac_lib_var=`echo elf'_'main | sed 'y%./+-%__p_%'`
++ echo $ac_n "checking for main in -lDONT_DO_IT_elf""... $ac_c" 1>&6
++echo "configure:2465: checking for main in -lDONT_DO_IT_elf" >&5
++ac_lib_var=`echo DONT_DO_IT_elf'_'main | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lelf $LIBS"
++LIBS="-lDONT_DO_IT_elf $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 2473 "configure"
+ #include "confdefs.h"
+@@ -2491,13 +2491,13 @@
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+- ac_tr_lib=HAVE_LIB`echo elf | sed -e 's/[^a-zA-Z0-9_]/_/g' \
++ ac_tr_lib=HAVE_LIB`echo DONT_DO_IT_elf | sed -e 's/[^a-zA-Z0-9_]/_/g' \
+ -e 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
+ cat >> confdefs.h <<EOF
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lelf $LIBS"
++ LIBS="-lDONT_DO_IT_elf $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6