aboutsummaryrefslogtreecommitdiff
path: root/emulators/advancemame
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2016-01-16 18:37:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2016-01-16 18:37:32 +0000
commite9be9e8b255bd1e3141d11559dd4e3b40dd66e5c (patch)
treec77d286a60b8dd0ae2336dee3fb08e604a69a1b9 /emulators/advancemame
parentfd906780724ca03a67bfb4677868efa5349c734d (diff)
downloadports-e9be9e8b255bd1e3141d11559dd4e3b40dd66e5c.tar.gz
ports-e9be9e8b255bd1e3141d11559dd4e3b40dd66e5c.zip
Notes
Diffstat (limited to 'emulators/advancemame')
-rw-r--r--emulators/advancemame/Makefile64
-rw-r--r--emulators/advancemame/distinfo4
-rw-r--r--emulators/advancemame/pkg-descr30
-rw-r--r--emulators/advancemame/pkg-plist23
4 files changed, 65 insertions, 56 deletions
diff --git a/emulators/advancemame/Makefile b/emulators/advancemame/Makefile
index 0fcc65d8f130..80f72d920378 100644
--- a/emulators/advancemame/Makefile
+++ b/emulators/advancemame/Makefile
@@ -2,67 +2,69 @@
# $FreeBSD$
PORTNAME= advancemame
-PORTVERSION= 1.2
-PORTREVISION= 3
+PORTVERSION= 1.4
CATEGORIES= emulators
-MASTER_SITES= SF
+MASTER_SITES= https://github.com/amadvance/advancemame/releases/download/${DISTNAME}/
MAINTAINER= ports@FreeBSD.org
COMMENT= SDL MAME port with advanced TV and monitor video support
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
+USES= gmake ncurses
USE_SDL= sdl
-USES= gmake
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-asm --disable-svgalib --disable-fb \
- --disable-alsa --enable-oss --disable-slang \
- --disable-ncurses --disable-kevent
-
-DATADIR= ${PREFIX}/share/advance
+CONFIGURE_ARGS= --disable-svgalib --disable-fb --disable-alsa --enable-oss \
+ --disable-kevent
CFLAGS+= -idirafter ${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN_FILES= advdev.1 advj.1 advk.1 advm.1 advmame.1 advs.1
-PORTDOCS= *
+DOCSDIR= ${PREFIX}/share/doc/advance
+DATADIR= ${PREFIX}/share/advance
-MAKE_JOBS_UNSAFE= yes
+PORTDOCS= *
-OPTIONS_DEFINE= FREETYPE DOCS
-OPTIONS_DEFAULT=FREETYPE
+OPTIONS_DEFINE= DOCS FREETYPE SLANG
+OPTIONS_DEFINE_i386= ASM
+OPTIONS_DEFAULT= FREETYPE
+OPTIONS_DEFAULT_i386= ASM
+ASM_BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
+ASM_USE= gcc=any
+ASM_CONFIGURE_ENABLE= asm
+FREETYPE_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
FREETYPE_CONFIGURE_ENABLE= freetype
-FREETYPE_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
+SLANG_LIB_DEPENDS= libslang.so:${PORTSDIR}/devel/libslang2
+SLANG_CONFIGURE_ENABLE= slang
+SLANG_LDFLAGS= -lncurses
post-patch:
@${REINPLACE_CMD} -e \
- 's|-lpthread|-pthread|' ${WRKSRC}/configure
+ 's|-lpthread|-pthread| ; \
+ /prefix/s|^\(docdir\)|#\1| ; \
+ /prefix/s|^\(mandir\)|#\1|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
- 's|@@|@|' ${WRKSRC}/Makefile.in
+ 's|@@|@| ; \
+ /^INSTALL_PROGRAM /s|=.*|= @INSTALL_PROGRAM@| ; \
+ /^INSTALL_MAN /s|=.*|= @INSTALL_MAN@| ; \
+ /^INSTALL_DATA /s|=.*|= @INSTALL_DATA@|' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
- '/\(pkgdocdir\)/s|^|#| ; \
+ 's|\([[:space:]]\)\($$(bindir)\)|\1$$(DESTDIR)\2| ; \
+ s|\([[:space:]]\)\($$(pkgdir)\)|\1$$(DESTDIR)\2| ; \
+ s|\([[:space:]]\)\($$(pkgdocdir)\)|\1$$(DESTDIR)\2| ; \
+ s|\([[:space:]]\)\($$(mandir)\)|\1$$(DESTDIR)\2| ; \
/WHOLE_CFLAGS_OPT/s|-O2|| ; \
/WHOLE_LDFLAGS/s|-s||' ${WRKSRC}/advance/advance.mak
@${REINPLACE_CMD} -e \
's|-lpthread|-pthread|' ${WRKSRC}/advance/emu.mak
-do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} advj advk advm advmame advs \
- ${STAGEDIR}${PREFIX}/bin)
- (cd ${WRKSRC}/doc && ${INSTALL_MAN} ${MAN_FILES} \
- ${STAGEDIR}${MANPREFIX}/man/man1)
- @${MKDIR} ${STAGEDIR}${DATADIR}
- (cd ${WRKSRC}/support && ${INSTALL_DATA} *.dat ${STAGEDIR}${DATADIR})
-.for i in artwork diff image rom sample snap
- @${MKDIR} ${STAGEDIR}${DATADIR}/${i}
- @${ECHO_CMD} -n > ${STAGEDIR}${DATADIR}/${i}/.keep_me
-.endfor
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} HISTORY README RELEASE \
${STAGEDIR}${DOCSDIR})
- (cd ${WRKSRC}/doc && ${INSTALL_DATA} *.[ht]* ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
diff --git a/emulators/advancemame/distinfo b/emulators/advancemame/distinfo
index 4bbcfd23aefe..9215928d384c 100644
--- a/emulators/advancemame/distinfo
+++ b/emulators/advancemame/distinfo
@@ -1,2 +1,2 @@
-SHA256 (advancemame-1.2.tar.gz) = eaf46e54f0cb5fa1d99f55604a4a3f8a065c1cf5e70ac4abc67391b0450ce439
-SIZE (advancemame-1.2.tar.gz) = 17508670
+SHA256 (advancemame-1.4.tar.gz) = 525e0897cd41fe8d3ef563e59592da740ebe005eda0948515dca410d01624bcc
+SIZE (advancemame-1.4.tar.gz) = 18463736
diff --git a/emulators/advancemame/pkg-descr b/emulators/advancemame/pkg-descr
index 4a03e51cf5ac..2f1504637c14 100644
--- a/emulators/advancemame/pkg-descr
+++ b/emulators/advancemame/pkg-descr
@@ -1,22 +1,22 @@
-AdvanceMAME and AdvanceMESS are unofficial MAME and MESS versions with an
-advanced video support for helping the use with TVs, Arcade Monitors, Fixed
-Frequencies Monitors and also for PC Monitors.
+AdvanceMAME and AdvanceMESS are unofficial MAME and MESS versions with
+an advanced video support for helping the use with TVs, Arcade Monitors,
+Fixed Frequencies Monitors and also for PC Monitors.
-They run in GNU/Linux, Mac OS X, DOS, Windows and in all the other platforms
-supported by the SDL library.
+They run in GNU/Linux, Mac OS X, DOS, Windows and in all the other
+platforms supported by the SDL library.
-The main difference compared with the official emulators is that the Advance
-versions are able to program directly the video board to always get a video
-mode with the correct size and frequency.
+The main difference compared with the official emulators is that the
+Advance versions are able to program directly the video board to always
+get a video mode with the correct size and frequency.
-Generally the Advance emulators are able to use a video mode which doesn't
-require any stretching or other unneeded effects to match the original arcade
-display.
+Generally the Advance emulators are able to use a video mode which
+doesn't require any stretching or other unneeded effects to match the
+original arcade display.
-The direct video board programming is fully supported in Linux and DOS. It's
-partially supported in Windows. It isn't supported in Mac OS X and other
-platforms.
+The direct video board programming is fully supported in Linux and DOS.
+It's partially supported in Windows. It isn't supported in Mac OS X and
+other platforms.
See website for other improvements.
-WWW: http://advancemame.sourceforge.net/
+WWW: http://www.advancemame.it/
diff --git a/emulators/advancemame/pkg-plist b/emulators/advancemame/pkg-plist
index 1830a4510285..9dcd1d622e71 100644
--- a/emulators/advancemame/pkg-plist
+++ b/emulators/advancemame/pkg-plist
@@ -1,4 +1,4 @@
-bin/advj
+bin/advj
bin/advk
bin/advm
bin/advmame
@@ -9,12 +9,19 @@ man/man1/advk.1.gz
man/man1/advm.1.gz
man/man1/advmame.1.gz
man/man1/advs.1.gz
-%%DATADIR%%/artwork/.keep_me
-%%DATADIR%%/diff/.keep_me
%%DATADIR%%/event.dat
-%%DATADIR%%/history.dat
%%DATADIR%%/hiscore.dat
-%%DATADIR%%/image/.keep_me
-%%DATADIR%%/rom/.keep_me
-%%DATADIR%%/sample/.keep_me
-%%DATADIR%%/snap/.keep_me
+%%DATADIR%%/history.dat
+%%DATADIR%%/rom/gridlee.zip
+%%DATADIR%%/rom/polyplay.zip
+%%DATADIR%%/rom/robby.zip
+%%DATADIR%%/sample/gridlee.zip
+%%DATADIR%%/snap/gridlee.zip
+%%DATADIR%%/snap/polyplay.zip
+%%DATADIR%%/snap/robby.zip
+@dir %%DATADIR%%/snap
+@dir %%DATADIR%%/sample
+@dir %%DATADIR%%/rom
+@dir %%DATADIR%%/image
+@dir %%DATADIR%%/crc
+@dir %%DATADIR%%/artwork