aboutsummaryrefslogtreecommitdiff
path: root/emulators/aranym/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-03-04 18:42:52 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-03-04 18:42:52 +0000
commit67a30d798979bea36f88f2cc7929636b4e7ad43d (patch)
tree15b7c4dfa137c5398f7264a798800ea45599f5a0 /emulators/aranym/Makefile
parent3cdf1c6b8c5f96adbfc7138499d579847dd090a6 (diff)
downloadports-67a30d798979bea36f88f2cc7929636b4e7ad43d.tar.gz
ports-67a30d798979bea36f88f2cc7929636b4e7ad43d.zip
Notes
Diffstat (limited to 'emulators/aranym/Makefile')
-rw-r--r--emulators/aranym/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/emulators/aranym/Makefile b/emulators/aranym/Makefile
new file mode 100644
index 000000000000..b7900f253d47
--- /dev/null
+++ b/emulators/aranym/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= aranym
+DISTVERSION= 1.1.0
+CATEGORIES= emulators
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}/
+DISTNAME= ${PORTNAME}_${DISTVERSION}.orig
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Atari Running on Any Machine
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= openjpeg>0:graphics/openjpeg \
+ sdl-config:devel/sdl12
+RUN_DEPENDS= bash:shells/bash
+
+USES= gmake perl5 pkgconfig gl localbase:ldflags sdl shebangfix xorg
+USE_GL= gl
+USE_SDL= sdl2 image2
+USE_XORG= x11
+
+SHEBANG_FILES= tools/arabridge
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= -disable-nat-debug --disable-nat-debug --enable-nfjpeg
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+
+.include <bsd.port.mk>