aboutsummaryrefslogtreecommitdiff
path: root/emulators/basiliskII
diff options
context:
space:
mode:
authorVasil Dimov <vd@FreeBSD.org>2006-12-04 16:28:35 +0000
committerVasil Dimov <vd@FreeBSD.org>2006-12-04 16:28:35 +0000
commit55b20f3ee8e844808f3c25b680554d9d62243b59 (patch)
tree2eba2cc57ac72c04c71f09e21b6e794f040f9d12 /emulators/basiliskII
parenta7b262b5a09de4504aeb1129770a3e02cf17c9fa (diff)
downloadports-55b20f3ee8e844808f3c25b680554d9d62243b59.tar.gz
ports-55b20f3ee8e844808f3c25b680554d9d62243b59.zip
Notes
Diffstat (limited to 'emulators/basiliskII')
-rw-r--r--emulators/basiliskII/Makefile49
-rw-r--r--emulators/basiliskII/distinfo3
-rw-r--r--emulators/basiliskII/pkg-descr4
-rw-r--r--emulators/basiliskII/pkg-message8
-rw-r--r--emulators/basiliskII/pkg-plist5
5 files changed, 69 insertions, 0 deletions
diff --git a/emulators/basiliskII/Makefile b/emulators/basiliskII/Makefile
new file mode 100644
index 000000000000..3c1ba52b5b28
--- /dev/null
+++ b/emulators/basiliskII/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: BasiliskII
+# Date created: 17 April 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= basiliskII
+PORTVERSION= 1.0
+PORTREVISION= 3
+CATEGORIES= emulators
+MASTER_SITES= http://www.gibix.net/projects/basilisk2/files/
+MASTER_SITE_SUBDIR= basilisk
+DISTNAME= BasiliskII_src_01052006
+
+MAINTAINER= mmendez@energyhq.be
+COMMENT= A free, portable, Open Source 68k Mac emulator
+
+BROKEN= Does not compile
+DEPRECATED= ${BROKEN}
+EXPIRATION_DATE=2006-12-01
+
+WRKSRC= ${WRKDIR}/BasiliskII-${PORTVERSION}/src/Unix
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_GNOME= esound gtk20
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS= --disable-fbdev-dga --enable-fpe=uae
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+MAN1= BasiliskII.1
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 400012
+CFLAGS+= -fpermissive
+.endif
+
+.if ${ARCH} == amd64
+BROKEN= does not compile on AMD64 architectures
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/emulators/basiliskII/distinfo b/emulators/basiliskII/distinfo
new file mode 100644
index 000000000000..9f8c36c099c7
--- /dev/null
+++ b/emulators/basiliskII/distinfo
@@ -0,0 +1,3 @@
+MD5 (BasiliskII_src_01052006.tar.bz2) = dfe9e088649133485bae28a713979481
+SHA256 (BasiliskII_src_01052006.tar.bz2) = 6782f2ed3587d7790557a0994f5b7472d7a27ded0f1598b9380efabde16bd3cc
+SIZE (BasiliskII_src_01052006.tar.bz2) = 1310908
diff --git a/emulators/basiliskII/pkg-descr b/emulators/basiliskII/pkg-descr
new file mode 100644
index 000000000000..f3ebb4e742c2
--- /dev/null
+++ b/emulators/basiliskII/pkg-descr
@@ -0,0 +1,4 @@
+Basilisk II is a free, portable, Open Source 68k Mac emulator. It requires a
+copy of a 512K or 1MB Mac ROM and a copy of MacOS 7.x or 8.x to run.
+
+WWW: http://www.gibix.net/projects/basilisk2/
diff --git a/emulators/basiliskII/pkg-message b/emulators/basiliskII/pkg-message
new file mode 100644
index 000000000000..12929c1e3aad
--- /dev/null
+++ b/emulators/basiliskII/pkg-message
@@ -0,0 +1,8 @@
+********************************************************************************
+
+ NOTE: You have to get a copy of the original Mac ROM image and a copy of MacOS
+ to run BasiliskII. Be aware that the only legal way to get ROM image is
+ to rip it out from your Mac computer. See BasiliskII home page to get
+ details.
+
+********************************************************************************
diff --git a/emulators/basiliskII/pkg-plist b/emulators/basiliskII/pkg-plist
new file mode 100644
index 000000000000..95dfd91b2370
--- /dev/null
+++ b/emulators/basiliskII/pkg-plist
@@ -0,0 +1,5 @@
+bin/BasiliskII
+share/BasiliskII/fbdevices
+share/BasiliskII/keycodes
+share/BasiliskII/tunconfig
+@dirrm share/BasiliskII