aboutsummaryrefslogtreecommitdiff
path: root/emulators/bochs
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-06-09 00:20:37 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-06-09 00:20:37 +0000
commit48b8ff83f465db3c431247e99f75ce5eb734846d (patch)
tree170db4e901459c928d1f4f80fc335035a71d30e3 /emulators/bochs
parented218409bd6270c07ac97ed5bab709341fb1061e (diff)
downloadports-48b8ff83f465db3c431247e99f75ce5eb734846d.tar.gz
ports-48b8ff83f465db3c431247e99f75ce5eb734846d.zip
Notes
Diffstat (limited to 'emulators/bochs')
-rw-r--r--emulators/bochs/Makefile6
-rw-r--r--emulators/bochs/distinfo2
-rw-r--r--emulators/bochs/files/patch-aa21
-rw-r--r--emulators/bochs/files/patch-ac13
-rw-r--r--emulators/bochs/files/patch-ad86
-rw-r--r--emulators/bochs/pkg-plist7
6 files changed, 25 insertions, 110 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 75ac5c293f1e..5ba8e287306e 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= bochs
-PORTVERSION= 1.1.2
+PORTVERSION= 1.2
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
@@ -19,7 +19,8 @@ MAINTAINER= clefevre@poboxes.com
USE_XLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-cpu-level=5 \
- --enable-cdrom
+ --enable-cdrom \
+ --disable-split-hd
CFLAGS+= -fno-rtti -fno-exceptions -fomit-frame-pointer
PKGMESSAGE= ${WRKDIR}/pkg-message
@@ -47,6 +48,7 @@ post-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bochs ${PREFIX}/bin/bochs-bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/bximage ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKDIR}/bochs.sh ${PREFIX}/bin/bochs
@${MKDIR} ${PREFIX}/share/bochs
${INSTALL_DATA} ${WRKSRC}/.bochsrc ${PREFIX}/share/bochs/dot.bochsrc
diff --git a/emulators/bochs/distinfo b/emulators/bochs/distinfo
index fd992b5f01ba..b4c4836adba2 100644
--- a/emulators/bochs/distinfo
+++ b/emulators/bochs/distinfo
@@ -1 +1 @@
-MD5 (bochs-1.1.2.tar.gz) = 3790082c1736aac66b3b25a95ba78891
+MD5 (bochs-1.2.tar.gz) = fab61c23bc2b2679da8541eee2222f14
diff --git a/emulators/bochs/files/patch-aa b/emulators/bochs/files/patch-aa
index 259f893cb9c7..5de74feaf15d 100644
--- a/emulators/bochs/files/patch-aa
+++ b/emulators/bochs/files/patch-aa
@@ -1,9 +1,16 @@
---- .bochsrc.orig Sun Nov 14 16:01:27 1999
-+++ .bochsrc Mon Nov 22 17:44:06 1999
-@@ -84,4 +84,4 @@
-
+
+$FreeBSD$
+
+--- .bochsrc.orig Thu May 31 22:55:33 2001
++++ .bochsrc Mon Jun 4 10:24:44 2001
+@@ -116,8 +116,8 @@
+ # log: ./bochs.out
+ # log: /dev/tty
+ #=======================================================================
-#log: /dev/null
--log: ./bochs.out
+-log: bochsout.txt
+log: /dev/null
-+#log: ./bochs.out
- keyboard_serial_delay: 200
++#log: bochsout.txt
+
+ #=======================================================================
+ # LOG CONTROLS
diff --git a/emulators/bochs/files/patch-ac b/emulators/bochs/files/patch-ac
deleted file mode 100644
index 90b82bbf2ab3..000000000000
--- a/emulators/bochs/files/patch-ac
+++ /dev/null
@@ -1,13 +0,0 @@
---- iodev/serial.cc.orig Thu Nov 11 21:44:52 1999
-+++ iodev/serial.cc Fri Jan 14 00:59:57 2000
-@@ -75,8 +75,8 @@
- term_new.c_iflag |= IGNBRK;
- term_new.c_iflag &= ~BRKINT;
- #endif
-- term_new.c_iflag |= IXOFF;
-- tcsetattr(0, TCSAFLUSH, &term_new);
-+ // term_new.c_iflag |= IXOFF;
-+ // tcsetattr(0, TCSAFLUSH, &term_new);
- #endif
- // nothing for now
- #if USE_RAW_SERIAL
diff --git a/emulators/bochs/files/patch-ad b/emulators/bochs/files/patch-ad
deleted file mode 100644
index 1c524980b9b5..000000000000
--- a/emulators/bochs/files/patch-ad
+++ /dev/null
@@ -1,86 +0,0 @@
-
-$FreeBSD$
-
---- iodev/cdrom.cc.orig Wed May 16 09:46:26 2001
-+++ iodev/cdrom.cc Wed May 30 01:56:06 2001
-@@ -50,7 +50,7 @@
- }
- #endif /* __sun */
-
--#ifdef __OpenBSD__
-+#if (defined(__OpenBSD__) || defined(__FreeBSD__))
- // OpenBSD pre version 2.7 may require extern "C" { } structure around
- // all the includes, because the i386 sys/disklabel.h contains code which
- // c++ considers invalid.
-@@ -148,7 +148,7 @@
- // some ioctl() calls to really eject the CD as well.
-
- if (fd >= 0) {
--#ifdef __OpenBSD__
-+#if (defined(__OpenBSD__) || defined(__FreeBSD__))
- (void) ioctl (fd, CDIOCALLOW);
- if (ioctl (fd, CDIOCEJECT) < 0)
- fprintf(stderr, "#eject_cdrom: eject returns error.\n");
-@@ -258,7 +258,7 @@
-
- return true;
- }
--#elif defined(__OpenBSD__)
-+#elif (defined(__OpenBSD__) || defined(__FreeBSD__))
- {
- struct ioc_toc_header h;
- struct ioc_read_toc_entry t;
-@@ -396,6 +396,53 @@
-
- fprintf(stderr, "#cdrom: capacity: %u\n", lp.d_secperunit);
- return(lp.d_secperunit);
-+ }
-+#elif defined(__FreeBSD__)
-+ {
-+ // Read the TOC to get the data size, since disklabel doesn't appear
-+ // to work, sadly.
-+ // Keith Jones, 16 January 2000
-+
-+#define MAX_TRACKS 100
-+
-+ int i, num_tracks, num_sectors;
-+ struct ioc_toc_header td;
-+ struct ioc_read_toc_entry rte;
-+ struct cd_toc_entry toc_buffer[MAX_TRACKS + 1];
-+
-+ if (fd < 0)
-+ bx_panic("cdrom: capacity: file not open.\n");
-+
-+ if (ioctl(fd, CDIOREADTOCHEADER, &td) < 0)
-+ bx_panic("cdrom: ioctl(CDIOREADTOCHEADER) failed\n");
-+
-+ num_tracks = (td.ending_track - td.starting_track) + 1;
-+ if (num_tracks > MAX_TRACKS)
-+ bx_panic("cdrom: TOC is too large\n");
-+
-+ rte.address_format = CD_LBA_FORMAT;
-+ rte.starting_track = td.starting_track;
-+ rte.data_len = (num_tracks + 1) * sizeof(struct cd_toc_entry);
-+ rte.data = toc_buffer;
-+ if (ioctl(fd, CDIOREADTOCENTRYS, &rte) < 0)
-+ bx_panic("cdrom: ioctl(CDIOREADTOCENTRYS) failed\n");
-+
-+ num_sectors = -1;
-+ for (i = 0; i < num_tracks; i++) {
-+ if (rte.data[i].control & 4) { /* data track */
-+ num_sectors = ntohl(rte.data[i + 1].addr.lba)
-+ - ntohl(rte.data[i].addr.lba);
-+ fprintf(stderr, "cdrom: Data track %d, length %d\n",
-+ rte.data[i].track, num_sectors);
-+ break;
-+ }
-+ }
-+
-+ if (num_sectors < 0)
-+ bx_panic("cdrom: no data track found\n");
-+
-+ return(num_sectors);
-+
- }
- #elif defined WIN32
- {
diff --git a/emulators/bochs/pkg-plist b/emulators/bochs/pkg-plist
index 980ecfab75c6..c2d745957abf 100644
--- a/emulators/bochs/pkg-plist
+++ b/emulators/bochs/pkg-plist
@@ -1,6 +1,9 @@
bin/bochs
bin/bochs-bin
-share/bochs/bios/BIOS-bochs-990925a
+bin/bximage
+share/bochs/bios/BIOS-bochs-2-processors
+share/bochs/bios/BIOS-bochs-4-processors
+share/bochs/bios/BIOS-bochs-latest
share/bochs/bios/VGABIOS-elpin-2.40
share/bochs/bios/VGABIOS-elpin-LICENSE
share/bochs/dot.bochsrc
@@ -30,6 +33,8 @@ share/bochs/font/vga.pcf.gz
%%PORTDOCS%%share/doc/bochs/instrumentation.html
%%PORTDOCS%%share/doc/bochs/mtools.html
%%PORTDOCS%%share/doc/bochs/random.txt
+%%PORTDOCS%%share/doc/bochs/release-prep.txt
+%%PORTDOCS%%share/doc/bochs/smp-simulation.html
%%PORTDOCS%%share/doc/bochs/sound.html
%%PORTDOCS%%share/doc/bochs/undercon.gif
%%PORTDOCS%%share/doc/bochs/whatisbochs.html