aboutsummaryrefslogtreecommitdiff
path: root/emulators/bochs
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2004-01-22 00:10:11 +0000
committerEric Anholt <anholt@FreeBSD.org>2004-01-22 00:10:11 +0000
commit9dfc919e100ead4738bc08fa18e8271e77ea6264 (patch)
tree0b59e618c4b699164ab51bded7021dafbe87832c /emulators/bochs
parent51b2cef52f1d43518433733f2e4330594b9ccdba (diff)
downloadports-9dfc919e100ead4738bc08fa18e8271e77ea6264.tar.gz
ports-9dfc919e100ead4738bc08fa18e8271e77ea6264.zip
Notes
Diffstat (limited to 'emulators/bochs')
-rw-r--r--emulators/bochs/Makefile19
1 files changed, 4 insertions, 15 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 477dfaa902e1..7516bdb8bf21 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -16,9 +16,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= anholt@FreeBSD.org
COMMENT= An IA-32 (x86) PC emulator that runs DOS, Win 95, and more
-# Global variables
-#
-
USE_XLIB= yes
USE_REINPLACE= yes
USE_GMAKE= yes
@@ -96,31 +93,23 @@ pre-patch::
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_GUI_TERM=yes\""
@${ECHO_MSG}
.endif
-.if !defined(WITH_BOCHS_VESA)
- @${ECHO_MSG} "If you want to enable the VESA BIOS video extensions of bochs,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_VESA=yes\""
- @${ECHO_MSG}
-.else
- @${ECHO_MSG} "Remember that with the VESA option you must also use VGABIOS-lgpl-latest"
- @${ECHO_MSG}
-.endif
.if !defined(WITH_BOCHS_PROCESSORS)
- @${ECHO_MSG} "If you want to compile with SMP support (implies WITH_BOCHS_CPU_LEVEL=6)."
+ @${ECHO_MSG} "If you want to compile with SMP support (implies WITH_BOCHS_CPU_LEVEL=6),"
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_PROCESSORS=<number of processors>\""
@${ECHO_MSG}
.endif
.if !defined(WITH_BOCHS_DEBUGGER)
- @${ECHO_MSG} "If you want to compile with builtin debugger and disassembler support."
+ @${ECHO_MSG} "If you want to compile with builtin debugger and disassembler support,"
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_DEBUGGER=yes\""
@${ECHO_MSG}
.endif
.if !defined(WITH_BOCHS_X86_DEBUGGER)
- @${ECHO_MSG} "If you want to compile with x86 hardware debugger support."
+ @${ECHO_MSG} "If you want to compile with x86 hardware debugger support,"
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_X86_DEBUGGER=yes\""
@${ECHO_MSG}
.endif
.if !defined(WITH_BOCHS_AMD64)
- @${ECHO_MSG} "If you want to compile with AMD x86-64 support."
+ @${ECHO_MSG} "If you want to compile with AMD x86-64 support,"
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_AMD64=yes\""
@${ECHO_MSG}
.endif