aboutsummaryrefslogtreecommitdiff
path: root/emulators/bochs
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-11-01 11:21:41 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-11-01 11:21:41 +0000
commit07ebc8ffebc127eb63b8840eeb51ad807f7e671a (patch)
treec300360b132dc9917e9bdc3fd4a3493ef9e5d692 /emulators/bochs
parent6cac88e5e5cfb44e42857a21647bc267453b5a01 (diff)
downloadports-07ebc8ffebc127eb63b8840eeb51ad807f7e671a.tar.gz
ports-07ebc8ffebc127eb63b8840eeb51ad807f7e671a.zip
Notes
Diffstat (limited to 'emulators/bochs')
-rw-r--r--emulators/bochs/Makefile74
-rw-r--r--emulators/bochs/distinfo4
-rw-r--r--emulators/bochs/files/patch-iodev__network__eth_fbsd.cc (renamed from emulators/bochs/files/patch-iodev-eth_fbsd.cc)6
3 files changed, 50 insertions, 34 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 26ff97a5b4cc..d5ffd5f83389 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -1,13 +1,8 @@
-# Ports collection makefile for: bochs
-# Date created: 16 December 1997
-# Whom: alex
-#
+# Created by: alex
# $FreeBSD$
-#
PORTNAME= bochs
-PORTVERSION= 2.5.1
-PORTREVISION= 1
+PORTVERSION= 2.6
PORTEPOCH= 2
CATEGORIES= emulators
MASTER_SITES= SF
@@ -16,17 +11,21 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= An IA-32 (x86) PC emulator that runs DOS, Win 95, and more
LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
-OPTIONS_DEFINE= A20_PIN ALIGN_CHECK ASSERT_CHECK CDROM CHAINING CLGD54XX CONF_MSRS CPP_SUFX \
- DEBUG DEBUGGER_X86 DISASM DOCS ES1370 FAST_FUNCCALL FPU GAMEPORT IDLE_HACK \
- INSTRUMENT IODEBUG LARGE_RAMFILE LOGGING LONG_PHY_ADDR MISALIGNEDSSE MWAIT NE2000 \
- OPTIMIZATIONS PCI PLUGINS PNIC RAW_SERIAL READLINE REPEAT_SPEED RFB SB16 SDL \
- SHOW_IPS SMP SVGA TERM USB USB_OHCI USB_XHCI VMX WX X11 X86_64 XPM
+OPTIONS_DEFINE= A20_PIN ALIGN_CHECK ASSERT_CHECK \
+ CDROM CHAINING CLGD54XX CONF_MSRS CPP_SUFX \
+ DEBUG DEBUGGER_X86 DISASM DOCS \
+ E1000 ES1370 FAST_FUNCCALL FPU \
+ GAMEPORT IDLE_HACK IODEBUG \
+ LARGE_RAMFILE LOGGING LONG_PHY_ADDR \
+ MISALIGNEDSSE MWAIT NE2000 OPTIMIZATIONS PCI PLUGINS PNIC \
+ RAW_SERIAL READLINE REPEAT_SPEED RFB \
+ SB16 SDL SHOW_IPS SMP SVGA SVM TERM USB USB_OHCI USB_XHCI \
+ VMX WX X11 X86_64 XPM
OPTIONS_SINGLE= DEBUG
OPTIONS_SINGLE_DEBUG= DEBUGGER GDB_STUB
-OPTIONS_DEFAULT= A20_PIN ALIGN_CHECK CDROM CONF_MSRS DISASM FPU LOGGING NE2000 \
- OPTIMIZATIONS SB16 X11
+OPTIONS_DEFAULT=A20_PIN ALIGN_CHECK CDROM CONF_MSRS DISASM FPU LOGGING \
+ NE2000 OPTIMIZATIONS SB16 X11
A20_PIN_DESC= Enable support for A20 pin
ALIGN_CHECK_DESC= Enable alignment check support
@@ -40,13 +39,13 @@ DEBUG_DESCR= Enable Debugging, select this and one of DEBUGGER or GDB_STUB (or n
DEBUGGER_DESC= Enable debugger support
DEBUGGER_X86_DESC= Enable x86 hardware debugger
DISASM_DESC= Enable disassemler support
+E1000_DESC= Enable Intel(R) Gigabit Ethernet support
ES1370_DESC= Enable ES1370 soundcard support
FAST_FUNCCALL_DESC= Enable fast function calls support (x86 only)
FPU_DESC= Enable FPU emulator
GAMEPORT_DESC= Enable standard PC gameport support
GDB_STUB_DESC= Enable GDB stub support
IDLE_HACK_DESC= Keep Bochs from using all CPU time
-INSTRUMENT_DESC= Enable support for instrumentation
IODEBUG_DESC= Enable I/O interface to debugger
LARGE_RAMFILE_DESC= Enable large ramfile support
LOGGING_DESC= Enable logging
@@ -67,6 +66,7 @@ SDL_DESC= Enable SDL display interface
SHOW_IPS_DESC= Enable logging of measured IPS
SMP_DESC= Enable SMP simulation support (CPU level 6)
SVGA_DESC= Enable SVGAlib support
+SVM_DESC= Enable SVM (AMD: secure virtual machine) emulation
TERM_DESC= Use text only, console based interface
USB_DESC= Enable limited USB UHCI support
USB_OHCI_DESC= Enable limited USB OHCI support
@@ -78,7 +78,7 @@ XPM_DESC= Enable XPM library support
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-CONFIGURE_ARGS= --disable-docbook
+CONFIGURE_ARGS= --disable-docbook --disable-instrumentation
MAKE_JOBS_SAFE= yes
CFLAGS+= -fno-exceptions -fomit-frame-pointer ${CPPFLAGS}
@@ -94,7 +94,7 @@ SUB_FILES= pkg-message
.include <bsd.port.options.mk>
-.if !${PORT_OPTIONS:MTERM} && !${PORT_OPTIONS:MWX} && ${PORT_OPTIONS:MX!!}
+.if !${PORT_OPTIONS:MTERM} && !${PORT_OPTIONS:MWX} && !${PORT_OPTIONS:MX11}
CONFIGURE_ARGS+=--with-nogui
.endif
@@ -164,6 +164,18 @@ CONFIGURE_ARGS+=--enable-disasm
CONFIGURE_ARGS+=--disable-disasm
.endif
+.if ${PORT_OPTIONS:ME1000}
+CONFIGURE_ARGS+=--enable-e1000
+.else
+CONFIGURE_ARGS+=--disable-e1000
+.endif
+
+.if ${PORT_OPTIONS:MES1370}
+CONFIGURE_ARGS+=--enable-es1370
+.else
+CONFIGURE_ARGS+=--disable-es1370
+.endif
+
.if ${PORT_OPTIONS:MFAST_FUNCCALL}
CONFIGURE_ARGS+=--enable-fast-function-calls
.else
@@ -194,13 +206,6 @@ CONFIGURE_ARGS+=--enable-idle-hack
CONFIGURE_ARGS+=--disable-idle-hack
.endif
-.if ${PORT_OPTIONS:MINSTRUMENT}
-BROKEN= currently unbuildable
-CONFIGURE_ARGS+=--enable-instrumentation
-.else
-CONFIGURE_ARGS+=--disable-instrumentation
-.endif
-
.if ${PORT_OPTIONS:MIODEBUG}
CONFIGURE_ARGS+=--enable-iodebug
.else
@@ -274,6 +279,7 @@ CONFIGURE_ARGS+=--disable-raw-serial
.endif
.if ${PORT_OPTIONS:MREADLINE}
+USE_READLINE= yes
CONFIGURE_ARGS+=--enable-readline
.else
CONFIGURE_ARGS+=--disable-readline
@@ -312,12 +318,22 @@ WITH_CPU_LEVEL= 6
.endif
.if ${PORT_OPTIONS:MSVGA}
-LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
+LIB_DEPENDS+= vga:${PORTSDIR}/graphics/svgalib
CONFIGURE_ARGS+=--with-svga
+.else
+CONFIGURE_ARGS+=--without-svga
+.endif
+
+.if ${PORT_OPTIONS:MSVM}
+CONFIGURE_ARGS+=--enable-svm
+.else
+CONFIGURE_ARGS+=--disable-svm
.endif
.if ${PORT_OPTIONS:MTERM}
CONFIGURE_ARGS+=--with-term
+.else
+CONFIGURE_ARGS+=--without-term
.endif
.if ${PORT_OPTIONS:MUSB}
@@ -379,7 +395,7 @@ CONFIGURE_ARGS+=--enable-cpu-level=${WITH_CPU_LEVEL}
.endif
.if ${PORT_OPTIONS:MSB16} || ${PORT_OPTIONS:MES1370}
-LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
+LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
CONFIGURE_ENV+= SOUND_LINK_OPTS="-L${LOCALBASE}/lib"
.endif
@@ -388,11 +404,11 @@ IGNORE= GDB_STUB is incompatible with multiprocessor
.endif
pre-everything::
- @${ECHO_CMD}
.if !defined(WITH_CPU_LEVEL)
+ @${ECHO_CMD}
@${ECHO_CMD} "If you want to change the processor level to emulate (default is 5, aka Pentium), set WITH_CPU_LEVEL to the desired value. Choices are 3, 4, 5 and 6 which mean target 386, 486, Pentium or Pentium Pro emulation." | ${FMT}
-.endif
@${ECHO_CMD}
+.endif
post-patch:
@${REINPLACE_CMD} -Ee \
diff --git a/emulators/bochs/distinfo b/emulators/bochs/distinfo
index c2c2843aa79a..5f1c2cadf6a1 100644
--- a/emulators/bochs/distinfo
+++ b/emulators/bochs/distinfo
@@ -1,2 +1,2 @@
-SHA256 (bochs-2.5.1.tar.gz) = 8d3f2ccd8fc3df2aff7ea370afc521cadd4a4f545faf6b0421013453ce3ea26e
-SIZE (bochs-2.5.1.tar.gz) = 4126651
+SHA256 (bochs-2.6.tar.gz) = 65123e44a6d2c1148d741da025d16311b9ccd600ef268b911aba73c67eaf86e1
+SIZE (bochs-2.6.tar.gz) = 4212828
diff --git a/emulators/bochs/files/patch-iodev-eth_fbsd.cc b/emulators/bochs/files/patch-iodev__network__eth_fbsd.cc
index 644be5f5907f..70d52896e3f7 100644
--- a/emulators/bochs/files/patch-iodev-eth_fbsd.cc
+++ b/emulators/bochs/files/patch-iodev__network__eth_fbsd.cc
@@ -1,6 +1,6 @@
---- iodev/eth_fbsd.cc.orig Sat Dec 10 19:37:35 2005
-+++ iodev/eth_fbsd.cc Sun Nov 19 15:56:46 2006
-@@ -227,6 +227,14 @@
+--- iodev/network/eth_fbsd.cc.orig 2012-09-02 20:30:11.000000000 +0900
++++ iodev/network/eth_fbsd.cc 2012-09-03 23:41:03.000000000 +0900
+@@ -235,6 +235,14 @@
return;
}