aboutsummaryrefslogtreecommitdiff
path: root/emulators/bochs
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-06-25 05:40:38 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-06-25 05:40:38 +0000
commit3a71381c721a0895e83f1c7b5528ff5920c86557 (patch)
tree4becb3108759611b3b218cb4672afeb806e05cf0 /emulators/bochs
parentb13ca6bb666330b7c8e980d43f358d0a966aaf6d (diff)
downloadports-3a71381c721a0895e83f1c7b5528ff5920c86557.tar.gz
ports-3a71381c721a0895e83f1c7b5528ff5920c86557.zip
Notes
Diffstat (limited to 'emulators/bochs')
-rw-r--r--emulators/bochs/Makefile38
-rw-r--r--emulators/bochs/distinfo5
2 files changed, 28 insertions, 15 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 24382cb2c286..3d937f904641 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bochs
-PORTVERSION= 2.4.5
+PORTVERSION= 2.4.6
PORTEPOCH= 2
CATEGORIES= emulators
MASTER_SITES= SF
@@ -16,7 +16,7 @@ COMMENT= An IA-32 (x86) PC emulator that runs DOS, Win 95, and more
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-docbook
OPTIONS= A20_PIN "Enable support for A20 pin" on \
@@ -26,6 +26,7 @@ OPTIONS= A20_PIN "Enable support for A20 pin" on \
CDROM "Enable CDROM support" on \
CLGD54XX "Enable Cirrus Logic GD54xx video card" off \
CONF_MSRS "Enable configurable MSR registers support" on \
+ CPP_SUFX "Use .cpp as C++ suffix" off \
DEBUGGER "Enable debugger support" off \
DEBUGGER_X86 "Enable x86 hardware debugger" off \
DISASM "Enable disassemler support " on \
@@ -33,6 +34,7 @@ OPTIONS= A20_PIN "Enable support for A20 pin" on \
FPU "Enable FPU emulator" on \
GAMEPORT "Enable standard PC gameport support" off \
GDB_STUB "Enable GDB stub support" off \
+ HS_ASMS "Enable support for host specific inline asms" off \
IDLE_HACK "Keep Bochs from using all CPU time" off \
INSTRUMENT "Enable support for instrumentation" off \
IODEBUG "Enable I/O interface to debugger" off \
@@ -41,7 +43,6 @@ OPTIONS= A20_PIN "Enable support for A20 pin" on \
MISALIGNEDSSE "Enable misaligned SSE support" off \
MWAIT "Enable experimental MONITOR/MWAIT support" off \
NE2000 "Enable limited ne2000 support" on \
- NEW_PIT "Enable use of the new PIT model" on \
OPTIMIZATIONS "Enable all safe speeed optimizations" on \
PCI "Enable limited i440FX PCI support" on \
PLUGINS "Enable building dynamic loadable plugins" off \
@@ -63,6 +64,7 @@ OPTIONS= A20_PIN "Enable support for A20 pin" on \
VMX "Enable Virtialization extensions" off \
WX "Use WxWidgets display interface" off \
X11 "Use X11 display interface" on \
+ X2APIC "Enable support for X2APIC" off \
X86_64 "Enable AMD x86-64 support" off \
XPM "Enable XPM library support" off
@@ -125,6 +127,12 @@ CONFIGURE_ARGS+=--disable-configurable-msrs
CONFIGURE_ARGS+=--enable-configurable-msrs
.endif
+.if defined(WITH_CPP_SUFX)
+CONFIGURE_ARGS+=--enable-cpp
+.else
+CONFIGURE_ARGS+=--disable-cpp
+.endif
+
.if defined(WITH_DEBUGGER)
CONFIGURE_ARGS+=--enable-debugger
.else
@@ -167,6 +175,12 @@ CONFIGURE_ARGS+=--enable-gdb-stub
CONFIGURE_ARGS+=--disable-gdb-stub
.endif
+.if defined(WITH_HS_ASMS)
+CONFIGURE_ARGS+=--enable-host-specific-asms
+.else
+CONFIGURE_ARGS+=--disable-host-specific-asms
+.endif
+
.if defined(WITH_IDLE_HACK)
CONFIGURE_ARGS+=--enable-idle-hack
.else
@@ -215,12 +229,6 @@ CONFIGURE_ARGS+=--enable-ne2000
CONFIGURE_ARGS+=--disable-ne2000
.endif
-.if !defined(WITH_NEW_PIT)
-CONFIGURE_ARGS+=--disable-new-pit
-.else
-CONFIGURE_ARGS+=--enable-new-pit
-.endif
-
.if defined(WITH_OPTIMIZATIONS)
CONFIGURE_ARGS+=--enable-all-optimizations
.else
@@ -338,18 +346,24 @@ CONFIGURE_ARGS+=--disable-debugger-gui
.endif
.if defined(WITH_X11)
-USE_XORG= xext xt
+USE_XORG= xrandr
CONFIGURE_ARGS+=--with-x11
.endif
+.if defined(WITH_X2APIC)
+CONFIGURE_ARGS+=--enable-x2apic
+.else
+CONFIGURE_ARGS+=--disable-x2apic
+.endif
+
.if defined(WITH_X86_64)
CONFIGURE_ARGS+=--enable-x86-64
.else
CONFIGURE_ARGS+=--disable-x86-64
.endif
-.if defined(WITH_XPM)
-USE_XORG= xpm
+.if defined(WITH_XPM) && defined(WITH_X11)
+USE_XORG+= xpm
CONFIGURE_ARGS+=--enable-xpm
.else
CONFIGURE_ARGS+=--disable-xpm
diff --git a/emulators/bochs/distinfo b/emulators/bochs/distinfo
index d2aea2d6bbb5..249bf617da5b 100644
--- a/emulators/bochs/distinfo
+++ b/emulators/bochs/distinfo
@@ -1,3 +1,2 @@
-MD5 (bochs-2.4.5.tar.gz) = fda7eadcd9590934d2901f8439631463
-SHA256 (bochs-2.4.5.tar.gz) = b948622a364c2e7da4221a6a4640ba2efa68422e1411ac377c69d37f46f67616
-SIZE (bochs-2.4.5.tar.gz) = 4059598
+SHA256 (bochs-2.4.6.tar.gz) = 689dcc5fccfd70c8340a54986f0cb9c2824009ed602718802868333da9ac53b9
+SIZE (bochs-2.4.6.tar.gz) = 4067147