aboutsummaryrefslogtreecommitdiff
path: root/emulators/bochs
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-23 14:23:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-23 14:23:36 +0000
commit33de5e9a5317ce9ded3e4ec8be22d9c6ace38d3f (patch)
tree3fdc4874841f3d26433949a0ff87fee39424ce6c /emulators/bochs
parent456c9202b1eb2e69b837647ee71308060d6d787e (diff)
downloadports-33de5e9a5317ce9ded3e4ec8be22d9c6ace38d3f.tar.gz
ports-33de5e9a5317ce9ded3e4ec8be22d9c6ace38d3f.zip
Notes
Diffstat (limited to 'emulators/bochs')
-rw-r--r--emulators/bochs/Makefile280
-rw-r--r--emulators/bochs/distinfo6
-rw-r--r--emulators/bochs/pkg-plist4
3 files changed, 259 insertions, 31 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index ff488a86a1d7..c9b4891931d3 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= bochs
-PORTVERSION= 2.3.7
+PORTVERSION= 2.4
PORTEPOCH= 2
CATEGORIES= emulators
MASTER_SITES= SF
@@ -14,52 +14,75 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= An IA-32 (x86) PC emulator that runs DOS, Win 95, and more
-BUILD_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
-RUN_DEPENDS= mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir
-
-USE_GNOME= gnometarget
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-docbook
-OPTIONS= ACPI "Enable ACPI emulation" off \
+OPTIONS= 1G_PAGES "Enable support for 1G pages in long mode" off \
+ A20_PIN "Enable support for A20 pin" on \
+ ACPI "Enable ACPI emulation" off \
AES "Enable support of AES CPU extensions" off \
+ ALIGN_CHECK "Enable alignment check support" on \
+ APIC "Enable APIC support" off \
+ ASSERT_CHECK "Enable BX_ASSERT checks" off \
CDROM "Enable CDROM support" on \
CLGD54XX "Enable Cirrus Logic GD54xx video card" off \
- DEBUGGER "Enable debugger and disassembler support" off \
+ CONF_MSRS "Enable configurable MSR registers support" on \
+ DAZ "Enable demornals-are-zeros support" off \
+ DEBUGGER "Enable debugger support" off \
DEBUGGER_X86 "Enable x86 hardware debugger" off \
+ DISASM "Enable disassemler support " on \
+ FAST_FUNCCALL "Enable fast function calls support (x86 only)" off \
FPU "Enable FPU emulator" on \
+ GAMEPORT "Enable standard PC gameport support" off \
+ GDB_STUB "Enable GDB stub support" off \
+ GLOBAL_PAGES "Enable support for global pages in PDE/PTE" off \
IDLE_HACK "Keep Bochs from using all CPU time" off \
- IGNORE_BAD_MSR "Ignore unknown MSR references (don't panic)" off \
+ IGNORE_BADMSR "Ignore unknown MSR references (don't panic)" on \
+ INSTRUMENT "Enable support for instrumentation" off \
+ IODEBUG "Enable I/O interface to debugger" off \
+ LARGE_PAGES "Enable support for large (2M/4M) pages" on \
+ LOGGING "Enable logging" on \
+ LONG_PHY_ADDR "Enable support for physical address >= 32bit" off \
MTRR "Enable MTRR emulation (CPU level >= 6)" off \
+ MISALIGNEDSSE "Enable misaligned SSE support" off \
+ MOVBE "Enable MOVBE intel Atom(R) instruction support" off \
MWAIT "Enable experimental MONITOR/MWAIT support" off \
NE2000 "Enable limited ne2000 support" on \
NEW_PIT "Enable use of the new PIT model" on \
OPTIMIZATIONS "Enable all safe speeed optimizations" on \
+ PAE "Enable support for Physical Address Extensions" off \
PCI "Enable limited i440FX PCI support" on \
+ POPCNT "Enable support for POPCNT instruction" off \
PLUGINS "Enable building dynamic loadable plugins" off \
PNIC "Enable PCI pseudo NIC (network card) support" off \
- PORT_E9_HACK "Writes to port e9 go to console" on \
+ RAW_SERIAL "Use raw serial port access" off \
READLINE "Enable readline support in debugger" off \
+ REPEAT_SPEED "Enable repeated IO and mem copy speedups" off \
RFB "Enable VNC server support in display" off \
SB16 "Enable Sound Blaster 16 emulation" on \
SDL "Enable SDL display interface" off \
+ SEP "Enable SYSENTER/SYSEXIT support" off \
SHOW_IPS "Enable logging of measured IPS" off \
SMP "Enable SMP simulation support (CPU level 6)" off \
SSE4 "Enable emulation of SSE4.2 instruction set" off \
SVGA "Enable SVGAlib support" off \
TCACHE "Enable trace cache" on \
TERM "Use text only, console based interface" off \
- USB "Enable limited i440FX PCI USB support" off \
+ USB "Enable limited USB UHCI support" off \
+ USB_OHCI "Enable limited USB OHCI support" off \
VBE "Enable VGA BIOS Extensions" on \
+ VME "Enable Virtual 8086 mode extensions" on \
+ VMX "Enable Virtialization extensions" off \
WX "Use WxWidgets display interface" off \
X11 "Use X11 display interface" on \
X86_64 "Enable AMD x86-64 support" off \
XPM "Enable XPM library support" off \
XSAVE "Enable support of XSAVE/XRSTOR CPU extensions" off
-CFLAGS+= -fno-rtti -fno-exceptions -fomit-frame-pointer
+CFLAGS+= -fno-exceptions -fomit-frame-pointer
+CXXFLAGS+= -fno-rtti
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
@@ -75,76 +98,238 @@ SUB_FILES= pkg-message
CONFIGURE_ARGS+=--with-nogui
.endif
+.if defined(WITH_1G_PAGES) && defined(WITH_X86_64)
+CONFIGURE_ARGS+=--enable-1g-pages
+.else
+CONFIGURE_ARGS+=--disable-1g-pages
+.endif
+
+.if !defined(WITH_A20_PIN)
+CONFIGURE_ARGS+=--disable-a20-pin
+.else
+CONFIGURE_ARGS+=--enable-a20-pin
+.endif
+
.if defined(WITH_ACPI)
CONFIGURE_ARGS+=--enable-acpi
+.else
+CONFIGURE_ARGS+=--disable-acpi
.endif
.if defined(WITH_AES)
CONFIGURE_ARGS+=--enable-aes
+.else
+CONFIGURE_ARGS+=--disable-aes
+.endif
+
+.if !defined(WITH_ALIGN_CHECK)
+CONFIGURE_ARGS+=--disable-alignment-check
+.else
+CONFIGURE_ARGS+=--enable-alignment-check
+.endif
+
+.if defined(WITH_APIC)
+CONFIGURE_ARGS+=--enable-apic
+.else
+CONFIGURE_ARGS+=--disable-apic
.endif
-.if defined(WITHOUT_CDROM)
+.if defined(WITH_ASSERT_CHECK)
+CONFIGURE_ARGS+=--enable-assert-checks
+.else
+CONFIGURE_ARGS+=--disable-assert-checks
+.endif
+
+.if !defined(WITH_CDROM)
CONFIGURE_ARGS+=--disable-cdrom
+.else
+CONFIGURE_ARGS+=--enable-cdrom
.endif
.if defined(WITH_CLGD54XX)
CONFIGURE_ARGS+=--enable-clgd54xx
+.else
+CONFIGURE_ARGS+=--disable-clgd54xx
+.endif
+
+.if !defined(WITH_CONF_MSRS)
+CONFIGURE_ARGS+=--disable-configurable-msrs
+.else
+CONFIGURE_ARGS+=--enable-configurable-msrs
+.endif
+
+.if defined(WITH_DAZ)
+CONFIGURE_ARGS+=--enable-daz
+.else
+CONFIGURE_ARGS+=--disable-daz
.endif
.if defined(WITH_DEBUGGER)
-CONFIGURE_ARGS+=--enable-debugger --enable-disasm
+CONFIGURE_ARGS+=--enable-debugger
+.else
+CONFIGURE_ARGS+=--disable-debugger
.endif
.if defined(WITH_DEBUGGER_X86)
CONFIGURE_ARGS+=--enable-x86-debugger
+.else
+CONFIGURE_ARGS+=--disable-x86-debugger
.endif
-.if defined(WITH_FPU)
+.if !defined(WITH_DISASM)
+CONFIGURE_ARGS+=--disable-disasm
+.else
+CONFIGURE_ARGS+=--enable-disasm
+.endif
+
+.if defined(WITH_FAST_FUNCCALL)
+CONFIGURE_ARGS+=--enable-fast-function-calls
+.else
+CONFIGURE_ARGS+=--disable-fast-function-calls
+.endif
+
+.if !defined(WITH_FPU)
+CONFIGURE_ARGS+=--disable-fpu
+.else
CONFIGURE_ARGS+=--enable-fpu
.endif
+.if defined(WITH_GAMEPORT)
+CONFIGURE_ARGS+=--enable-gameport
+.else
+CONFIGURE_ARGS+=--disable-gameport
+.endif
+
+.if defined(WITH_GDB_STUB)
+CONFIGURE_ARGS+=--enable-gdb-stub
+.else
+CONFIGURE_ARGS+=--disable-gdb-stub
+.endif
+
+.if defined(WITH_GLOBAL_PAGES)
+CONFIGURE_ARGS+=--enable-global-pages
+.else
+CONFIGURE_ARGS+=--disable-global-pages
+.endif
+
.if defined(WITH_IDLE_HACK)
CONFIGURE_ARGS+=--enable-idle-hack
+.else
+CONFIGURE_ARGS+=--disable-idle-hack
.endif
-.if defined(WITH_IGNORE_BAD_MSR)
+.if !defined(WITH_IGNORE_BADMSR)
+CONFIGURE_ARGS+=--disable-ignore-bad-msr
+.else
CONFIGURE_ARGS+=--enable-ignore-bad-msr
.endif
+.if defined(WITH_INSTRUMENT)
+CONFIGURE_ARGS+=--enable-instrumentation
+.else
+CONFIGURE_ARGS+=--disable-instrumentation
+.endif
+
+.if defined(WITH_IODEBUG)
+CONFIGURE_ARGS+=--enable-iodebug
+.else
+CONFIGURE_ARGS+=--disable-iodebug
+.endif
+
+.if !defined(WITH_LARGE_PAGES)
+CONFIGURE_ARGS+=--disable-large-pages
+.else
+CONFIGURE_ARGS+=--enable-large-pages
+.endif
+
+.if !defined(WITH_LOGGING)
+CONFIGURE_ARGS+=--disable-logging
+.else
+CONFIGURE_ARGS+=--enable-logging
+.endif
+
+.if defined(WITH_LONG_PHY_ADDR)
+CONFIGURE_ARGS+=--enable-long-phy-address
+.else
+CONFIGURE_ARGS+=--disable-long-phy-address
+.endif
+
.if defined(WITH_MTRR)
CONFIGURE_ARGS+=--enable-mtrr
+.else
+CONFIGURE_ARGS+=--disable-mtrr
+.endif
+
+.if defined(WITH_MISALIGNDSSE)
+CONFIGURE_ARGS+=--enable-misaligned-sse
+.else
+CONFIGURE_ARGS+=--disable-misaligned-sse
+.endif
+
+.if defined(WITH_MOVBE)
+CONFIGURE_ARGS+=--enable-movbe
+.else
+CONFIGURE_ARGS+=--disable-movbe
.endif
.if defined(WITH_MWAIT)
CONFIGURE_ARGS+=--enable-monitor-mwait
+.else
+CONFIGURE_ARGS+=--disable-monitor-mwait
.endif
.if defined(WITH_NE2000)
CONFIGURE_ARGS+=--enable-ne2000
+.else
+CONFIGURE_ARGS+=--disable-ne2000
.endif
-.if defined(WITHOUT_NEW_PIT)
+.if !defined(WITH_NEW_PIT)
CONFIGURE_ARGS+=--disable-new-pit
+.else
+CONFIGURE_ARGS+=--enable-new-pit
.endif
.if defined(WITH_OPTIMIZATIONS)
CONFIGURE_ARGS+=--enable-all-optimizations
+.else
+CONFIGURE_ARGS+=--disable-all-optimizations
+.endif
+
+.if defined(WITH_PAE)
+CONFIGURE_ARGS+=--enable-pae
+.else
+CONFIGURE_ARGS+=--disable-pae
.endif
.if defined(WITH_PCI)
CONFIGURE_ARGS+=--enable-pci
+.else
+CONFIGURE_ARGS+=--disable-pci
+.endif
+
+.if defined(WITH_POPCNT)
+CONFIGURE_ARGS+=--enable-popcnt
+.else
+CONFIGURE_ARGS+=--disable-popcnt
.endif
.if defined(WITH_PLUGINS)
CONFIGURE_ARGS+=--enable-plugins
+.else
+CONFIGURE_ARGS+=--disable-plugins
.endif
.if defined(WITH_PNIC)
CONFIGURE_ARGS+=--enable-pnic
+.else
+CONFIGURE_ARGS+=--disable-pnic
.endif
-.if defined(WITHOUT_PORT_E9_HACK)
-CONFIGURE_ARGS+=--disable-port-e9-hack
+.if defined(WITH_RAW_SERIAL)
+CONFIGURE_ARGS+=--enable-raw-serial
+.else
+CONFIGURE_ARGS+=--disable-raw-serial
.endif
.if defined(WITH_READLINE)
@@ -153,26 +338,42 @@ CONFIGURE_ARGS+=--enable-readline
CONFIGURE_ARGS+=--disable-readline
.endif
+.if defined(WITH_REPEAT_SPEED)
+CONFIGURE_ARGS+=--enable-repeat-speedups
+.else
+CONFIGURE_ARGS+=--disable-repeat-speedups
+.endif
+
.if defined(WITH_RFB)
CONFIGURE_ARGS+=--with-rfb
+.else
+CONFIGURE_ARGS+=--without-rfb
.endif
.if defined(WITH_SB16)
CONFIGURE_ARGS+=--enable-sb16=freebsd
.endif
-.if defined(WITH_SMP)
-CONFIGURE_ARGS+=--enable-smp
-WITH_CPU_LEVEL= 6
-.endif
-
.if defined(WITH_SDL)
USE_SDL= sdl
CONFIGURE_ARGS+=--with-sdl
.endif
+.if defined(WITH_SEP)
+CONFIGURE_ARGS+=--enable-sep
+.else
+CONFIGURE_ARGS+=--disable-sep
+.endif
+
.if defined(WITH_SHOW_IPS)
CONFIGURE_ARGS+=--enable-show-ips
+.else
+CONFIGURE_ARGS+=--disable-show-ips
+.endif
+
+.if defined(WITH_SMP)
+CONFIGURE_ARGS+=--enable-smp
+WITH_CPU_LEVEL= 6
.endif
.if defined(WITH_SSE4) || defined(WITH_AES) || defined(WITH_XSAVE)
@@ -189,7 +390,7 @@ CONFIGURE_ARGS+=--with-svga
CONFIGURE_ARGS+=--with-term
.endif
-.if defined(WITHOUT_TCACHE)
+.if !defined(WITH_TCACHE)
CONFIGURE_ARGS+=--disable-trace-cache
.else
CONFIGURE_ARGS+=--enable-trace-cache
@@ -197,15 +398,39 @@ CONFIGURE_ARGS+=--enable-trace-cache
.if defined(WITH_USB)
CONFIGURE_ARGS+=--enable-usb
+.else
+CONFIGURE_ARGS+=--disable-usb
+.endif
+
+.if defined(WITH_USB_OHCI)
+CONFIGURE_ARGS+=--enable-usb-ohci
+.else
+CONFIGURE_ARGS+=--disable-usb-ohci
.endif
-.if defined(WITH_VBE)
+.if !defined(WITH_VBE)
+CONFIGURE_ARGS+=--disable-vbe
+.else
CONFIGURE_ARGS+=--enable-vbe
.endif
+.if !defined(WITH_VME)
+CONFIGURE_ARGS+=--disable-vme
+.else
+CONFIGURE_ARGS+=--enable-vme
+.endif
+
+.if defined(WITH_VMX)
+CONFIGURE_ARGS+=--enable-vmx
+.else
+CONFIGURE_ARGS+=--disable-vmx
+.endif
+
.if defined(WITH_WX)
USE_WX= 2.4-2.6
CONFIGURE_ARGS+=--with-wx
+.else
+CONFIGURE_ARGS+=--disable-debugger-gui
.endif
.if defined(WITH_X11)
@@ -215,16 +440,21 @@ CONFIGURE_ARGS+=--with-x11
.if defined(WITH_X86_64)
CONFIGURE_ARGS+=--enable-x86-64
+.else
+CONFIGURE_ARGS+=--disable-x86-64
.endif
.if defined(WITH_XPM)
USE_XORG= xpm
+CONFIGURE_ARGS+=--enable-xpm
.else
CONFIGURE_ARGS+=--disable-xpm
.endif
.if defined(WITH_XSAVE)
CONFIGURE_ARGS+=--enable-xsave
+.else
+CONFIGURE_ARGS+=--disable-xsave
.endif
.if defined(WITH_CPU_LEVEL)
diff --git a/emulators/bochs/distinfo b/emulators/bochs/distinfo
index 5917ec3d8f39..91203d062ab9 100644
--- a/emulators/bochs/distinfo
+++ b/emulators/bochs/distinfo
@@ -1,3 +1,3 @@
-MD5 (bochs-2.3.7.tar.gz) = a2e5f922505bf16cabd36bb9d571a2c4
-SHA256 (bochs-2.3.7.tar.gz) = 77f27fedadc6431df0a06ee226259a80443524ae9d221c97c5986e3f7927bb04
-SIZE (bochs-2.3.7.tar.gz) = 3989982
+MD5 (bochs-2.4.tar.gz) = 45d19285bf68687772537c3eaeeb657f
+SHA256 (bochs-2.4.tar.gz) = 998d81c3cd8c022d2913c8d9d3bef4b9f171e2f685d5c8b5a5eb3b2cd92e4695
+SIZE (bochs-2.4.tar.gz) = 4041139
diff --git a/emulators/bochs/pkg-plist b/emulators/bochs/pkg-plist
index 01ac232272d1..dde88e62d8c7 100644
--- a/emulators/bochs/pkg-plist
+++ b/emulators/bochs/pkg-plist
@@ -29,10 +29,8 @@ bin/bximage
%%PORTDOCS%%%%DOCSDIR%%/TODO
%%PORTDOCS%%%%DOCSDIR%%/biossums.txt
%%PORTDOCS%%%%DOCSDIR%%/bochsrc-sample.txt
-%%PORTDOCS%%%%DOCSDIR%%/cvs-structure.txt
-%%PORTDOCS%%%%DOCSDIR%%/html/Linux.html
+%%PORTDOCS%%%%DOCSDIR%%/enh_dbg_user_man.txt
%%PORTDOCS%%%%DOCSDIR%%/html/cosimulation.html
-%%PORTDOCS%%%%DOCSDIR%%/html/index.html
%%PORTDOCS%%%%DOCSDIR%%/memory.txt
%%PORTDOCS%%%%DOCSDIR%%/random.txt
%%PORTDOCS%%@dirrm %%DOCSDIR%%/html