aboutsummaryrefslogtreecommitdiff
path: root/emulators/bochs
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-29 18:13:28 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-29 18:13:28 +0000
commitbac833972ef261fdd3d81e6be003ec8c90d0b535 (patch)
treeae07921b22e92af9327c891a6d4622a3337b1ca4 /emulators/bochs
parentc4173385f8ee4f230854b502e61b9a591624133b (diff)
downloadports-bac833972ef261fdd3d81e6be003ec8c90d0b535.tar.gz
ports-bac833972ef261fdd3d81e6be003ec8c90d0b535.zip
Notes
Diffstat (limited to 'emulators/bochs')
-rw-r--r--emulators/bochs/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 0ea3854a953a..c76123efe061 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -57,10 +57,14 @@ CONFIGURE_ARGS+= --disable-mmx
.endif
.endif
-.if defined(WITH_BOCHS_TERM)
+.if defined(WITH_BOCHS_GUI_TERM)
CONFIGURE_ARGS+= --with-term
.endif
+.if defined(WITH_BOCHS_GUI_NOGUI)
+CONFIGURE_ARGS+= --with-nogui
+.endif
+
.if defined(WITH_BOCHS_AMD64)
CONFIGURE_ARGS+= --enable-x86-64
.endif
@@ -84,11 +88,16 @@ pre-patch::
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_CPU_LEVEL=<cpu level>\""
@${ECHO_MSG}
.endif
-.if !defined(WITH_BOCHS_TERM)
+.if !defined(WITH_BOCHS_GUI_TERM)
@${ECHO_MSG} "If you want to enable the plain text, console-based bochs interface"
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_GUI_TERM=yes\""
@${ECHO_MSG}
.endif
+.if !defined(WITH_BOCHS_GUI_NOGUI)
+ @${ECHO_MSG} "If you want the bochs display"
+ @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_GUI_NOGUI=yes\""
+ @${ECHO_MSG}
+.endif
.if !defined(WITH_BOCHS_PROCESSORS)
@${ECHO_MSG} "If you want to compile with SMP support (implies WITH_BOCHS_CPU_LEVEL=6),"
@${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_BOCHS_PROCESSORS=<number of processors>\""