aboutsummaryrefslogtreecommitdiff
path: root/emulators/dolphin-emu-devel
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2013-03-20 14:27:20 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2013-03-20 14:27:20 +0000
commit3bf53b93a21cfd31ea2a928485ab0b41b95b1afc (patch)
treec6aff734fd951671b5ff08a2b93b63d0fe2f5ce0 /emulators/dolphin-emu-devel
parent8ad9fd338e18c7333c669841ecb1cc31204644a7 (diff)
downloadports-3bf53b93a21cfd31ea2a928485ab0b41b95b1afc.tar.gz
ports-3bf53b93a21cfd31ea2a928485ab0b41b95b1afc.zip
Notes
Diffstat (limited to 'emulators/dolphin-emu-devel')
-rw-r--r--emulators/dolphin-emu-devel/Makefile21
-rw-r--r--emulators/dolphin-emu-devel/distinfo4
-rw-r--r--emulators/dolphin-emu-devel/files/patch-CMakeLists.txt16
-rw-r--r--emulators/dolphin-emu-devel/files/patch-CMakeTests-CheckLib.cmake21
-rw-r--r--emulators/dolphin-emu-devel/pkg-plist69
5 files changed, 114 insertions, 17 deletions
diff --git a/emulators/dolphin-emu-devel/Makefile b/emulators/dolphin-emu-devel/Makefile
index 86e1e4fb6fec..87fd3a7b0cd9 100644
--- a/emulators/dolphin-emu-devel/Makefile
+++ b/emulators/dolphin-emu-devel/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
lzo2:${PORTSDIR}/archivers/lzo2 \
sfml-network:${PORTSDIR}/devel/sfml
-REVDATE= 20130110
+REVDATE= 20130225
USE_ICONV= yes
USE_PKGCONFIG= build
@@ -41,21 +41,18 @@ USE_GCC= 4.6+
USE_CMAKE= yes
CMAKE_BUILD_TYPE= Release
# Disable ao (seems buggy) and ALSA (emulated)
-# XXX ENCODE_FRAMEDUMPS is disabled because it will fail detecting required
-# libs (libavcodec, libavformat, libswscale, libavutil) as our version of
-# ffmpeg is currently too old
CMAKE_ARGS+= -DDISABLE_AO:BOOL=ON \
-DDISABLE_ALSA:BOOL=ON \
-DDISABLE_BLUEZ:BOOL=ON \
- -DENCODE_FRAMEDUMPS:BOOL=OFF \
-DCMAKE_INSTALL_RPATH_USE_LINK_PATH:BOOL=ON
SUB_FILES= pkg-message
SUB_LIST+= MAINTAINER=${MAINTAINER}
-OPTIONS_DEFINE= PULSEAUDIO PORTAUDIO DEBUG
+OPTIONS_DEFINE= PULSEAUDIO PORTAUDIO DEBUG FRAMEDUMPS
PORTAUDIO_DESC= Enable PortAudio (mic) support
-OPTIONS_DEFAULT= PORTAUDIO
+FRAMEDUMPS_DESC= Encode framedumps in AVI format
+OPTIONS_DEFAULT= PORTAUDIO FRAMEDUMPS
.include <bsd.port.pre.mk>
@@ -95,6 +92,16 @@ LIB_DEPENDS+= portaudio.2:${PORTSDIR}/audio/portaudio2
CMAKE_ARGS+= -DDISABLE_PORTAUDIO:BOOL=ON
.endif
+.if ${PORT_OPTIONS:MFRAMEDUMPS}
+CMAKE_ARGS+= -DENCODE_FRAMEDUMPS:BOOL=ON
+LIB_DEPENDS+= avcodec1:${PORTSDIR}/multimedia/ffmpeg1 \
+ avformat1:${PORTSDIR}/multimedia/ffmpeg1 \
+ swscale1:${PORTSDIR}/multimedia/ffmpeg1 \
+ avutil1:${PORTSDIR}/multimedia/ffmpeg1
+.else
+CMAKE_ARGS+= -DENCODE_FRAMEDUMPS:BOOL=OFF
+.endif
+
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/emulators/dolphin-emu-devel/distinfo b/emulators/dolphin-emu-devel/distinfo
index 0ac495b82f72..e2c725db76a4 100644
--- a/emulators/dolphin-emu-devel/distinfo
+++ b/emulators/dolphin-emu-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dolphin-emu-3.5.r20130110.tgz) = 358cbcf21ee84c8d2a5a65fbc1bcc983fe6615ef6817bf0f16d64927dc6a1242
-SIZE (dolphin-emu-3.5.r20130110.tgz) = 26220728
+SHA256 (dolphin-emu-3.5.r20130225.tgz) = 1a9ae1d828c8959fb165a2859554ca7fcc3eb8336a11bc5a69274785bec29100
+SIZE (dolphin-emu-3.5.r20130225.tgz) = 26975818
diff --git a/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt b/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt
index f41203d375d6..73f4660c7764 100644
--- a/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt
+++ b/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt
@@ -1,6 +1,6 @@
---- CMakeLists.txt.orig 2012-09-11 12:52:22.000000000 +0200
-+++ CMakeLists.txt 2012-09-18 06:49:30.000000000 +0200
-@@ -249,51 +249,81 @@
+--- CMakeLists.txt.orig 2013-02-25 17:12:52.000000000 +0100
++++ CMakeLists.txt 2013-02-25 17:22:59.000000000 +0100
+@@ -286,51 +286,81 @@
message("OpenMP parallelization disabled")
endif()
@@ -67,13 +67,13 @@
+ message("bluez (bluetooth) support disabled")
+endif()
--check_lib(PULSEAUDIO libpulse QUIET)
+-check_lib(PULSEAUDIO libpulse-simple QUIET)
-if(PULSEAUDIO_FOUND)
- add_definitions(-DHAVE_PULSEAUDIO=1)
- message("PulseAudio found, enabling PulseAudio sound backend")
+option(DISABLE_PULSEAUDIO "Disable PulseAudio sound backend" OFF)
+if(NOT DISABLE_PULSEAUDIO)
-+ check_lib(PULSEAUDIO libpulse QUIET)
++ check_lib(PULSEAUDIO libpulse-simple QUIET)
+ if(PULSEAUDIO_FOUND)
+ add_definitions(-DHAVE_PULSEAUDIO=1)
+ message("PulseAudio found, enabling PulseAudio sound backend")
@@ -113,7 +113,7 @@
# Note: We do not need to explicitly check for X11 as it is done in the cmake
# FindOpenGL module on linux.
-@@ -323,22 +353,33 @@
+@@ -359,22 +389,33 @@
check_libav()
endif()
@@ -158,9 +158,9 @@
-endif(PORTAUDIO)
+endif()
- option(OPROFILING "Enable profiling" OFF)
if(OPROFILING)
-@@ -602,10 +643,13 @@
+ check_lib(OPROFILE opagent opagent.h)
+@@ -634,10 +675,13 @@
install(DIRECTORY Data/User/ DESTINATION ${datadir}/user PATTERN)
install(DIRECTORY Data/Sys/ DESTINATION ${datadir}/sys PATTERN)
endif()
diff --git a/emulators/dolphin-emu-devel/files/patch-CMakeTests-CheckLib.cmake b/emulators/dolphin-emu-devel/files/patch-CMakeTests-CheckLib.cmake
new file mode 100644
index 000000000000..ca8f74e95efb
--- /dev/null
+++ b/emulators/dolphin-emu-devel/files/patch-CMakeTests-CheckLib.cmake
@@ -0,0 +1,21 @@
+--- CMakeTests/CheckLib.cmake.orig 2012-11-07 08:05:26.000000000 +0100
++++ CMakeTests/CheckLib.cmake 2013-03-06 07:22:30.000000000 +0100
+@@ -55,8 +55,8 @@
+
+ macro(check_libav)
+ if(PKG_CONFIG_FOUND)
+- pkg_check_modules(LIBAV libavcodec>=53.35.0 libavformat>=53.21.0
+- libswscale>=2.1.0 libavutil>=51.22.1)
++ pkg_check_modules(LIBAV libavcodec1>=53.35.0 libavformat1>=53.21.0
++ libswscale1>=2.1.0 libavutil1>=51.22.1)
+ else()
+ message("pkg-config is required to check for libav")
+ endif()
+@@ -64,6 +64,7 @@
+ message("libav found, enabling AVI frame dumps")
+ add_definitions(-DHAVE_LIBAV)
+ include_directories(${LIBAV_INCLUDE_DIRS})
++ link_directories(${LIBAV_LIBRARY_DIRS})
+ else()
+ message("libav not found, disabling AVI frame dumps")
+ endif()
diff --git a/emulators/dolphin-emu-devel/pkg-plist b/emulators/dolphin-emu-devel/pkg-plist
index 24717e9fef3f..6bc068ef7f00 100644
--- a/emulators/dolphin-emu-devel/pkg-plist
+++ b/emulators/dolphin-emu-devel/pkg-plist
@@ -73,6 +73,23 @@ bin/dolphin-emu
%%DATADIR%%/user/Shaders/auto_toon2.txt
%%DATADIR%%/user/Shaders/invert_blue.txt
%%DATADIR%%/user/Shaders/invert.txt
+%%DATADIR%%/user/Themes/Boomy/help.png
+%%DATADIR%%/user/Themes/Boomy/gcpad.png
+%%DATADIR%%/user/Themes/Boomy/refresh.png
+%%DATADIR%%/user/Themes/Boomy/graphics.png
+%%DATADIR%%/user/Themes/Boomy/fullscreen.png
+%%DATADIR%%/user/Themes/Boomy/open.png
+%%DATADIR%%/user/Themes/Boomy/wiimote.png
+%%DATADIR%%/user/Themes/Boomy/README.txt
+%%DATADIR%%/user/Themes/Boomy/dsp.png
+%%DATADIR%%/user/Themes/Boomy/config.png
+%%DATADIR%%/user/Themes/Boomy/play.png
+%%DATADIR%%/user/Themes/Boomy/stop.png
+%%DATADIR%%/user/Themes/Boomy/screenshot.png
+%%DATADIR%%/user/Themes/Boomy/browse.png
+%%DATADIR%%/user/Themes/Boomy/pause.png
+%%DATADIR%%/user/Themes/Boomy/nobanner.png
+%%DATADIR%%/user/GameConfig/GF8P69.ini
%%DATADIR%%/user/GameConfig/GC3P78.ini
%%DATADIR%%/user/GameConfig/R8LE20.ini
%%DATADIR%%/user/GameConfig/SSRPXT.ini
@@ -1458,6 +1475,56 @@ bin/dolphin-emu
%%DATADIR%%/user/GameConfig/SERF4Q.ini
%%DATADIR%%/user/GameConfig/GDSP78.ini
%%DATADIR%%/user/GameConfig/GPAE01.ini
+%%DATADIR%%/user/GameConfig/GAZM69.ini
+%%DATADIR%%/user/GameConfig/GSSP8P.ini
+%%DATADIR%%/user/GameConfig/G5SE7D.ini
+%%DATADIR%%/user/GameConfig/GHSX69.ini
+%%DATADIR%%/user/GameConfig/GHLP69.ini
+%%DATADIR%%/user/GameConfig/R3MP01.ini
+%%DATADIR%%/user/GameConfig/RS5JC8.ini
+%%DATADIR%%/user/GameConfig/RH8E4F.ini
+%%DATADIR%%/user/GameConfig/GQWX69.ini
+%%DATADIR%%/user/GameConfig/G5SP7D.ini
+%%DATADIR%%/user/GameConfig/RS5PC8.ini
+%%DATADIR%%/user/GameConfig/GHLJ69.ini
+%%DATADIR%%/user/GameConfig/GSSJ8P.ini
+%%DATADIR%%/user/GameConfig/SDBP78.ini
+%%DATADIR%%/user/GameConfig/GH4M69.ini
+%%DATADIR%%/user/GameConfig/GKYJ01.ini
+%%DATADIR%%/user/GameConfig/GSSP70.ini
+%%DATADIR%%/user/GameConfig/SDBE78.ini
+%%DATADIR%%/user/GameConfig/RS5EC8.ini
+%%DATADIR%%/user/GameConfig/G2RE52.ini
+%%DATADIR%%/user/GameConfig/GVLF69.ini
+%%DATADIR%%/user/GameConfig/GH4S69.ini
+%%DATADIR%%/user/GameConfig/GAZI69.ini
+%%DATADIR%%/user/GameConfig/GHLX69.ini
+%%DATADIR%%/user/GameConfig/GHSP69.ini
+%%DATADIR%%/user/GameConfig/RH8X4F.ini
+%%DATADIR%%/user/GameConfig/GAZD69.ini
+%%DATADIR%%/user/GameConfig/GAZH69.ini
+%%DATADIR%%/user/GameConfig/GHLY69.ini
+%%DATADIR%%/user/GameConfig/GP5P01.ini
+%%DATADIR%%/user/GameConfig/GAZP69.ini
+%%DATADIR%%/user/GameConfig/GQWP69.ini
+%%DATADIR%%/user/GameConfig/GH4F69.ini
+%%DATADIR%%/user/GameConfig/GH4J69.ini
+%%DATADIR%%/user/GameConfig/GVLD69.ini
+%%DATADIR%%/user/GameConfig/GZPP70.ini
+%%DATADIR%%/user/GameConfig/GHSJ69.ini
+%%DATADIR%%/user/GameConfig/GAZS69.ini
+%%DATADIR%%/user/GameConfig/GVLP69.ini
+%%DATADIR%%/user/GameConfig/GHLZ69.ini
+%%DATADIR%%/user/GameConfig/GH4I69.ini
+%%DATADIR%%/user/GameConfig/GH4P69.ini
+%%DATADIR%%/user/GameConfig/RH8JEL.ini
+%%DATADIR%%/user/GameConfig/GAZF69.ini
+%%DATADIR%%/user/GameConfig/GAZJ69.ini
+%%DATADIR%%/user/GameConfig/GP5J01.ini
+%%DATADIR%%/user/GameConfig/GQWJ69.ini
+%%DATADIR%%/user/GameConfig/GH4D69.ini
+%%DATADIR%%/user/GameConfig/GZPE70.ini
+%%DATADIR%%/user/GameConfig/GH4H69.ini
%%DATADIR%%/user/Wii/shared2/sys/SYSCONF
%%DATADIR%%/user/Wii/shared2/ec/shopsetu.log
%%DATADIR%%/user/Wii/shared2/succession/shop.log
@@ -1486,6 +1553,8 @@ bin/dolphin-emu
@dirrm %%DATADIR%%/user/OpenCL
@dirrm %%DATADIR%%/user/Maps
@dirrm %%DATADIR%%/user/GameConfig
+@dirrm %%DATADIR%%/user/Themes/Boomy
+@dirrm %%DATADIR%%/user/Themes
@dirrm %%DATADIR%%/user
@dirrm %%DATADIR%%/sys/Wii
@dirrm %%DATADIR%%/sys/GC