aboutsummaryrefslogtreecommitdiff
path: root/emulators/dolphin-emu-devel
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2012-11-09 09:25:48 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2012-11-09 09:25:48 +0000
commitfc940864a1243a36f98ce4d659a608321dbf5111 (patch)
treecc8dbdc7cbd48e54357eb977700438686b8e1c84 /emulators/dolphin-emu-devel
parentdb69708ce2ad101e02fd365b732d9a9cfdec07a8 (diff)
downloadports-fc940864a1243a36f98ce4d659a608321dbf5111.tar.gz
ports-fc940864a1243a36f98ce4d659a608321dbf5111.zip
Notes
Diffstat (limited to 'emulators/dolphin-emu-devel')
-rw-r--r--emulators/dolphin-emu-devel/Makefile3
-rw-r--r--emulators/dolphin-emu-devel/distinfo4
-rw-r--r--emulators/dolphin-emu-devel/files/patch-CMakeLists.txt2
3 files changed, 4 insertions, 5 deletions
diff --git a/emulators/dolphin-emu-devel/Makefile b/emulators/dolphin-emu-devel/Makefile
index bb1cf0b9c69c..bcea679c1915 100644
--- a/emulators/dolphin-emu-devel/Makefile
+++ b/emulators/dolphin-emu-devel/Makefile
@@ -7,7 +7,6 @@
PORTNAME= dolphin-emu
PORTVERSION= 3.0.r${REVDATE}
-PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
LOCAL/martymac
@@ -24,7 +23,7 @@ LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
lzo2:${PORTSDIR}/archivers/lzo2 \
sfml-network:${PORTSDIR}/devel/sfml
-REVDATE= 20120912
+REVDATE= 20121107
USE_ICONV= yes
USE_GNOME= pkgconfig
diff --git a/emulators/dolphin-emu-devel/distinfo b/emulators/dolphin-emu-devel/distinfo
index 7aa120e690fd..47a06969d327 100644
--- a/emulators/dolphin-emu-devel/distinfo
+++ b/emulators/dolphin-emu-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dolphin-emu-3.0.r20120912.tgz) = af7a14c6d6ab2e07786dc2d6652d874bf2ebddbf1cb72c8640af2dfebbbcc4a6
-SIZE (dolphin-emu-3.0.r20120912.tgz) = 26154876
+SHA256 (dolphin-emu-3.0.r20121107.tgz) = dbbd6116a4c998d6df7c5db776fcddc6d134e0a7a2b658c4f86c7dfd66bfb353
+SIZE (dolphin-emu-3.0.r20121107.tgz) = 26168234
diff --git a/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt b/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt
index 6b675cf31b7f..f41203d375d6 100644
--- a/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt
+++ b/emulators/dolphin-emu-devel/files/patch-CMakeLists.txt
@@ -131,7 +131,7 @@
+option(DISABLE_PORTAUDIO "Disable PortAudio (mic) support" OFF)
+if(NOT DISABLE_PORTAUDIO)
+ include(CheckCXXSourceRuns)
-+ include_directories(${CMAKE_INSTALL_PREFIX}/include/portaudio2)
++ include_directories(BEFORE ${CMAKE_INSTALL_PREFIX}/include/portaudio2)
+ link_directories(${CMAKE_INSTALL_PREFIX}/lib/portaudio2)
+ set(CMAKE_REQUIRED_INCLUDES ${CMAKE_INSTALL_PREFIX}/include/portaudio2)
+ set(CMAKE_REQUIRED_FLAGS -L${CMAKE_INSTALL_PREFIX}/lib/portaudio2)