aboutsummaryrefslogtreecommitdiff
path: root/emulators/dolphin-emu
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2018-09-25 19:33:09 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2018-09-25 19:33:09 +0000
commitae43c5e5784010820e049e89aa3e716b17a580b2 (patch)
tree165cf8790b0a8ef8a6803b035e4d0736766276a3 /emulators/dolphin-emu
parent5e6e78c705daea44b3157552a600450c352db183 (diff)
Notes
Diffstat (limited to 'emulators/dolphin-emu')
-rw-r--r--emulators/dolphin-emu/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index 18a40fe5b973..a6021eab16df 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -42,7 +42,7 @@ LIB_DEPENDS= libpulse.so:audio/pulseaudio \
libcurl.so:ftp/curl \
libhidapi.so:comms/hidapi
-USES= cmake compiler:c++11-lib desktop-file-utils iconv pkgconfig \
+USES= cmake compiler:c++17-lang desktop-file-utils iconv pkgconfig \
qmake qt:5
USE_GITHUB= yes
@@ -64,6 +64,9 @@ CMAKE_ARGS+= -DTRY_X11:BOOL=ON \
-DCMAKE_REQUIRED_FLAGS:STRING="-L${LOCALBASE}/lib"
MAKE_ENV+= DESTDIR="${STAGEDIR}"
+# XXX Fix build on archs where 'unsigned long' is 32bit
+CXXFLAGS+= -DLZO_CFG_PREFER_TYPEOF_ACC_INT32E_T=LZO_TYPEOF_INT
+
# XXX Bypass git check (and set a dummy -unused- revision)
CMAKE_ARGS+= -DDOLPHIN_WC_BRANCH:STRING="stable" \
-DDOLPHIN_WC_REVISION:STRING="1"