aboutsummaryrefslogtreecommitdiff
path: root/emulators/dosbox
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2003-11-01 14:28:19 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2003-11-01 14:28:19 +0000
commitbbe8d41dbda69906a4ea8f702b6cdacb54565616 (patch)
treea3d6d749f3610f7381f742996b9f110458737157 /emulators/dosbox
parent1587b71700ba9470554394e3cfe06668f9de2dc5 (diff)
downloadports-bbe8d41dbda69906a4ea8f702b6cdacb54565616.tar.gz
ports-bbe8d41dbda69906a4ea8f702b6cdacb54565616.zip
Notes
Diffstat (limited to 'emulators/dosbox')
-rw-r--r--emulators/dosbox/Makefile40
-rw-r--r--emulators/dosbox/distinfo2
-rw-r--r--emulators/dosbox/files/patch-configure11
-rw-r--r--emulators/dosbox/files/patch-src::gui::sdlmain.cpp12
-rw-r--r--emulators/dosbox/pkg-descr8
-rw-r--r--emulators/dosbox/pkg-message4
-rw-r--r--emulators/dosbox/pkg-plist7
7 files changed, 45 insertions, 39 deletions
diff --git a/emulators/dosbox/Makefile b/emulators/dosbox/Makefile
index bd34400e5676..888a902f4808 100644
--- a/emulators/dosbox/Makefile
+++ b/emulators/dosbox/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dosbox
-PORTVERSION= 0.58
+PORTVERSION= 0.60
CATEGORIES= emulators
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,34 +14,38 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= knyghtmare@knyghtmare.com
COMMENT= An emulator of a PC with DOS
-LIB_DEPENDS= SDL-1.1.5:${PORTSDIR}/devel/sdl12
-
-SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+LIB_DEPENDS= SDL_net.0:${PORTSDIR}/net/sdl_net \
+ png.5:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
-CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
-
USE_REINPLACE= yes
+USE_SDL= yes
+
+MAN1= dosbox.1
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+CPPFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --enable-core-inline
post-patch:
- @${REINPLACE_CMD} -e 's#"SDL.h"#<SDL11/SDL.h>#' \
- ${WRKSRC}/src/gui/sdlmain.cpp ${WRKSRC}/src/hardware/mixer.cpp
- @${REINPLACE_CMD} -e 's#<SDL.h>#<SDL11/SDL.h>#' ${WRKSRC}/include/timer.h
- @${REINPLACE_CMD} -e 's#"SDL_thread.h"#<SDL11/SDL_thread.h>#' \
- ${WRKSRC}/src/gui/sdlmain.cpp
+ @${REINPLACE_CMD} -e 's#SDL\/#SDL11\/#g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's#\/usr\/share\/doc\/dosbox#${DOCSDIR}#g' \
+ ${WRKSRC}/docs/dosbox.1
+ @${SED} 's#%%DOCSDIR%%#${DOCSDIR}#' ${PKGDIR}/pkg-message > \
+ ${WRKDIR}/pkg-message
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/dosbox ${PREFIX}/bin/dosbox
+ ${INSTALL_MAN} ${WRKSRC}/docs/dosbox.1 ${PREFIX}/man/man1/
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/dosbox
- ${INSTALL_DATA} ${WRKSRC}/NEWS ${PREFIX}/share/doc/dosbox
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/dosbox
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
post-install:
- @${ECHO_CMD} "================================================="
- @${ECHO_CMD} "Be sure to read the README for usage instructions"
- @${ECHO_CMD} "located in ${PREFIX}/share/doc/dosbox by default"
- @${ECHO_CMD} "================================================="
+ @${CAT} ${WRKDIR}/pkg-message
.include <bsd.port.mk>
diff --git a/emulators/dosbox/distinfo b/emulators/dosbox/distinfo
index cc670c3b26cc..9db9211d2b07 100644
--- a/emulators/dosbox/distinfo
+++ b/emulators/dosbox/distinfo
@@ -1 +1 @@
-MD5 (dosbox-0.58.tar.gz) = 91c49a597134f35f899d32a8b253205b
+MD5 (dosbox-0.60.tar.gz) = ca68955bcc3585630dcf17bab6ec185a
diff --git a/emulators/dosbox/files/patch-configure b/emulators/dosbox/files/patch-configure
new file mode 100644
index 000000000000..919ace42ac26
--- /dev/null
+++ b/emulators/dosbox/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Sun Oct 19 13:46:59 2003
++++ configure Sun Oct 19 13:47:15 2003
+@@ -5350,7 +5350,7 @@
+
+ if test x$enable_core_inline = xyes ; then
+ echo "$as_me:$LINENO: result: enabling inlined memory handling in CPU Core" >&5
+-echo "${ECHO_T}enabling inlined memory handling in CPU Core" >&6,
++echo "${ECHO_T}enabling inlined memory handling in CPU Core" >&6
+ cat >>confdefs.h <<\_ACEOF
+ #define C_CORE_INLINE 1
+ _ACEOF
diff --git a/emulators/dosbox/files/patch-src::gui::sdlmain.cpp b/emulators/dosbox/files/patch-src::gui::sdlmain.cpp
deleted file mode 100644
index 42d97580c59f..000000000000
--- a/emulators/dosbox/files/patch-src::gui::sdlmain.cpp
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/gui/sdlmain.cpp.orig Sun May 11 14:05:10 2003
-+++ src/gui/sdlmain.cpp Sun May 11 14:06:05 2003
-@@ -39,9 +39,7 @@
- //#define DISABLE_JOYSTICK
- #define C_GFXTHREADED 1 //Enabled by default
-
--#if defined(MACOSX)
- extern char** environ;
--#endif
-
- struct SDL_Block {
- volatile bool active; //If this isn't set don't draw
diff --git a/emulators/dosbox/pkg-descr b/emulators/dosbox/pkg-descr
index 525e6a3f1f55..c9e67863bbda 100644
--- a/emulators/dosbox/pkg-descr
+++ b/emulators/dosbox/pkg-descr
@@ -4,10 +4,10 @@ local file system for files.
Currently emulated is:
-o CPU:286/386 realmode
-o GFX:VGA/EGS/CGA
+o CPU:286/386 realmode/pmode
+o GFX:VGA/EGS/CGA/SVGA/VESA
o SND:PC-Speaker/Tandy 3-Voice/Adlib/SoundBlaster
o MSC:Keyboard/Mouse
-o DOS:Director FileSystem/XMS/EMS
+o DOS:Directory FileSystem/XMS/EMS
-WWW: http://dosbox.zophar.net/
+WWW: http://dosbox.sourceforge.net/
diff --git a/emulators/dosbox/pkg-message b/emulators/dosbox/pkg-message
new file mode 100644
index 000000000000..fc2d0a52d9e2
--- /dev/null
+++ b/emulators/dosbox/pkg-message
@@ -0,0 +1,4 @@
+=================================================
+Be sure to read the README for usage instructions
+located in %%DOCSDIR%% by default
+=================================================
diff --git a/emulators/dosbox/pkg-plist b/emulators/dosbox/pkg-plist
index 2a29518c62f4..312522fc70da 100644
--- a/emulators/dosbox/pkg-plist
+++ b/emulators/dosbox/pkg-plist
@@ -1,5 +1,4 @@
bin/dosbox
-%%PORTDOCS%%share/doc/dosbox/NEWS
-%%PORTDOCS%%share/doc/dosbox/README
-%%PORTDOCS%%@dirrm share/doc/dosbox
-@dirrm share/dosbox
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%