aboutsummaryrefslogtreecommitdiff
path: root/emulators/dosbox
diff options
context:
space:
mode:
authorMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-05-01 22:19:27 +0000
committerMunechika SUMIKAWA <sumikawa@FreeBSD.org>2003-05-01 22:19:27 +0000
commitdade58f65fa0d7279b332fb544813f678fb8cae5 (patch)
treec691691781523dd7bea2ab77553465e0a76f78d7 /emulators/dosbox
parent744d776bc95f1c4159f408481d95baf749617c80 (diff)
downloadports-dade58f65fa0d7279b332fb544813f678fb8cae5.tar.gz
ports-dade58f65fa0d7279b332fb544813f678fb8cae5.zip
Notes
Diffstat (limited to 'emulators/dosbox')
-rw-r--r--emulators/dosbox/Makefile48
-rw-r--r--emulators/dosbox/distinfo1
-rw-r--r--emulators/dosbox/files/patch-src::misc::messages.cpp12
-rw-r--r--emulators/dosbox/pkg-descr13
-rw-r--r--emulators/dosbox/pkg-plist6
5 files changed, 80 insertions, 0 deletions
diff --git a/emulators/dosbox/Makefile b/emulators/dosbox/Makefile
new file mode 100644
index 000000000000..b3fbdff39b3f
--- /dev/null
+++ b/emulators/dosbox/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: dosbox
+# Date created: 28 July 2002
+# Whom: Tom Carrick <knyghtmare@knyghtmare.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dosbox
+PORTVERSION= 0.55
+CATEGORIES= emulators
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= knyghtmare@knyghtmare.com
+COMMENT= An emulator of a PC with DOS
+
+LIB_DEPENDS= SDL-1.1.4:${PORTSDIR}/devel/sdl12
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
+
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's#<SDL/#<SDL11/#' ${WRKSRC}/include/timer.h \
+ ${WRKSRC}/src/gui/sdlmain.cpp ${WRKSRC}/src/hardware/mixer.cpp
+ ${REINPLACE_CMD} -e "s#@@PREFIX@@#${PREFIX}#" \
+ ${WRKSRC}/src/misc/messages.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/dosbox ${PREFIX}/bin/dosbox
+ ${MKDIR} ${PREFIX}/share/dosbox
+ ${INSTALL_DATA} ${WRKSRC}/src/dosbox.lang ${PREFIX}/share/dosbox
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/dosbox
+ ${INSTALL_DATA} ${WRKSRC}/NEWS ${PREFIX}/share/doc/dosbox
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/dosbox
+.endif
+
+post-install:
+ @${ECHO_CMD} "================================================="
+ @${ECHO_CMD} "Be sure to read the README for usage instructions"
+ @${ECHO_CMD} "located in ${PREFIX}/share/doc/dosbox by default"
+ @${ECHO_CMD} "================================================="
+
+.include <bsd.port.mk>
diff --git a/emulators/dosbox/distinfo b/emulators/dosbox/distinfo
new file mode 100644
index 000000000000..820364bf53aa
--- /dev/null
+++ b/emulators/dosbox/distinfo
@@ -0,0 +1 @@
+MD5 (dosbox-0.55.tar.gz) = b3daf143cb27f9d43b0683c39e26951a
diff --git a/emulators/dosbox/files/patch-src::misc::messages.cpp b/emulators/dosbox/files/patch-src::misc::messages.cpp
new file mode 100644
index 000000000000..e319c6e27ff5
--- /dev/null
+++ b/emulators/dosbox/files/patch-src::misc::messages.cpp
@@ -0,0 +1,12 @@
+--- src/misc/messages.cpp.orig Tue Jul 30 15:13:10 2002
++++ src/misc/messages.cpp Tue Sep 3 09:29:12 2002
+@@ -101,7 +101,7 @@
+ /* Load the messages from "dosbox.lang file" */
+ first_message=0;
+ char filein[CROSS_LEN];
+- strcpy(filein,dosbox_basedir);
+- strcat(filein,"dosbox.lang");
++ strcpy(filein,"@@PREFIX@@/share/dosbox/dosbox.lang");
++/* strcat(filein,"dosbox.lang"); */
+ LoadMessageFile(filein);
+ }
diff --git a/emulators/dosbox/pkg-descr b/emulators/dosbox/pkg-descr
new file mode 100644
index 000000000000..525e6a3f1f55
--- /dev/null
+++ b/emulators/dosbox/pkg-descr
@@ -0,0 +1,13 @@
+DOSBox is an emulator of a PC with dos.
+The main focus of this project is emulating old dos games using the
+local file system for files.
+
+Currently emulated is:
+
+o CPU:286/386 realmode
+o GFX:VGA/EGS/CGA
+o SND:PC-Speaker/Tandy 3-Voice/Adlib/SoundBlaster
+o MSC:Keyboard/Mouse
+o DOS:Director FileSystem/XMS/EMS
+
+WWW: http://dosbox.zophar.net/
diff --git a/emulators/dosbox/pkg-plist b/emulators/dosbox/pkg-plist
new file mode 100644
index 000000000000..5e8f980652db
--- /dev/null
+++ b/emulators/dosbox/pkg-plist
@@ -0,0 +1,6 @@
+bin/dosbox
+share/dosbox/dosbox.lang
+@dirrm share/dosbox
+%%PORTDOCS%%share/doc/dosbox/NEWS
+%%PORTDOCS%%share/doc/dosbox/README
+%%PORTDOCS%%@dirrm share/doc/dosbox