aboutsummaryrefslogtreecommitdiff
path: root/emulators/dosbox
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-05-30 07:02:51 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-05-30 07:02:51 +0000
commita2345d72dd69725b312ece9c9da0384051227585 (patch)
tree295729d859c4c1b0f017e09fd4271487a1f5c4db /emulators/dosbox
parentd13d39b57127484e25811a5916ec65b49c64edf8 (diff)
downloadports-a2345d72dd69725b312ece9c9da0384051227585.tar.gz
ports-a2345d72dd69725b312ece9c9da0384051227585.zip
Notes
Diffstat (limited to 'emulators/dosbox')
-rw-r--r--emulators/dosbox/Makefile2
-rw-r--r--emulators/dosbox/files/patch-src::cpu::core_dyn_x86.cpp11
2 files changed, 13 insertions, 0 deletions
diff --git a/emulators/dosbox/Makefile b/emulators/dosbox/Makefile
index 81ba8ee2b279..dea4fce93db6 100644
--- a/emulators/dosbox/Makefile
+++ b/emulators/dosbox/Makefile
@@ -27,6 +27,8 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS+= --enable-core-inline
+USE_GCC= 3.2+
+
post-patch:
@${REINPLACE_CMD} -e 's#\/usr\/share\/doc\/dosbox#${DOCSDIR}#g' \
${WRKSRC}/docs/dosbox.1
diff --git a/emulators/dosbox/files/patch-src::cpu::core_dyn_x86.cpp b/emulators/dosbox/files/patch-src::cpu::core_dyn_x86.cpp
new file mode 100644
index 000000000000..9d276f8e9cad
--- /dev/null
+++ b/emulators/dosbox/files/patch-src::cpu::core_dyn_x86.cpp
@@ -0,0 +1,11 @@
+--- src/cpu/core_dyn_x86.cpp.orig Thu Feb 9 12:32:52 2006
++++ src/cpu/core_dyn_x86.cpp Thu May 25 22:58:53 2006
+@@ -22,6 +22,8 @@
+
+ #define CHECKED_MEMORY_ACCESS
+
++#include <sys/types.h>
++
+ #include <assert.h>
+ #include <stdarg.h>
+ #include <stdio.h>