aboutsummaryrefslogtreecommitdiff
path: root/emulators/dynagen
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-06-11 16:38:50 +0000
committerJohn Marino <marino@FreeBSD.org>2014-06-11 16:38:50 +0000
commit3c67b90bc023e661a4c9e2b161be4e38586d63fc (patch)
tree35397015d999482bb685e98e9468f08539d80a7b /emulators/dynagen
parent1ec1ad3645ad44090c37262d1c9426203b948a68 (diff)
downloadports-3c67b90bc023e661a4c9e2b161be4e38586d63fc.tar.gz
ports-3c67b90bc023e661a4c9e2b161be4e38586d63fc.zip
emulators/dynagen: Add stage support
In addition: * Update maintainer address * minor tweaks PR: 190923 submitted by: maintainer (Pavel Volkoy)
Notes
Notes: svn path=/head/; revision=357506
Diffstat (limited to 'emulators/dynagen')
-rw-r--r--emulators/dynagen/Makefile67
-rw-r--r--emulators/dynagen/files/patch-setup.py6
-rw-r--r--emulators/dynagen/pkg-deinstall6
-rw-r--r--emulators/dynagen/pkg-descr2
-rw-r--r--emulators/dynagen/pkg-install4
5 files changed, 33 insertions, 52 deletions
diff --git a/emulators/dynagen/Makefile b/emulators/dynagen/Makefile
index dfa1c809ec19..f087cef122e5 100644
--- a/emulators/dynagen/Makefile
+++ b/emulators/dynagen/Makefile
@@ -3,21 +3,21 @@
PORTNAME= dynagen
PORTVERSION= 0.11.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators
-MASTER_SITES= SF/dyna-gen/${PORTNAME}%20source%20_%20Linux/${PORTNAME}%20${PORTVERSION}
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= dyna-gen/${PORTNAME}%20source%20_%20Linux/${PORTNAME}%20${PORTVERSION}
-MAINTAINER= pavelivolkov@googlemail.com
+MAINTAINER= pavelivolkov@gmail.com
COMMENT= Text-based front end for Dynamips development version
LICENSE= GPLv2
-# Note that it *should* be dynamips-devel but that port installs it as dynamips
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}configobj>=4.4.0:${PORTSDIR}/devel/py-configobj \
dynamips:${PORTSDIR}/emulators/dynamips-community
PLIST_FILES= bin/dynagen \
- etc/dynagen.ini.sample \
+ "@sample etc/dynagen.ini.sample" \
%%PYTHON_SITELIBDIR%%/confConsole.py \
%%PYTHON_SITELIBDIR%%/confConsole.pyc \
%%PYTHON_SITELIBDIR%%/confConsole.pyo \
@@ -43,44 +43,35 @@ PORTDATA= *
USES= dos2unix
USE_PYTHON= yes
-USE_PYDISTUTILS= yes
+USE_PYDISTUTILS=yes
ALL_TARGET= # empty
-NO_STAGE= yes
post-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/dynagen ${PREFIX}/bin
- ${INSTALL_DATA} ${WRKSRC}/dynagen.ini ${PREFIX}/etc/dynagen.ini.sample
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ ${INSTALL_SCRIPT} ${WRKSRC}/dynagen ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/dynagen.ini ${STAGEDIR}${PREFIX}/etc/dynagen.ini.sample
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/configspec ${DATADIR}/configspec
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/configspec ${STAGEDIR}${DATADIR}/configspec
-.ifndef NOPORTDOCS
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/docs/tutorial.htm ${DOCSDIR}
- @${MKDIR} ${DOCSDIR}/tutorial_files
- ${INSTALL_DATA} ${WRKSRC}/docs/tutorial_files/* ${DOCSDIR}/tutorial_files
-.endif
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/tutorial.htm ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/tutorial_files
+ ${INSTALL_DATA} ${WRKSRC}/docs/tutorial_files/* ${STAGEDIR}${DOCSDIR}/tutorial_files
-.ifndef NOPORTEXAMPLES
- @${MKDIR} ${EXAMPLESDIR}
- @${MKDIR} ${EXAMPLESDIR}/sample_labs
- @${MKDIR} ${EXAMPLESDIR}/sample_labs/ethernet_switch
- ${INSTALL_DATA} ${WRKSRC}/sample_labs/ethernet_switch/ethsw1.net ${EXAMPLESDIR}/sample_labs/ethernet_switch
- @${MKDIR} ${EXAMPLESDIR}/sample_labs/frame_relay
- ${INSTALL_DATA} ${WRKSRC}/sample_labs/frame_relay/frame_relay1.net ${EXAMPLESDIR}/sample_labs/frame_relay
- @${MKDIR} ${EXAMPLESDIR}/sample_labs/multiserver
- ${INSTALL_DATA} ${WRKSRC}/sample_labs/multiserver/multiserver.net ${EXAMPLESDIR}/sample_labs/multiserver
- @${MKDIR} ${EXAMPLESDIR}/sample_labs/pix
- ${INSTALL_DATA} ${WRKSRC}/sample_labs/pix/pixtest.net ${EXAMPLESDIR}/sample_labs/pix
- @${MKDIR} ${EXAMPLESDIR}/sample_labs/simple1
- ${INSTALL_DATA} ${WRKSRC}/sample_labs/simple1/simple1.net ${EXAMPLESDIR}/sample_labs/simple1
- @${MKDIR} ${EXAMPLESDIR}/sample_labs/simple2
- ${INSTALL_DATA} ${WRKSRC}/sample_labs/simple2/simple2.net ${EXAMPLESDIR}/sample_labs/simple2
- ${INSTALL_DATA} ${WRKSRC}/sample_labs/all_config_options.txt ${EXAMPLESDIR}/sample_labs
-.endif
-
-pre-deinstall:
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGDEINSTALL} ${PKGNAME} DEINSTALL
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/sample_labs
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/sample_labs/ethernet_switch
+ ${INSTALL_DATA} ${WRKSRC}/sample_labs/ethernet_switch/ethsw1.net ${STAGEDIR}${EXAMPLESDIR}/sample_labs/ethernet_switch
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/sample_labs/frame_relay
+ ${INSTALL_DATA} ${WRKSRC}/sample_labs/frame_relay/frame_relay1.net ${STAGEDIR}${EXAMPLESDIR}/sample_labs/frame_relay
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/sample_labs/multiserver
+ ${INSTALL_DATA} ${WRKSRC}/sample_labs/multiserver/multiserver.net ${STAGEDIR}${EXAMPLESDIR}/sample_labs/multiserver
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/sample_labs/pix
+ ${INSTALL_DATA} ${WRKSRC}/sample_labs/pix/pixtest.net ${STAGEDIR}${EXAMPLESDIR}/sample_labs/pix
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/sample_labs/simple1
+ ${INSTALL_DATA} ${WRKSRC}/sample_labs/simple1/simple1.net ${STAGEDIR}${EXAMPLESDIR}/sample_labs/simple1
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/sample_labs/simple2
+ ${INSTALL_DATA} ${WRKSRC}/sample_labs/simple2/simple2.net ${STAGEDIR}${EXAMPLESDIR}/sample_labs/simple2
+ ${INSTALL_DATA} ${WRKSRC}/sample_labs/all_config_options.txt ${STAGEDIR}${EXAMPLESDIR}/sample_labs
.include <bsd.port.mk>
diff --git a/emulators/dynagen/files/patch-setup.py b/emulators/dynagen/files/patch-setup.py
index 7814fd41057f..c42bb6988cff 100644
--- a/emulators/dynagen/files/patch-setup.py
+++ b/emulators/dynagen/files/patch-setup.py
@@ -15,9 +15,9 @@
+ author = "Greg Anuzelli",
+ author_email = "dynagen@gmail.com",
+ url = "http://sourceforge.net/projects/dyna-gen",
-+
-+ py_modules = ['confConsole','console','dynamips_lib',
-+ 'pemu_lib', 'pemubin', 'pemuwrapper']
++ license = "GPLv2",
++ long_description = """Dynagen is a utility for use with the dynamips Cisco router simulator. It allows you to quickly provision and manage virtual networks using an INI like configuration file.""",
++ py_modules = ['confConsole','console','dynamips_lib','pemu_lib', 'pemubin', 'pemuwrapper']
+)
+
+print "If you have installed the modules, copy dynagen to some "
diff --git a/emulators/dynagen/pkg-deinstall b/emulators/dynagen/pkg-deinstall
index 832f1b7289a7..e69de29bb2d1 100644
--- a/emulators/dynagen/pkg-deinstall
+++ b/emulators/dynagen/pkg-deinstall
@@ -1,6 +0,0 @@
-#!/bin/sh
-if [ "$2" = "DEINSTALL" ]; then
- cmp -s -z "${PKG_PREFIX}/etc/dynagen.ini.sample" "${PKG_PREFIX}/etc/dynagen.ini" && \
- rm -f "${PKG_PREFIX}/etc/dynagen.ini"
-fi
-exit 0
diff --git a/emulators/dynagen/pkg-descr b/emulators/dynagen/pkg-descr
index 4da72d1abb37..6ba7f0213e22 100644
--- a/emulators/dynagen/pkg-descr
+++ b/emulators/dynagen/pkg-descr
@@ -6,4 +6,4 @@ specifying bridges, frame-relay, ATM switches, etc. It also provides
a management CLI for listing devices, suspending and reloading
instances, etc.
-WWW: http://dyna-gen.sourceforge.net/
+WWW: http://dyna-gen.sourceforge.net/
diff --git a/emulators/dynagen/pkg-install b/emulators/dynagen/pkg-install
index 1a2f20b07d19..e69de29bb2d1 100644
--- a/emulators/dynagen/pkg-install
+++ b/emulators/dynagen/pkg-install
@@ -1,4 +0,0 @@
-#!/bin/sh
-[ "$2" = "POST-INSTALL" -a ! -e ${PKG_PREFIX}/etc/dynagen.ini ] && \
- cp -p ${PKG_PREFIX}/etc/dynagen.ini.sample ${PKG_PREFIX}/etc/dynagen.ini
-exit 0