aboutsummaryrefslogtreecommitdiff
path: root/emulators/dynamips-community
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-08-02 16:39:13 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-08-02 16:39:13 +0000
commit421607b9019cdfbef8ad7566995b2d22b63ef86a (patch)
treec0b7249c3e0e8bc6138ecb19b2f05f1f5148bdb2 /emulators/dynamips-community
parent7299f2d25b10f1250b71276d16f905e56ff331f6 (diff)
downloadports-421607b9019cdfbef8ad7566995b2d22b63ef86a.tar.gz
ports-421607b9019cdfbef8ad7566995b2d22b63ef86a.zip
Notes
Diffstat (limited to 'emulators/dynamips-community')
-rw-r--r--emulators/dynamips-community/Makefile34
-rw-r--r--emulators/dynamips-community/distinfo4
-rw-r--r--emulators/dynamips-community/files/patch-Makefile24
-rw-r--r--emulators/dynamips-community/files/patch-common_fs_nvram.c9
-rw-r--r--emulators/dynamips-community/files/patch-stable_Makefile20
-rw-r--r--emulators/dynamips-community/files/patch-unstable_Makefile11
-rw-r--r--emulators/dynamips-community/pkg-descr2
7 files changed, 15 insertions, 89 deletions
diff --git a/emulators/dynamips-community/Makefile b/emulators/dynamips-community/Makefile
index 3379db5df9bb..b0517d982167 100644
--- a/emulators/dynamips-community/Makefile
+++ b/emulators/dynamips-community/Makefile
@@ -2,11 +2,10 @@
# $FreeBSD$
PORTNAME= dynamips
-PORTVERSION= 0.2.12
+PORTVERSION= 0.2.15
+DISTVERSIONPREFIX= v
CATEGORIES= emulators
-MASTER_SITES= SF/gns-3/Dynamips/${PORTVERSION}
PKGNAMESUFFIX= -community
-DISTNAME= ${PORTNAME}-${PORTVERSION}-source
MAINTAINER= pavelivolkov@gmail.com
COMMENT= Cisco 1700/2600/3600/3700/7200 Simulator
@@ -18,15 +17,14 @@ LIB_DEPENDS= libelf.so:${PORTSDIR}/devel/libelf \
CONFLICTS= dynamips-[0-9]* dynamips-devel-[0-9]*
-USES= gmake zip
-MAKE_JOBS_UNSAFE= yes
+USES= cmake
+USE_GITHUB= yes
-OPTIONS_DEFINE= DOCS UNSTABLE
-UNSTABLE_DESC= development code (x64 Mac)
+MAKE_JOBS_UNSAFE= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+GH_ACCOUNT= GNS3
+GH_PROJECT= dynamips
-LDFLAGS+= -luuid
MAKE_ENV= DYNAMIPS_CODE=${DYNAMIPS_CODE} \
DYNAMIPS_ARCH=${DYNAMIPS_ARCH}
@@ -38,27 +36,19 @@ PLIST_FILES= bin/${PORTNAME} bin/nvram_export \
PORTDOCS= *
-.if ${PORT_OPTIONS:MUNSTABLE}
-DYNAMIPS_CODE= unstable
-.else
DYNAMIPS_CODE= stable
-.endif
-
-.if ${ARCH} == powerpc && ${DYNAMIPS_CODE} == unstable
-DYNAMIPS_ARCH= ppc32
-.endif
.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1000000
DYNAMIPS_ARCH= nojit
.endif
-#BROKEN_ia64= does not compile: invokes i386 assembler
-#BROKEN_sparc64= ${BROKEN_ia64}
-#BROKEN_powerpc= ${BROKEN_ia64}
+BROKEN_ia64= does not compile: invokes i386 assembler
+BROKEN_sparc64= ${BROKEN_ia64}
+BROKEN_powerpc= ${BROKEN_ia64}
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}.${DYNAMIPS_CODE} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
- ${INSTALL_PROGRAM} ${WRKSRC}/nvram_export.${DYNAMIPS_CODE} ${STAGEDIR}${PREFIX}/bin/nvram_export
+ ${INSTALL_PROGRAM} ${WRKSRC}/${DYNAMIPS_CODE}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${DYNAMIPS_CODE}/nvram_export ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/man/nvram_export.1 ${STAGEDIR}${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/man/hypervisor_mode.7 ${STAGEDIR}${MANPREFIX}/man/man7
diff --git a/emulators/dynamips-community/distinfo b/emulators/dynamips-community/distinfo
index 2f5cc2eaba5d..bdabff4725ca 100644
--- a/emulators/dynamips-community/distinfo
+++ b/emulators/dynamips-community/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dynamips-0.2.12-source.zip) = b8a60c2ff577ec3a5c2b892bce654a68cc072c79fbca2b708d36d42bd3e9eb12
-SIZE (dynamips-0.2.12-source.zip) = 995877
+SHA256 (GNS3-dynamips-v0.2.15_GH0.tar.gz) = 4f77a88470069dccab391ce786b633061511593efbd0a9b895e5711325eceb36
+SIZE (GNS3-dynamips-v0.2.15_GH0.tar.gz) = 839493
diff --git a/emulators/dynamips-community/files/patch-Makefile b/emulators/dynamips-community/files/patch-Makefile
deleted file mode 100644
index d54439a3e34c..000000000000
--- a/emulators/dynamips-community/files/patch-Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
---- Makefile.orig 2014-02-10 17:50:38.000000000 +0400
-+++ Makefile 2014-03-03 12:12:12.000000000 +0400
-@@ -4,14 +4,15 @@
- # - Use "x86" for a build on x86 (32-bits)
- # - Use "amd64" for a build on x86_64 (64-bits)
- # - Use "nojit" for unsupported architectures.
--ifeq ($(shell arch),x86_64)
--export DYNAMIPS_ARCH?=amd64
-+ifndef DYNAMIPS_ARCH
-+ifneq ($(findstring $(shell uname -m),x86_64 amd64),)
-+DYNAMIPS_ARCH=amd64
-+else ifneq ($(findstring $(shell uname -m),i686 i386),)
-+DYNAMIPS_ARCH=x86
- else
--ifeq ($(shell arch),i686)
--export DYNAMIPS_ARCH?=x86
--else
--export DYNAMIPS_ARCH?=nojit
-+DYNAMIPS_ARCH=nojit
- endif
-+export DYNAMIPS_ARCH
- endif
-
- # For MAC x64 you can compile the "unstable" version, which should work
diff --git a/emulators/dynamips-community/files/patch-common_fs_nvram.c b/emulators/dynamips-community/files/patch-common_fs_nvram.c
deleted file mode 100644
index bed535c8eb00..000000000000
--- a/emulators/dynamips-community/files/patch-common_fs_nvram.c
+++ /dev/null
@@ -1,9 +0,0 @@
---- common/fs_nvram.c.orig 2014-03-03 12:41:30.000000000 +0400
-+++ common/fs_nvram.c 2014-03-03 12:41:46.000000000 +0400
-@@ -862,4 +862,4 @@
- }
-
- return(0);
--}
-\ No newline at end of file
-+}
diff --git a/emulators/dynamips-community/files/patch-stable_Makefile b/emulators/dynamips-community/files/patch-stable_Makefile
deleted file mode 100644
index 561a01cbcc59..000000000000
--- a/emulators/dynamips-community/files/patch-stable_Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
---- stable/Makefile.orig 2014-02-10 17:50:38.000000000 +0400
-+++ stable/Makefile 2014-03-03 12:35:51.000000000 +0400
-@@ -2,6 +2,8 @@
- # Copyright (c) 2005-2006 Christophe Fillot.
- # Copyright (c) 2013 Daniel Lintott.
-
-+$(warning stable DYNAMIPS_ARCH="${DYNAMIPS_ARCH}")
-+
- # Get include files from the current directory and from the common directory
- INCLUDE+=-I. -I../common
-
-@@ -244,7 +246,7 @@
-
- nvram_export$(BIN_EXT): nvram_export.o fs_nvram.o
- @echo "Linking $@"
-- @$(CC) -Wall $(CFLAGS) $(INCLUDE) $(LDFLAGS) -o $@ nvram_export.o fs_nvram.o
-+ @$(CC) -Wall $(CFLAGS) $(INCLUDE) $(LDFLAGS) -o $@ nvram_export.o fs_nvram.o $(LIBS)
-
- .PHONY: clean
- clean:
diff --git a/emulators/dynamips-community/files/patch-unstable_Makefile b/emulators/dynamips-community/files/patch-unstable_Makefile
deleted file mode 100644
index 7038592cb39a..000000000000
--- a/emulators/dynamips-community/files/patch-unstable_Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- unstable/Makefile.orig 2014-03-03 12:37:26.000000000 +0400
-+++ unstable/Makefile 2014-03-03 12:37:56.000000000 +0400
-@@ -249,7 +249,7 @@
-
- nvram_export$(BIN_EXT): nvram_export.o fs_nvram.o
- @echo "Linking $@"
-- @$(CC) -Wall $(CFLAGS) $(INCLUDE) $(LDFLAGS) -o $@ nvram_export.o fs_nvram.o
-+ @$(CC) -Wall $(CFLAGS) $(INCLUDE) $(LDFLAGS) -o $@ nvram_export.o fs_nvram.o $(LIBS)
-
- .PHONY: clean
- clean:
diff --git a/emulators/dynamips-community/pkg-descr b/emulators/dynamips-community/pkg-descr
index e06c57531bc5..58d15f0a7e01 100644
--- a/emulators/dynamips-community/pkg-descr
+++ b/emulators/dynamips-community/pkg-descr
@@ -1,3 +1,3 @@
Cisco 1700/2600/3600/3700/7200 simulator.
-WWW: http://www.gns3.net/dynamips/
+WWW: https://github.com/GNS3/dynamips