aboutsummaryrefslogtreecommitdiff
path: root/emulators/dynamips-devel/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2006-11-14 04:22:00 +0000
committerMax Khon <fjoe@FreeBSD.org>2006-11-14 04:22:00 +0000
commitedd3566211bdb6546cd9d40c760e7aa31e8f10b9 (patch)
treeb7980311a6c8e4b76372ec13340291c6f290b9b4 /emulators/dynamips-devel/Makefile
parent83a38e9ea5a95153b834392e2f2c30db951b4ee8 (diff)
downloadports-edd3566211bdb6546cd9d40c760e7aa31e8f10b9.tar.gz
ports-edd3566211bdb6546cd9d40c760e7aa31e8f10b9.zip
Notes
Diffstat (limited to 'emulators/dynamips-devel/Makefile')
-rw-r--r--emulators/dynamips-devel/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/emulators/dynamips-devel/Makefile b/emulators/dynamips-devel/Makefile
index 6c95a1316dc1..41d9d073fd9f 100644
--- a/emulators/dynamips-devel/Makefile
+++ b/emulators/dynamips-devel/Makefile
@@ -7,12 +7,12 @@
PORTNAME= dynamips
PORTVERSION= 0.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= http://www.ipflow.utc.fr/dynamips/
MAINTAINER= fjoe@FreeBSD.org
-COMMENT= Cisco 7200 Simulator
+COMMENT= Cisco 3600/7200 Simulator
LIB_DEPENDS= elf.0:${PORTSDIR}/devel/libelf
@@ -37,16 +37,19 @@ do-install:
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386" #|| ${ARCH} == "amd64"
-DYNAMIPS_ARCH= "${ARCH}"
+.if ${ARCH} == "i386"
+DYNAMIPS_ARCH= "x86"
+.elif ${ARCH} == "amd64"
+DYNAMIPS_ARCH= "nojit" # JIT does not work on amd64 for some reason
.else
DYNAMIPS_ARCH= "nojit"
.endif
-.if ${OSVERSION} < 600029
+.if ${OSVERSION} < 602100 || ${OSVERSION} < 700021
#
-# Requires libpcap 0.9+
-MAKE_ENV+= HAS_PCAP=0
+# Requires libpcap 0.9.4
+LIB_DEPENDS+= pcap.2:${PORTSDIR}/net/libpcap
+BUILD_DEPENDS+= libpcap>=0.9.4:${PORTSDIR}/net/libpcap
.endif
.if ${OSVERSION} >= 700013