aboutsummaryrefslogtreecommitdiff
path: root/emulators/fceux
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-15 23:02:05 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-15 23:02:05 +0000
commit0731abe759239aa85d997292f64468cceac0260f (patch)
treee7d225b7b2092115d11f1f2743723500e4515ca5 /emulators/fceux
parentd0bfdb90d86f225849c9b5f171929afe64d6f2d7 (diff)
downloadports-0731abe759239aa85d997292f64468cceac0260f.tar.gz
ports-0731abe759239aa85d997292f64468cceac0260f.zip
Notes
Diffstat (limited to 'emulators/fceux')
-rw-r--r--emulators/fceux/Makefile5
-rw-r--r--emulators/fceux/distinfo4
-rw-r--r--emulators/fceux/files/patch-src-movie.c20
3 files changed, 24 insertions, 5 deletions
diff --git a/emulators/fceux/Makefile b/emulators/fceux/Makefile
index 8310eb7406c3..f1330009a7d1 100644
--- a/emulators/fceux/Makefile
+++ b/emulators/fceux/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= fceu
-PORTVERSION= 0.98.10
+PORTVERSION= 0.98.11
CATEGORIES= emulators
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://fceultra.sourceforge.net/releases/
+MASTER_SITES= http://fceultra.sourceforge.net/releases/
MASTER_SITE_SUBDIR= fceultra
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
diff --git a/emulators/fceux/distinfo b/emulators/fceux/distinfo
index 36bfa681216f..a34b5f65c1a8 100644
--- a/emulators/fceux/distinfo
+++ b/emulators/fceux/distinfo
@@ -1,2 +1,2 @@
-MD5 (fceu-0.98.10.src.tar.bz2) = e0b396955b3ef4c7e4b5cc518cdec39f
-SIZE (fceu-0.98.10.src.tar.bz2) = 559750
+MD5 (fceu-0.98.11.src.tar.bz2) = fda762a06c0167b903e4278beccc4760
+SIZE (fceu-0.98.11.src.tar.bz2) = 556643
diff --git a/emulators/fceux/files/patch-src-movie.c b/emulators/fceux/files/patch-src-movie.c
new file mode 100644
index 000000000000..c172724e893a
--- /dev/null
+++ b/emulators/fceux/files/patch-src-movie.c
@@ -0,0 +1,20 @@
+--- src/movie.c.orig Sat Aug 14 07:13:51 2004
++++ src/movie.c Sat Aug 14 07:15:58 2004
+@@ -154,7 +154,7 @@
+
+ void FCEUMOV_AddJoy(uint8 *js)
+ {
+- int x,y;
++ int x,y,tmpfix;
+
+ if(!current) return; /* Not playback nor recording. */
+
+@@ -190,7 +190,7 @@
+ tmp >>= 5;
+ tmp &= 0x3;
+ ti=0;
+- int tmpfix = tmp;
++ tmpfix = tmp;
+ while(tmp--) { nextts |= fgetc(slots[-1 - current]) << (ti * 8); ti++; }
+
+ // This fixes a bug in movies recorded before version 0.98.11