aboutsummaryrefslogtreecommitdiff
path: root/emulators/fceux
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-12-27 23:56:01 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-12-27 23:56:01 +0000
commit93bb3e964af10c41270d64c69996f32040e33ae3 (patch)
treef8406cca0bb9e1d03171f7eda081ebfb91a036d2 /emulators/fceux
parent87f43fa80f188ef792510fd26ee30857852f6a4a (diff)
downloadports-93bb3e964af10c41270d64c69996f32040e33ae3.tar.gz
ports-93bb3e964af10c41270d64c69996f32040e33ae3.zip
Notes
Diffstat (limited to 'emulators/fceux')
-rw-r--r--emulators/fceux/Makefile26
-rw-r--r--emulators/fceux/distinfo2
-rw-r--r--emulators/fceux/files/patch-Makefile.unixsdl14
-rw-r--r--emulators/fceux/pkg-plist11
4 files changed, 29 insertions, 24 deletions
diff --git a/emulators/fceux/Makefile b/emulators/fceux/Makefile
index 206eb3cebec6..f8cf769423c9 100644
--- a/emulators/fceux/Makefile
+++ b/emulators/fceux/Makefile
@@ -6,17 +6,15 @@
#
PORTNAME= fceu
-PORTVERSION= 0.96
-PORTREVISION= 1
+PORTVERSION= 0.97.5
CATEGORIES= emulators
-MASTER_SITES= http://fceultra.sourceforge.net/files/
-DISTNAME= fceu${PORTVERSION:S/.//}src
+MASTER_SITES= http://xodnizel.net/fceultra/downloads/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= gibbon@cocoa.freemail.ne.jp
COMMENT= A portable NES/Famicom emulator based on Bero's original FCE
-LIB_DEPENDS= SDL-1.1:${PORTSDIR}/devel/sdl12
-
+USE_SDL= yes
MAN6= fceu.6
WRKSRC= ${WRKDIR}/fceu
USE_X_PREFIX= yes
@@ -25,16 +23,17 @@ MAKEFILE= Makefile.unixsdl
USE_REINPLACE= yes
DOCS= AUTHORS COPYING ChangeLog FAQ README TODO \
- cheat.txt fcs.txt porting.txt rel/readme-linux.txt
+ cheat.html fceultra.html fcs.txt porting.txt protocol.txt
TECHDOCS= README.now README.sound UNIF_current.txt nsfspec.txt
TECHCPUDOC= 4017.txt 6502_cpu.txt NESSOUND-4th.txt NESSOUND.txt dmc.txt
-TECHEXPDOCS= mmc5-e.txt mmc5_bank_switch.txt
-TECHPPUDOCS= "2C02\technical\operation.TXT" loopy1.txt loopy2.txt
+TECHEXPDOCS= SMB2j.txt mmc5-e.txt mmc5_bank_switch.txt tengen.txt \
+ vrcvi.txt vrcvii.txt
+TECHPPUDOCS= "2C02_technical_operation.TXT" loopy1.txt loopy2.txt
.if defined(WITH_OPTIMIZED_FLAGS)
CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -malign-double
.if (${MACHINE_ARCH} == "i386")
-CFLAGS+= -mfancy-math-387
+CFLAGS+= -ffast-math -mfancy-math-387
.endif # i386
.endif
@@ -56,7 +55,6 @@ PLIST_SUB= TECHDOCS="@comment "
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e 's+%%LOCALBASE%%+${LOCALBASE}+g;' ${WRKSRC}/Makefile.unixsdl
.if (${MACHINE_ARCH} != "i386")
# do I have to do this for ia64 and amd64 too?
@${REINPLACE_CMD} -e 's|-DC80x86||g;' ${WRKSRC}/Makefile.unixsdl
@@ -70,6 +68,7 @@ pre-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fceu ${PREFIX}/bin
+
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.if !defined(NOPORTDOCS)
@@ -77,6 +76,7 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/Documentation/${docs} ${DOCSDIR}
.endfor
.endif
+
.if !defined(NOPORTDOCS)
${INSTALL_MAN} ${WRKSRC}/Documentation/fceu.6 ${PREFIX}/man/man6
.if defined(TECH_DOC_INSTALL)
@@ -96,8 +96,8 @@ do-install:
.endfor
@${MKDIR} ${DOCSDIR}/tech/ppu
.for docs in ${TECHPPUDOCS}
- ${INSTALL_DATA} ${WRKSRC}/Documentation/tech/ppu/${docs:S/\\/ /g} \
- ${DOCSDIR}/tech/ppu
+ ${INSTALL_DATA} ${WRKSRC}/Documentation/tech/ppu/${docs:S|_| |g} \
+ ${DOCSDIR}/tech/ppu/${docs}
.endfor
.endif
.endif
diff --git a/emulators/fceux/distinfo b/emulators/fceux/distinfo
index 18b73106c617..4fa3ac30219b 100644
--- a/emulators/fceux/distinfo
+++ b/emulators/fceux/distinfo
@@ -1 +1 @@
-MD5 (fceu096src.tar.gz) = 26934713c1f64f20a3f4f8a2dba0f9fb
+MD5 (fceu-0.97.5.src.tar.gz) = a3a3732d58ddb66ae9a78b2bac1d6a1f
diff --git a/emulators/fceux/files/patch-Makefile.unixsdl b/emulators/fceux/files/patch-Makefile.unixsdl
index 6fabf2caba4b..27703203be6e 100644
--- a/emulators/fceux/files/patch-Makefile.unixsdl
+++ b/emulators/fceux/files/patch-Makefile.unixsdl
@@ -1,18 +1,18 @@
---- Makefile.unixsdl.orig Fri Jun 20 12:50:03 2003
-+++ Makefile.unixsdl Mon Jul 21 07:53:48 2003
+--- Makefile.unixsdl.orig Mon Nov 10 12:33:14 2003
++++ Makefile.unixsdl Tue Dec 9 01:13:35 2003
@@ -1,5 +1,5 @@
CC = gcc
--TFLAGS = -DFRAMESKIP -DSTDIOIFACE -DUNIXDSP -DNETWORK -DFPS `sdl-config --cflags` -mcpu=i686 -O2 -Izlib -fomit-frame-pointer -DC80x86 -DLSB_FIRST -DSDL -DUNIX -DPSS_STYLE=1 -DZLIB
-+TFLAGS = -DFRAMESKIP -DSTDIOIFACE -DUNIXDSP -DNETWORK -DFPS `%%LOCALBASE%%/bin/sdl11-config --cflags` -Izlib -fomit-frame-pointer -DC80x86 -DLSB_FIRST -DSDL -DUNIX -DPSS_STYLE=1 -DZLIB
+-TFLAGS = -DOPENGL -DFRAMESKIP -DUNIXDSP -DNETWORK -DFPS `sdl-config --cflags` -mcpu=i686 -O2 -Izlib -fomit-frame-pointer -DLSB_FIRST -DSDL -DUNIX -DPSS_STYLE=1 -DZLIB -DC80x86
++TFLAGS = -DOPENGL -DFRAMESKIP -DUNIXDSP -DNETWORK -DFPS `${SDL_CONFIG} --cflags` -I/usr/X11R6/include -Izlib -DLSB_FIRST -DSDL -DUNIX -DPSS_STYLE=1 -DZLIB -DC80x86
RM = rm -f
B = drivers/cli/
@@ -9,7 +9,7 @@
include zlib/Makefile
- OBJDRIVER = ${B}sdl.o ${B}interface.o ${B}main.o ${B}sdl-throttle.o ${B}unix-netplay.o ${B}sdl-sound.o ${B}sdl-video.o ${B}sdl-joystick.o drivers/common/cheat.o drivers/common/config.o drivers/common/args.o drivers/common/vidblit.o drivers/common/unixdsp.o ${UNZIPOBJS}
--LDRIVER = -lm `sdl-config --libs` -lz
-+LDRIVER = -lm `%%LOCALBASE%%/bin/sdl11-config --libs` -lz
+ OBJDRIVER = ${B}sdl.o ${B}sdl-opengl.o ${B}main.o ${B}sdl-throttle.o ${B}unix-netplay.o ${B}sdl-sound.o ${B}sdl-video.o ${B}sdl-joystick.o drivers/common/cheat.o drivers/common/config.o drivers/common/args.o drivers/common/vidblit.o drivers/common/unixdsp.o drivers/common/sfifo.o ${UNZIPOBJS}
+-LDRIVER = -lm `sdl-config --libs` -lz -lGL
++LDRIVER = -lm `${SDL_CONFIG} --libs` -lz -lGL -L/usr/X11R6/lib
include Makefile.base
diff --git a/emulators/fceux/pkg-plist b/emulators/fceux/pkg-plist
index 127ef2da2150..763f0046771f 100644
--- a/emulators/fceux/pkg-plist
+++ b/emulators/fceux/pkg-plist
@@ -5,10 +5,11 @@ bin/fceu
%%PORTDOCS%%%%DOCSDIR%%/FAQ
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/TODO
-%%PORTDOCS%%%%DOCSDIR%%/cheat.txt
+%%PORTDOCS%%%%DOCSDIR%%/cheat.html
+%%PORTDOCS%%%%DOCSDIR%%/fceultra.html
%%PORTDOCS%%%%DOCSDIR%%/fcs.txt
%%PORTDOCS%%%%DOCSDIR%%/porting.txt
-%%PORTDOCS%%%%DOCSDIR%%/readme-linux.txt
+%%PORTDOCS%%%%DOCSDIR%%/protocol.txt
%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/README.now
%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/README.sound
%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/UNIF_current.txt
@@ -18,11 +19,15 @@ bin/fceu
%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/cpu/NESSOUND-4th.txt
%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/cpu/NESSOUND.txt
%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/cpu/dmc.txt
+%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/exp/SMB2j.txt
%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/exp/mmc5-e.txt
%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/exp/mmc5_bank_switch.txt
+%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/exp/tengen.txt
+%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/exp/vrcvi.txt
+%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/exp/vrcvii.txt
%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/ppu/loopy1.txt
%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/ppu/loopy2.txt
-%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/ppu/2C02 technical operation.TXT
+%%PORTDOCS%%%%TECHDOCS%%%%DOCSDIR%%/tech/ppu/2C02_technical_operation.TXT
%%PORTDOCS%%%%TECHDOCS%%@dirrm %%DOCSDIR%%/tech/ppu
%%PORTDOCS%%%%TECHDOCS%%@dirrm %%DOCSDIR%%/tech/exp
%%PORTDOCS%%%%TECHDOCS%%@dirrm %%DOCSDIR%%/tech/cpu