aboutsummaryrefslogtreecommitdiff
path: root/emulators/fmsx
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2007-11-15 22:22:16 +0000
committerMax Khon <fjoe@FreeBSD.org>2007-11-15 22:22:16 +0000
commita557de663f75ce2fff7be3b4d8aedc02056ed5a1 (patch)
tree89d616baa5f5052cc0dc1010a4cc6c39fdaa90c4 /emulators/fmsx
parentb1f1582edfd767592ae9c31d2e85c26861310b0c (diff)
downloadports-a557de663f75ce2fff7be3b4d8aedc02056ed5a1.tar.gz
ports-a557de663f75ce2fff7be3b4d8aedc02056ed5a1.zip
Notes
Diffstat (limited to 'emulators/fmsx')
-rw-r--r--emulators/fmsx/Makefile4
-rw-r--r--emulators/fmsx/files/patch-Patch.c18
2 files changed, 18 insertions, 4 deletions
diff --git a/emulators/fmsx/Makefile b/emulators/fmsx/Makefile
index bf92f13f9a90..cb70f945dac5 100644
--- a/emulators/fmsx/Makefile
+++ b/emulators/fmsx/Makefile
@@ -35,10 +35,6 @@ OPTIONS= BPP8 "With BPP8" Off \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
post-patch:
.ifdef(WITH_BPP32) || defined(PACKAGE_BUILDING) || defined(BATCH)
${REINPLACE_CMD} -e 's/%%BPP%%/BPP32/' ${WRKSRC}/Makefile
diff --git a/emulators/fmsx/files/patch-Patch.c b/emulators/fmsx/files/patch-Patch.c
new file mode 100644
index 000000000000..4283dd96e961
--- /dev/null
+++ b/emulators/fmsx/files/patch-Patch.c
@@ -0,0 +1,18 @@
+--- Patch.c.orig 2007-11-16 02:31:51.000000000 +0600
++++ Patch.c 2007-11-16 02:35:41.000000000 +0600
+@@ -24,15 +24,6 @@
+
+ void SSlot(byte Value); /* Used to switch secondary slots */
+
+-#ifdef FMSX
+-extern byte *RAM[],PSL[],SSLReg;
+-static byte RdZ80(word A)
+-{
+- if(A!=0xFFFF) return(RAM[A>>13][A&0x1FFF]);
+- else return((PSL[3]==3)? ~SSLReg:RAM[7][0x1FFF]);
+-}
+-#endif
+-
+ /** PatchZ80() ***********************************************/
+ /** Emulate BIOS calls. This function is called on an ED FE **/
+ /** instruction to emulate disk/tape access, etc. **/