aboutsummaryrefslogtreecommitdiff
path: root/emulators/fuse
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2008-02-09 02:13:31 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2008-02-09 02:13:31 +0000
commit1272b0d24d170b1c81547dd7c77dd27f334ca378 (patch)
treede61813524079c0cc4746318d1106f8994038645 /emulators/fuse
parent62d2bc8b244777b67dfc77748ca5d7b088d149e1 (diff)
downloadports-1272b0d24d170b1c81547dd7c77dd27f334ca378.tar.gz
ports-1272b0d24d170b1c81547dd7c77dd27f334ca378.zip
Notes
Diffstat (limited to 'emulators/fuse')
-rw-r--r--emulators/fuse/Makefile70
-rw-r--r--emulators/fuse/distinfo6
-rw-r--r--emulators/fuse/files/patch-compat.h11
-rw-r--r--emulators/fuse/files/patch-log2.c18
-rw-r--r--emulators/fuse/files/patch-osssound.c18
-rw-r--r--emulators/fuse/files/patch-svgadisplay.c11
-rw-r--r--emulators/fuse/files/patch-svgakeyboard.c22
-rw-r--r--emulators/fuse/files/patch-svgakeysyms.c11
-rw-r--r--emulators/fuse/pkg-plist3
9 files changed, 24 insertions, 146 deletions
diff --git a/emulators/fuse/Makefile b/emulators/fuse/Makefile
index ab0f25be1834..6f2a88b76c42 100644
--- a/emulators/fuse/Makefile
+++ b/emulators/fuse/Makefile
@@ -6,73 +6,41 @@
#
PORTNAME= fuse
-PORTVERSION= 0.8.0.1
+PORTVERSION= 0.9.0
CATEGORIES= emulators
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= fuse-emulator
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= yuri.pankov@gmail.com
COMMENT= Free Unix (Sinclair ZX-)Spectrum Emulator
-LIB_DEPENDS= spectrum.5:${PORTSDIR}/emulators/libspectrum \
+LIB_DEPENDS= spectrum.6:${PORTSDIR}/emulators/libspectrum \
765.4:${PORTSDIR}/emulators/lib765 \
- xml2.5:${PORTSDIR}/textproc/libxml2 \
- png.5:${PORTSDIR}/graphics/png
+ gcrypt.13:${PORTSDIR}/security/libgcrypt
-WANT_GNOME= yes
-WANT_SDL= yes
-USE_XLIB= yes
-USE_PERL5_BUILD= yes
-USE_GETOPT_LONG= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-plus3-disk-prefix=${LOCALBASE}
-CFLAGS+= `${LOCALBASE}/bin/libpng-config --I_opts` -I${LOCALBASE}/include
+USE_GNOME= libxml2 glib20 gtk20
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
-OPTIONS= SMALLMEM "Low memory compile needed" off \
- GTK "Use GTK1 user interface" off \
- GTK2 "Use GTK2 user interface" on \
- SDL "Use SDL user interface" on \
- SVGALIB "Use SVGAlib user interface" off \
- GCRYPT "Support digital signing of .RZX files" off
+MAN1= fuse.1
-.include <bsd.port.pre.mk>
+OPTIONS= AO "Use libao for audio output" off \
+ SAMPLERATE "Support for better beeper sound quality" on
-# adjust location of manual page
-CONFIGURE_ARGS+= --mandir=${PREFIX}/man
+.include <bsd.port.pre.mk>
-.if defined(WITH_SMALLMEM)
-BROKEN= Does not compile
-CONFIGURE_ARGS+= --enable-smallmem
+.if defined(WITH_AO)
+CONFIGURE_ARGS+=--with-libao
+LIB_DEPENDS+= ao.3:${PORTSDIR}/audio/libao
.endif
-.if !defined(WITHOUT_GTK)
-USE_GNOME= gtk12
+.if !defined(WITHOUT_SAMPLERATE)
+LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
.else
-CONFIGURE_ARGS+= --without-gtk
-.endif
-
-.if defined(WITH_GTK2)
-CONFIGURE_ARGS+= --with-gtk2
-USE_GNOME+= gtk20
-.endif
-
-.if defined(WITH_SDL)
-CONFIGURE_ARGS+= --with-sdl
-USE_SDL= yes
+CONFIGURE_ARGS+=--without-libsamplerate
.endif
-.if defined(WITH_SVGALIB)
-CONFIGURE_ARGS+= --with-svgalib
-LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
-.endif
-
-.if defined(WITH_GCRYPT) || exists(${LOCALBASE}/include/gcrypt.h)
-CONFIGURE_ENV+= LDFLAGS="-L${LOCALBASE}/lib"
-LIB_DEPENDS+= gcrypt.13:${PORTSDIR}/security/libgcrypt
-.endif
-
-MAN1= fuse.1
-
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${DOCSDIR}
diff --git a/emulators/fuse/distinfo b/emulators/fuse/distinfo
index 2ab1334396d3..2a11a8a403a4 100644
--- a/emulators/fuse/distinfo
+++ b/emulators/fuse/distinfo
@@ -1,3 +1,3 @@
-MD5 (fuse-0.8.0.1.tar.gz) = 34f85578c64d94ebf0cca309f837d502
-SHA256 (fuse-0.8.0.1.tar.gz) = 6e00199c7025ec47885002928237fd408444ace399e58146016a1c0b8d11f4b0
-SIZE (fuse-0.8.0.1.tar.gz) = 1270551
+MD5 (fuse-0.9.0.tar.gz) = e6434ae8d5d97613c5ae0c7d42df0e49
+SHA256 (fuse-0.9.0.tar.gz) = 9db37ce95450d1a6a62d1b177f0a62aaa9866347fb8bb9342a1649584d325ea7
+SIZE (fuse-0.9.0.tar.gz) = 1371359
diff --git a/emulators/fuse/files/patch-compat.h b/emulators/fuse/files/patch-compat.h
deleted file mode 100644
index 68110410f463..000000000000
--- a/emulators/fuse/files/patch-compat.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- compat.h.orig Sat Sep 13 16:53:04 2003
-+++ compat.h Tue Oct 28 12:48:07 2003
-@@ -45,7 +45,7 @@
-
- /* Replacement functions */
- #ifndef HAVE_GETOPT_LONG
--#include "compat/getopt.h"
-+#include "getopt.h"
- #endif /* #ifndef HAVE_GETOPT_LONG */
-
- #ifndef HAVE_MKSTEMP
diff --git a/emulators/fuse/files/patch-log2.c b/emulators/fuse/files/patch-log2.c
deleted file mode 100644
index e79dba5fd88d..000000000000
--- a/emulators/fuse/files/patch-log2.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- sound/sdlsound.c.orig 2007-04-27 23:18:27.000000000 +0200
-+++ sound/sdlsound.c 2007-07-29 14:54:59.000000000 +0200
-@@ -52,6 +52,15 @@
- /* Records sound writer status information */
- static int audio_output_started;
-
-+/*
-+ * log2() seems to be a Linuxism, define it here as it is absent in libm
-+ */
-+double
-+log2(double x)
-+{
-+ return log(x)/log(2);
-+}
-+
- int
- sound_lowlevel_init( const char *device, int *freqptr, int *stereoptr )
- {
diff --git a/emulators/fuse/files/patch-osssound.c b/emulators/fuse/files/patch-osssound.c
deleted file mode 100644
index a91dc2cddf76..000000000000
--- a/emulators/fuse/files/patch-osssound.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- sound/osssound.c.orig Sat Sep 13 16:53:12 2003
-+++ sound/osssound.c Tue Oct 28 17:19:06 2003
-@@ -107,6 +107,7 @@
- return 1;
- }
-
-+#if 0
- if(*freqptr>8250) frag++;
- if(*freqptr>16500) frag++;
- if(*freqptr>33000) frag++;
-@@ -118,6 +119,7 @@
- close(soundfd);
- return 1;
- }
-+#endif
-
- return 0; /* success */
- }
diff --git a/emulators/fuse/files/patch-svgadisplay.c b/emulators/fuse/files/patch-svgadisplay.c
deleted file mode 100644
index 17a15d4cb76f..000000000000
--- a/emulators/fuse/files/patch-svgadisplay.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ui/svga/svgadisplay.c.orig 2007-07-29 14:53:05.000000000 +0200
-+++ ui/svga/svgadisplay.c 2007-07-29 14:53:45.000000000 +0200
-@@ -258,7 +258,7 @@
- scaled_x = scale * x; scaled_y = scale * y;
-
- /* Create scaled image */
-- scaler_proc16( (libspectrum_byte*)&svgadisplay_image[y][x], display_pitch,
-+ scaler_proc16( (libspectrum_byte*)&svgadisplay_image[y][x], svgadisplay_pitch,
- (libspectrum_byte*)&scaled_image[scaled_y][scaled_x],
- scaled_pitch, w, h );
-
diff --git a/emulators/fuse/files/patch-svgakeyboard.c b/emulators/fuse/files/patch-svgakeyboard.c
deleted file mode 100644
index edfc31a6b5d2..000000000000
--- a/emulators/fuse/files/patch-svgakeyboard.c
+++ /dev/null
@@ -1,22 +0,0 @@
---- ui/svga/svgakeyboard.c.orig 2007-07-29 14:59:10.000000000 +0200
-+++ ui/svga/svgakeyboard.c 2007-07-29 15:10:19.000000000 +0200
-@@ -75,7 +75,8 @@
- if( fuse_keysym == INPUT_KEY_NONE ) return 0;
-
- fuse_event.type = INPUT_EVENT_KEYPRESS;
-- fuse_event.types.key.key = fuse_keysym;
-+ fuse_event.types.key.native_key = fuse_keysym;
-+ fuse_event.types.key.spectrum_key = fuse_keysym;
-
- return input_event( &fuse_event );
- }
-@@ -91,7 +92,8 @@
- if( fuse_keysym == INPUT_KEY_NONE ) return 0;
-
- fuse_event.type = INPUT_EVENT_KEYRELEASE;
-- fuse_event.types.key.key = fuse_keysym;
-+ fuse_event.types.key.native_key = fuse_keysym;
-+ fuse_event.types.key.spectrum_key = fuse_keysym;
-
- return input_event( &fuse_event );
- }
diff --git a/emulators/fuse/files/patch-svgakeysyms.c b/emulators/fuse/files/patch-svgakeysyms.c
deleted file mode 100644
index c0f582ddd403..000000000000
--- a/emulators/fuse/files/patch-svgakeysyms.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- ui/svga/keysyms.c.orig 2007-07-29 15:36:40.000000000 +0200
-+++ ui/svga/keysyms.c 2007-07-29 15:36:48.000000000 +0200
-@@ -116,7 +116,7 @@
- { SCANCODE_CURSORBLOCKLEFT, INPUT_KEY_Left },
- { SCANCODE_CURSORBLOCKRIGHT, INPUT_KEY_Right },
- { SCANCODE_INSERT, INPUT_KEY_Insert },
-- { SCANCODE_DELETE, INPUT_KEY_Delete },
-+ { SCANCODE_REMOVE, INPUT_KEY_Delete },
- { SCANCODE_HOME, INPUT_KEY_Home },
- { SCANCODE_END, INPUT_KEY_End },
- { SCANCODE_PAGEUP, INPUT_KEY_Page_Up },
diff --git a/emulators/fuse/pkg-plist b/emulators/fuse/pkg-plist
index d0b386d13fa1..2015c5962596 100644
--- a/emulators/fuse/pkg-plist
+++ b/emulators/fuse/pkg-plist
@@ -11,7 +11,7 @@ bin/fuse
%%DATADIR%%/48.rom
%%DATADIR%%/cassette.bmp
%%DATADIR%%/disk_plus3.szx
-%%DATADIR%%/fuse.font
+%%DATADIR%%/gluck.rom
%%DATADIR%%/if1-1.rom
%%DATADIR%%/if1-2.rom
%%DATADIR%%/keyboard.scr
@@ -27,6 +27,7 @@ bin/fuse
%%DATADIR%%/plus3e-1.rom
%%DATADIR%%/plus3e-2.rom
%%DATADIR%%/plus3e-3.rom
+%%DATADIR%%/plusd.rom
%%DATADIR%%/se-0.rom
%%DATADIR%%/se-1.rom
%%DATADIR%%/tape_128.szx