aboutsummaryrefslogtreecommitdiff
path: root/emulators/fuse
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /emulators/fuse
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
downloadports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.tar.gz
ports-2b74a89bc8342f0b9b737c37d87737caf7b0ea1e.zip
Notes
Diffstat (limited to 'emulators/fuse')
-rw-r--r--emulators/fuse/Makefile3
-rw-r--r--emulators/fuse/files/patch-screenshot.c10
2 files changed, 12 insertions, 1 deletions
diff --git a/emulators/fuse/Makefile b/emulators/fuse/Makefile
index e83bdfcc43b8..0266ed326d99 100644
--- a/emulators/fuse/Makefile
+++ b/emulators/fuse/Makefile
@@ -7,7 +7,7 @@
PORTNAME= fuse
PORTVERSION= 1.0.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}-emulator/${PORTNAME}/${PORTVERSION}
@@ -15,6 +15,7 @@ MAINTAINER= yuri.pankov@gmail.com
COMMENT= Free Unix (Sinclair ZX-)Spectrum Emulator
LIB_DEPENDS= spectrum.8:${PORTSDIR}/emulators/libspectrum \
+ png15:${PORTSDIR}/graphics/png \
gcrypt.18:${PORTSDIR}/security/libgcrypt
LICENSE= GPLv2
diff --git a/emulators/fuse/files/patch-screenshot.c b/emulators/fuse/files/patch-screenshot.c
new file mode 100644
index 000000000000..25205faf3088
--- /dev/null
+++ b/emulators/fuse/files/patch-screenshot.c
@@ -0,0 +1,10 @@
+--- screenshot.c.orig 2011-01-12 22:36:28.000000000 +0100
++++ screenshot.c 2012-05-09 12:59:50.000000000 +0200
+@@ -49,6 +49,7 @@
+ #ifdef USE_LIBPNG
+
+ #include <png.h>
++#include <zlib.h>
+
+ static int get_rgb32_data( libspectrum_byte *rgb32_data, size_t stride,
+ size_t height, size_t width );