aboutsummaryrefslogtreecommitdiff
path: root/emulators/fuse
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-05-20 15:03:18 +0000
committerRene Ladan <rene@FreeBSD.org>2013-05-20 15:03:18 +0000
commit8194533c4bff974d98632589cd9a9a79ecf9fe96 (patch)
treee756127e701c9a12b5b468144626c4d87bc6c20c /emulators/fuse
parentc1dc5f06041afb55f9872357457b9272b20cf714 (diff)
downloadports-8194533c4bff974d98632589cd9a9a79ecf9fe96.tar.gz
ports-8194533c4bff974d98632589cd9a9a79ecf9fe96.zip
Notes
Diffstat (limited to 'emulators/fuse')
-rw-r--r--emulators/fuse/Makefile9
-rw-r--r--emulators/fuse/distinfo4
-rw-r--r--emulators/fuse/files/patch-screenshot.c10
-rw-r--r--emulators/fuse/files/patch-sound__aosound.c27
-rw-r--r--emulators/fuse/pkg-plist14
5 files changed, 36 insertions, 28 deletions
diff --git a/emulators/fuse/Makefile b/emulators/fuse/Makefile
index fbe0d0d58cdd..f0a070600403 100644
--- a/emulators/fuse/Makefile
+++ b/emulators/fuse/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= fuse
-PORTVERSION= 1.0.0.1
-PORTREVISION= 3
+PORTVERSION= 1.1.0
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}-emulator/${PORTNAME}/${PORTVERSION}
@@ -12,7 +11,7 @@ COMMENT= Free Unix (Sinclair ZX-)Spectrum Emulator
LICENSE= GPLv2
-LIB_DEPENDS= spectrum.8:${PORTSDIR}/emulators/libspectrum \
+LIB_DEPENDS= spectrum:${PORTSDIR}/emulators/libspectrum \
png15:${PORTSDIR}/graphics/png \
gcrypt:${PORTSDIR}/security/libgcrypt
@@ -34,13 +33,13 @@ SAMPLERATE_DESC= Better beeper sound quality
.if ${PORT_OPTIONS:MAO}
CONFIGURE_ARGS+=--with-libao
-LIB_DEPENDS+= ao.4:${PORTSDIR}/audio/libao
+LIB_DEPENDS+= ao:${PORTSDIR}/audio/libao
.else
CONFIGURE_ARGS+=--without-libao
.endif
.if ${PORT_OPTIONS:MSAMPLERATE}
-LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
+LIB_DEPENDS+= samplerate:${PORTSDIR}/audio/libsamplerate
.else
CONFIGURE_ARGS+=--without-libsamplerate
.endif
diff --git a/emulators/fuse/distinfo b/emulators/fuse/distinfo
index 5807d7253c39..c5419e83d0d1 100644
--- a/emulators/fuse/distinfo
+++ b/emulators/fuse/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fuse-1.0.0.1.tar.gz) = 4bc7be3dca87aaf244b0769387a4d9b40f74d50b5077a4cf499d88c3362b511b
-SIZE (fuse-1.0.0.1.tar.gz) = 1629111
+SHA256 (fuse-1.1.0.tar.gz) = c0960b72f76e3b9fb49ad6970d2f80e0db8e8bfd257449f37c30bd76ea071617
+SIZE (fuse-1.1.0.tar.gz) = 1870034
diff --git a/emulators/fuse/files/patch-screenshot.c b/emulators/fuse/files/patch-screenshot.c
deleted file mode 100644
index 25205faf3088..000000000000
--- a/emulators/fuse/files/patch-screenshot.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- screenshot.c.orig 2011-01-12 22:36:28.000000000 +0100
-+++ screenshot.c 2012-05-09 12:59:50.000000000 +0200
-@@ -49,6 +49,7 @@
- #ifdef USE_LIBPNG
-
- #include <png.h>
-+#include <zlib.h>
-
- static int get_rgb32_data( libspectrum_byte *rgb32_data, size_t stride,
- size_t height, size_t width );
diff --git a/emulators/fuse/files/patch-sound__aosound.c b/emulators/fuse/files/patch-sound__aosound.c
new file mode 100644
index 000000000000..f7346fe64d17
--- /dev/null
+++ b/emulators/fuse/files/patch-sound__aosound.c
@@ -0,0 +1,27 @@
+--- ./sound/aosound.c.orig 2013-05-16 22:26:12.000000000 +0200
++++ ./sound/aosound.c 2013-05-20 14:06:11.000000000 +0200
+@@ -78,14 +78,14 @@
+ }
+ }
+
+-static void
++static int
+ parse_driver_options( const char *device, int *driver_id, ao_option **options )
+ {
+ char *mutable, *option, *key, *value;
+
+ /* Get a copy of the device string we can modify */
+ if( !device || *device == '\0' )
+- return;
++ return 1;
+
+ mutable = utils_safe_strdup( device );
+
+@@ -119,6 +119,7 @@
+ }
+
+ free( mutable );
++ return 0;
+ }
+
+ int
diff --git a/emulators/fuse/pkg-plist b/emulators/fuse/pkg-plist
index 194fd24e1ff7..51799b4c8196 100644
--- a/emulators/fuse/pkg-plist
+++ b/emulators/fuse/pkg-plist
@@ -2,21 +2,13 @@
bin/fuse
%%DATADIR%%/128-0.rom
%%DATADIR%%/128-1.rom
-%%DATADIR%%/128p-0.rom
-%%DATADIR%%/128p-1.rom
-%%DATADIR%%/256s-0.rom
-%%DATADIR%%/256s-1.rom
-%%DATADIR%%/256s-2.rom
-%%DATADIR%%/256s-3.rom
%%DATADIR%%/48.rom
%%DATADIR%%/cassette.bmp
+%%DATADIR%%/disciple.rom
%%DATADIR%%/disk_plus3.szx
-%%DATADIR%%/gluck.rom
-%%DATADIR%%/if1-1.rom
-%%DATADIR%%/if1-2.rom
%%DATADIR%%/keyboard.scr
+%%DATADIR%%/menu_data.ui
%%DATADIR%%/microdrive.bmp
-%%DATADIR%%/opus.rom
%%DATADIR%%/plus2-0.rom
%%DATADIR%%/plus2-1.rom
%%DATADIR%%/plus3-0.rom
@@ -31,6 +23,7 @@ bin/fuse
%%DATADIR%%/plusd.rom
%%DATADIR%%/se-0.rom
%%DATADIR%%/se-1.rom
+%%DATADIR%%/speccyboot-1.4.rom
%%DATADIR%%/tape_128.szx
%%DATADIR%%/tape_16.szx
%%DATADIR%%/tape_2048.szx
@@ -48,7 +41,6 @@ bin/fuse
%%DATADIR%%/tc2048.rom
%%DATADIR%%/tc2068-0.rom
%%DATADIR%%/tc2068-1.rom
-%%DATADIR%%/trdos.rom
@dirrm %%DATADIR%%
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog