aboutsummaryrefslogtreecommitdiff
path: root/emulators/fuse
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2016-06-11 22:02:29 +0000
committerRene Ladan <rene@FreeBSD.org>2016-06-11 22:02:29 +0000
commitc1538cfa581f5dc2873c55c7fc38746de3b1eb0f (patch)
tree26390cd0c6a7452d37a8ccb2f8c9e44aeac83e96 /emulators/fuse
parentfd1bf1a623140ffabba3d7c1a09ecf7caf25407f (diff)
downloadports-c1538cfa581f5dc2873c55c7fc38746de3b1eb0f.tar.gz
ports-c1538cfa581f5dc2873c55c7fc38746de3b1eb0f.zip
Notes
Diffstat (limited to 'emulators/fuse')
-rw-r--r--emulators/fuse/Makefile15
-rw-r--r--emulators/fuse/distinfo5
-rw-r--r--emulators/fuse/files/patch-sound__aosound.c27
3 files changed, 12 insertions, 35 deletions
diff --git a/emulators/fuse/Makefile b/emulators/fuse/Makefile
index 53f6565151ba..87445ca18c53 100644
--- a/emulators/fuse/Makefile
+++ b/emulators/fuse/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= fuse
-PORTVERSION= 1.1.1
-PORTREVISION= 9
+PORTVERSION= 1.2.0
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}-emulator/${PORTNAME}/${PORTVERSION}
@@ -12,13 +11,16 @@ COMMENT= Free Unix (Sinclair ZX-)Spectrum Emulator
LICENSE= GPLv2
-LIB_DEPENDS= libspectrum.so:emulators/libspectrum \
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libgcrypt.so:security/libgcrypt \
libpng.so:graphics/png \
- libgcrypt.so:security/libgcrypt
+ libspectrum.so:emulators/libspectrum
GNU_CONFIGURE= yes
-USES= gmake localbase pkgconfig
-USE_GNOME= libxml2 glib20
+USES= gettext gmake localbase pkgconfig
+USE_GNOME= cairo libxml2 glib20
+USE_XORG= x11
CONFIGURE_ARGS+=--without-alsa --without-joystick
@@ -57,6 +59,7 @@ INSTALLS_ICONS= yes
post-extract:
${CP} ${WRKSRC}/roms/README.copyright ${WRKSRC}
+
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
diff --git a/emulators/fuse/distinfo b/emulators/fuse/distinfo
index 3e518283548b..67a83c8d767b 100644
--- a/emulators/fuse/distinfo
+++ b/emulators/fuse/distinfo
@@ -1,2 +1,3 @@
-SHA256 (fuse-1.1.1.tar.gz) = a857d4bd62e01d18429897467508af15624cbaf343caed8b9ba1ab3a8879444e
-SIZE (fuse-1.1.1.tar.gz) = 1881332
+TIMESTAMP = 1465509349
+SHA256 (fuse-1.2.0.tar.gz) = 72621b23c31c69a31e97b698761c4a21a209b23f4d53f8b441291c14f6811acb
+SIZE (fuse-1.2.0.tar.gz) = 1622829
diff --git a/emulators/fuse/files/patch-sound__aosound.c b/emulators/fuse/files/patch-sound__aosound.c
deleted file mode 100644
index 67b03d0423f3..000000000000
--- a/emulators/fuse/files/patch-sound__aosound.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- sound/aosound.c.orig 2013-05-16 20:26:12 UTC
-+++ sound/aosound.c
-@@ -78,14 +78,14 @@ driver_error( void )
- }
- }
-
--static void
-+static int
- parse_driver_options( const char *device, int *driver_id, ao_option **options )
- {
- char *mutable, *option, *key, *value;
-
- /* Get a copy of the device string we can modify */
- if( !device || *device == '\0' )
-- return;
-+ return 0;
-
- mutable = utils_safe_strdup( device );
-
-@@ -119,6 +119,7 @@ parse_driver_options( const char *device
- }
-
- free( mutable );
-+ return 0;
- }
-
- int