aboutsummaryrefslogtreecommitdiff
path: root/emulators/generator-cbiere/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-08-30 01:10:02 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-08-30 01:10:02 +0000
commitfdbb5ac0f89f8fd677cee1aa2da499d68a91d82e (patch)
treec72438723a31df55f9681b550dc787d56b696152 /emulators/generator-cbiere/Makefile
parentd32b42a78cdf4560afeec714335fafc1a3c7b191 (diff)
downloadports-fdbb5ac0f89f8fd677cee1aa2da499d68a91d82e.tar.gz
ports-fdbb5ac0f89f8fd677cee1aa2da499d68a91d82e.zip
Notes
Diffstat (limited to 'emulators/generator-cbiere/Makefile')
-rw-r--r--emulators/generator-cbiere/Makefile44
1 files changed, 9 insertions, 35 deletions
diff --git a/emulators/generator-cbiere/Makefile b/emulators/generator-cbiere/Makefile
index 19388b655c9d..785c9f57d896 100644
--- a/emulators/generator-cbiere/Makefile
+++ b/emulators/generator-cbiere/Makefile
@@ -6,11 +6,13 @@
#
PORTNAME= generator
-PORTVERSION= 0.35
+PORTVERSION= 0.35.r1
+PORTEPOCH= 1
CATEGORIES= emulators
-MASTER_SITES= http://www.ghostwhitecrab.com/generator/
+MASTER_SITES= http://www.ghostwhitecrab.com/generator/ \
+ http://www.ghostwhitecrab.de/generator/
PKGNAMESUFFIX= -cbiere
-DISTNAME= ${PORTNAME}-${PORTVERSION}${PKGNAMESUFFIX}
+DISTNAME= ${PORTNAME}-0.35${PKGNAMESUFFIX}-r1
MAINTAINER= alejandro@varnet.biz
COMMENT= SEGA Genesis emulator
@@ -26,12 +28,11 @@ OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
RAZE "Use RAZE z80 emulation (only for i386)" on \
SDL_AUDIO "Use SDL for audio" off
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-transform-name=s/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-transform-name=s/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/
CONFIGURE_ARGS+= --with-gtk
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
PLIST_FILES= bin/${PORTNAME}${PKGNAMESUFFIX}-gtk
@@ -44,33 +45,6 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${ARCH} != "amd64" && ${ARCH} != "i386"
-USE_REINPLACE= yes
-
-post-patch:
-# These architectures do not support "-minline-all-stringops"
- @${REINPLACE_CMD} -e 's|-minline-all-stringops||g' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-.if ${ARCH} == "alpha"
-# "-ffast-math" does not work on alpha
- @${REINPLACE_CMD} -e 's|-ffast-math||g' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-.endif
-.endif
-
-# Generator needs GCC 2.95.x or GCC >= 3.4.2 to work properly.
-# Generator-CBiere automatically determines the GCC version.
-
-.if ${OSVERSION} < 400012
-# GCC < 2.95 is in the base system.
-USE_GCC= 2.95
-.endif
-
-.if ${OSVERSION} >= 500035 && ${OSVERSION} < 502126
-# GCC > 2.95 (3.X) && GCC < 3.4.2 is in the base system.
-USE_GCC= 3.4
-.endif
-
.if defined(WITHOUT_OPTIMIZED_CFLAGS)
CONFIGURE_ARGS+= --without-gcc
.endif