aboutsummaryrefslogtreecommitdiff
path: root/emulators/generator-cbiere
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 10:34:46 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 10:34:46 +0000
commitf3381fa548d3edd4687bf4cf975577eeb10d68b7 (patch)
treea607b9b0948608d5c47edc8a47b7a82c47b30717 /emulators/generator-cbiere
parent67375d16b1d5928bed929dcddfd6dcf003678869 (diff)
downloadports-f3381fa548d3edd4687bf4cf975577eeb10d68b7.tar.gz
ports-f3381fa548d3edd4687bf4cf975577eeb10d68b7.zip
Notes
Diffstat (limited to 'emulators/generator-cbiere')
-rw-r--r--emulators/generator-cbiere/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/emulators/generator-cbiere/Makefile b/emulators/generator-cbiere/Makefile
index 6ff45127a3b4..4fffcc2a4315 100644
--- a/emulators/generator-cbiere/Makefile
+++ b/emulators/generator-cbiere/Makefile
@@ -25,9 +25,9 @@ USE_GMAKE= yes
USE_GNOME= gtk12
MAKE_JOBS_UNSAFE= yes
-OPTIONS= OPTIMIZED_CFLAGS "Enable compilation optimizations" on \
- RAZE "Use RAZE z80 emulation (only for i386)" on \
- SDL_AUDIO "Use SDL for audio" off
+OPTIONS_DEFINE= OPTIMIZED_CFLAGS RAZE SDL
+RAZE_DESC= Use RAZE z80 emulation (only for i386)
+SDL_DESC= Use SDL for audio
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-transform-name=s/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/
@@ -41,18 +41,18 @@ LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
.include <bsd.port.pre.mk>
-.if defined(WITHOUT_OPTIMIZED_CFLAGS)
+.if empty(PORT_OPTIONS:MOPTIIMIZED_CFLAGS)
CONFIGURE_ARGS+= --without-gcc
.endif
-.if !defined(WITHOUT_RAZE) && ${ARCH} == "i386"
+.if ${PORT_OPTIONS:MRAZE} && ${ARCH} == "i386"
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
CONFIGURE_ARGS+=--with-raze
.else
CONFIGURE_ARGS+=--with-cmz80
.endif
-.if defined(WITH_SDL_AUDIO)
+.if ${PORT_OPTIONS:MSDL}
CONFIGURE_ARGS+=--with-sdl-audio
.endif