aboutsummaryrefslogtreecommitdiff
path: root/emulators/gngeo
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:20:28 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-28 21:20:28 +0000
commitf53196ebc931edf54afe56ab65deddc4f2d5b8fb (patch)
tree17f3405d36f74dd57d11bda9e7ecc80c2929914c /emulators/gngeo
parent02ad6b1271fd43ec6fd524c9a6957530cd83d262 (diff)
downloadports-f53196ebc931edf54afe56ab65deddc4f2d5b8fb.tar.gz
ports-f53196ebc931edf54afe56ab65deddc4f2d5b8fb.zip
Notes
Diffstat (limited to 'emulators/gngeo')
-rw-r--r--emulators/gngeo/Makefile28
1 files changed, 13 insertions, 15 deletions
diff --git a/emulators/gngeo/Makefile b/emulators/gngeo/Makefile
index 7e2b88a6c604..8e94e226d990 100644
--- a/emulators/gngeo/Makefile
+++ b/emulators/gngeo/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gngeo
-# Date created: 17 Aug 2005
-# Whom: Alejandro Pulver <alejandro@varnet.biz>
-#
+# Created by: Alejandro Pulver <alejandro@varnet.biz>
# $FreeBSD$
-#
PORTNAME= gngeo
PORTVERSION= 0.7
@@ -28,39 +24,41 @@ LDFLAGS+= `${SDL_CONFIG} --libs` -L${LOCALBASE}/lib
SUB_FILES= pkg-message
-OPTIONS= GUI "Enable GUI support (experimental)" off \
- I386ASM "Use i386 optimization" on \
- RAZE "Use Raze as z80 emulator (only for i386)" on \
- STAR "Use Starscream as 68k emulator (only for i386)" on
+OPTIONS_DEFINE= GUI
+OPTIONS_DEFINE_i386= ASM RAZE STAR
+OPTIONS_DEFAULT_i386= ASM RAZE STAR
+GUI_DESC= Enable GUI support (experimental)
+RAZE_DESC= Use Raze as z80 emulator
+STAR_DESC= Use Starscream as 68k emulator
MAN1= gngeo.1
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_I386ASM) || !defined(WITHOUT_RAZE) || \
- !defined(WITHOUT_STAR)
+.if ${PORT_OPTIONS:MI386ASM} || ${PORT_OPTIONS:MRAZE} || \
+ ${PORT_OPTIONS:MSTAR}
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
.endif
-.if defined(WITH_GUI)
+.if ${PORT_OPTIONS:MGUI}
CONFIGURE_ARGS+= --enable-gui
.else
CONFIGURE_ARGS+= --disable-gui
.endif
-.if !defined(WITHOUT_I386ASM) && ${ARCH} == "i386"
+.if ${PORT_OPTIONS:MI386ASM}
CONFIGURE_ARGS+= --enable-i386asm
.else
CONFIGURE_ARGS+= --disable-i386asm
.endif
-.if !defined(WITHOUT_RAZE) && ${ARCH} == "i386"
+.if ${PORT_OPTIONS:MRAZE}
CONFIGURE_ARGS+= --enable-raze
.else
CONFIGURE_ARGS+= --enable-mamez80
.endif
-.if !defined(WITHOUT_STAR) && ${ARCH} == "i386"
+.if ${PORT_OPTIONS:MSTAR}
CONFIGURE_ARGS+= --enable-starscream
.else
CONFIGURE_ARGS+= --enable-gen68k