aboutsummaryrefslogtreecommitdiff
path: root/emulators/gngeo
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-04-17 20:06:04 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-04-17 20:06:04 +0000
commite15f608393e54b0714fff4d1fd6da22b310c74c1 (patch)
treead79b6726e3184c5a83059d876bad313fc0cd6d3 /emulators/gngeo
parent875d050008c44793a5d50056175bdf0246fd1dc5 (diff)
downloadports-e15f608393e54b0714fff4d1fd6da22b310c74c1.tar.gz
ports-e15f608393e54b0714fff4d1fd6da22b310c74c1.zip
Notes
Diffstat (limited to 'emulators/gngeo')
-rw-r--r--emulators/gngeo/Makefile62
-rw-r--r--emulators/gngeo/distinfo6
-rw-r--r--emulators/gngeo/files/extra-patch-src__emu.h11
-rw-r--r--emulators/gngeo/files/patch-configure17
-rw-r--r--emulators/gngeo/files/pkg-message.in35
-rw-r--r--emulators/gngeo/pkg-plist6
6 files changed, 87 insertions, 50 deletions
diff --git a/emulators/gngeo/Makefile b/emulators/gngeo/Makefile
index 3a964878e002..5d7ee94e0ad5 100644
--- a/emulators/gngeo/Makefile
+++ b/emulators/gngeo/Makefile
@@ -6,25 +6,28 @@
#
PORTNAME= gngeo
-PORTVERSION= 0.6.4
+PORTVERSION= 0.6.11
CATEGORIES= emulators
MASTER_SITES= http://m.peponas.free.fr/gngeo/download/
DIST_SUBDIR= ${PORTNAME}
-MAINTAINER= alepulver@FreeBSD.org
+MAINTAINER= acardenas@bsd.org.pe
COMMENT= NeoGeo emulator
-RESTRICTED= The Neo-Geo BIOS can not be redistributed
-
+USE_X_PREFIX= yes
+USE_GETOPT_LONG=yes
USE_GMAKE= yes
USE_SDL= image sdl
USE_GL= yes
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-transform-name=""
-CONFIGURE_ENV= CPPFLAGS="`${SDL_CONFIG} --cflags` -I${X11BASE}/include" \
- LDFLAGS="`${SDL_CONFIG} --libs`"
+CONFIGURE_ARGS= --program-transform-name="" --disable-gp2x
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+
+CPPFLAGS= ${CFLAGS} `${SDL_CONFIG} --cflags` -I${X11BASE}/include
+LDFLAGS= `${SDL_CONFIG} --libs` -L${X11BASE}/lib
+
+SUB_FILES= pkg-message
OPTIONS= GUI "Enable GUI support (experimental)" off \
I386ASM "Use i386 optimization" on \
@@ -33,32 +36,14 @@ OPTIONS= GUI "Enable GUI support (experimental)" off \
MAN1= gngeo.1
-NGBIOS= neo-geo.rom ng-lo.rom ng-sfix.rom ng-sm1.rom
-
-post-patch:
- @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}| ; \
- s|-mcpu=$$target_cpu||' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-
-post-install:
-# Neo-Geo BIOS
-.for f in ${NGBIOS}
- @${INSTALL_DATA} ${DISTDIR}/${f} ${DATADIR}
-.endfor
-
-# Examples
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/sample_gngeorc ${EXAMPLESDIR}/gngeorc
-
.include <bsd.port.pre.mk>
-.for f in ${NGBIOS}
-. if !exists(${DISTDIR}/${DIST_SUBDIR}/${f}) || defined(PACKAGE_BUILDING)
-IGNORE?= Could not find ${DISTDIR}/${DIST_SUBDIR}/${f}. You need to manually download a copy of the Neo-Geo BIOS, extract the files and place them into ${DISTDIR}/${DIST_SUBDIR}. It is available at http://www.ocf.berkeley.edu/~wwu/downloads/neogeo.zip
-. endif
-.endfor
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src__emu.h
+.endif
-.if defined(WITH_I386ASM) || defined(WITH_RAZE) || defined(WITH_STAR)
+.if !defined(WITHOUT_I386ASM) || !defined(WITHOUT_RAZE) || \
+ !defined(WITHOUT_STAR)
BUILD_DEPENDS+= nasm:${PORTSDIR}/devel/nasm
.endif
@@ -68,22 +53,31 @@ CONFIGURE_ARGS+= --enable-gui
CONFIGURE_ARGS+= --disable-gui
.endif
-.if defined(WITH_I386ASM) && ${ARCH} == "i386"
+.if !defined(WITHOUT_I386ASM) && ${ARCH} == "i386"
CONFIGURE_ARGS+= --enable-i386asm
.else
CONFIGURE_ARGS+= --disable-i386asm
.endif
-.if defined(WITH_RAZE) && ${ARCH} == "i386"
+.if !defined(WITHOUT_RAZE) && ${ARCH} == "i386"
CONFIGURE_ARGS+= --enable-raze
.else
CONFIGURE_ARGS+= --enable-mamez80
.endif
-.if defined(WITH_STAR) && ${ARCH} == "i386"
+.if !defined(WITHOUT_STAR) && ${ARCH} == "i386"
CONFIGURE_ARGS+= --enable-starscream
.else
CONFIGURE_ARGS+= --enable-gen68k
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
+post-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample_gngeorc ${EXAMPLESDIR}/gngeorc
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
.include <bsd.port.post.mk>
diff --git a/emulators/gngeo/distinfo b/emulators/gngeo/distinfo
index f13742ea6cb3..9a150e8adf3c 100644
--- a/emulators/gngeo/distinfo
+++ b/emulators/gngeo/distinfo
@@ -1,3 +1,3 @@
-MD5 (gngeo/gngeo-0.6.4.tar.gz) = 690a624935a25af19d80d05088dc7d3c
-SHA256 (gngeo/gngeo-0.6.4.tar.gz) = e51a699ce8800fd717166b31c94918b252d578e764fecff8b8ec3a7acbb4a6b7
-SIZE (gngeo/gngeo-0.6.4.tar.gz) = 558473
+MD5 (gngeo/gngeo-0.6.11.tar.gz) = fee91301dab874b0a28d361ba68d6cd1
+SHA256 (gngeo/gngeo-0.6.11.tar.gz) = 6ec67cdec7775caf81b81eb9c1c0a6209a2e1cf2cc4dfa670d4aaef40f24c45a
+SIZE (gngeo/gngeo-0.6.11.tar.gz) = 1014372
diff --git a/emulators/gngeo/files/extra-patch-src__emu.h b/emulators/gngeo/files/extra-patch-src__emu.h
new file mode 100644
index 000000000000..9fa9f09c3207
--- /dev/null
+++ b/emulators/gngeo/files/extra-patch-src__emu.h
@@ -0,0 +1,11 @@
+--- src/emu.h.orig Wed Feb 8 17:21:55 2006
++++ src/emu.h Fri Apr 14 12:52:00 2006
+@@ -24,7 +24,7 @@
+ #endif
+
+ #include <string.h>
+-#include <stdint.h>
++#include <inttypes.h>
+ #include "SDL.h"
+ #include "SDL_types.h"
+ #define Uintptr long
diff --git a/emulators/gngeo/files/patch-configure b/emulators/gngeo/files/patch-configure
index cc9641201f14..c853eaa4173b 100644
--- a/emulators/gngeo/files/patch-configure
+++ b/emulators/gngeo/files/patch-configure
@@ -1,13 +1,14 @@
---- configure.orig Mon Sep 20 13:35:06 2004
-+++ configure Wed Aug 17 16:29:55 2005
-@@ -3118,10 +3118,6 @@
+--- configure.orig Sat Apr 1 10:19:10 2006
++++ configure Thu Apr 13 23:02:32 2006
+@@ -3111,11 +3111,6 @@
+ echo "$as_me: error: can't find SDL on your system" >&2;}
{ (exit 1); exit 1; }; }
fi
-
--else
-- { { echo "$as_me:$LINENO: error: can't find sdl-config on your system" >&5
+-
+- else
+- { { echo "$as_me:$LINENO: error: can't find sdl-config on your system" >&5
-echo "$as_me: error: can't find sdl-config on your system" >&2;}
- { (exit 1); exit 1; }; };
+ fi
+ enable_gp2x=false
fi
-
-
diff --git a/emulators/gngeo/files/pkg-message.in b/emulators/gngeo/files/pkg-message.in
new file mode 100644
index 000000000000..1158dc043351
--- /dev/null
+++ b/emulators/gngeo/files/pkg-message.in
@@ -0,0 +1,35 @@
+==============================================================================
+
+GnGeo has been installed.
+
+1) You need to manually download neogeo-bios or neogeo-unibios. It's available
+ at:
+
+ - neogeo-bios: http://www.ocf.berkeley.edu/~wwu/downloads/neogeo.zip
+ - neogeo-unibios: http://unibios.free.fr/download.html
+
+ Please keep in mind that the NEOGEO BIOS is copyrighted software.
+
+2) Choose one and extract the files and place them into
+ %%DATADIR%% directory.
+
+3) If you use the neogeo-bios, you need rename some files.
+
+ - neo-geo.rom -> sp-s2.sp1
+ - ng-lo.rom -> 000-lo.lo
+ - ng-sfix.rom -> sfix.sfx
+ - ng-sm1.rom -> ng-sm1.rom
+
+4) Run gngeo.
+
+ Using neogeo-bios:
+ # gngeo <romname>
+
+ Using neogeo-unibios:
+ # gngeo --system unibios <romname>
+
+ Note: Use rom's name (romname) without zip extension.
+
+5) Enjoy it ;)
+
+==============================================================================
diff --git a/emulators/gngeo/pkg-plist b/emulators/gngeo/pkg-plist
index 35bce21b6fb1..aec991dae009 100644
--- a/emulators/gngeo/pkg-plist
+++ b/emulators/gngeo/pkg-plist
@@ -3,12 +3,8 @@ bin/gngeo
%%DATADIR%%/gui_font.bmp
%%DATADIR%%/gui_font2.bmp
%%DATADIR%%/little_font.bmp
-%%DATADIR%%/neo-geo.rom
-%%DATADIR%%/ng-lo.rom
-%%DATADIR%%/ng-sfix.rom
-%%DATADIR%%/ng-sm1.rom
%%DATADIR%%/romrc
%%DATADIR%%/sb_arrows.bmp
%%EXAMPLESDIR%%/gngeorc
-@dirrm %%DATADIR%%
@dirrm %%EXAMPLESDIR%%
+@unexec rmdir %D/%%DATADIR%% >/dev/null 2>&1 || echo "If you are permanently removing this port, you should remove the Neo-Geo BIOS files left in %D/%%DATADIR%%."