aboutsummaryrefslogtreecommitdiff
path: root/emulators/gsnes9x
diff options
context:
space:
mode:
authorAlexander Langer <alex@FreeBSD.org>2000-07-16 15:32:28 +0000
committerAlexander Langer <alex@FreeBSD.org>2000-07-16 15:32:28 +0000
commit4e044e735f784ee9c31986ebb0fef0bb0f87def9 (patch)
tree27279f42e1e26273aafcf4650b3cfdfb818b7c3d /emulators/gsnes9x
parentd9b9e951a403337596a3412ae6d1ba162800342e (diff)
downloadports-4e044e735f784ee9c31986ebb0fef0bb0f87def9.tar.gz
ports-4e044e735f784ee9c31986ebb0fef0bb0f87def9.zip
Notes
Diffstat (limited to 'emulators/gsnes9x')
-rw-r--r--emulators/gsnes9x/Makefile49
-rw-r--r--emulators/gsnes9x/distinfo1
-rw-r--r--emulators/gsnes9x/files/PLIST.docs31
-rw-r--r--emulators/gsnes9x/files/PLIST.nodocs4
-rw-r--r--emulators/gsnes9x/files/patch-aa46
-rw-r--r--emulators/gsnes9x/files/patch-ab38
-rw-r--r--emulators/gsnes9x/files/patch-ac11
-rw-r--r--emulators/gsnes9x/pkg-comment1
-rw-r--r--emulators/gsnes9x/pkg-descr10
-rw-r--r--emulators/gsnes9x/pkg-plist31
10 files changed, 222 insertions, 0 deletions
diff --git a/emulators/gsnes9x/Makefile b/emulators/gsnes9x/Makefile
new file mode 100644
index 000000000000..ea12b1bd631c
--- /dev/null
+++ b/emulators/gsnes9x/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: GSnes9x
+# Date created: 18 Jun 2000
+# Whom: Kelly Yancey <kbyanc@posi.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gsnes9x
+PORTVERSION= 3.0
+CATEGORIES= emulators
+MASTER_SITES= http://abulafia.fciencias.unam.mx/~canek/gsnes9x/source/
+DISTNAME= GSnes9x-3.0
+
+MAINTAINER= kbyanc@posi.net
+
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext \
+ gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ esd.2:${PORTSDIR}/audio/esound
+RUN_DEPENDS= snes9x:${PORTSDIR}/emulators/snes9x
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+
+CONFIGURE_ARGS= --without-included-gettext \
+ --with-esd
+
+.if defined(NOPORTDOCS)
+pre-install:
+ ${INSTALL_DATA} ${FILESDIR}/PLIST.nodocs ${PKGDIR}/PLIST
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/GSnes9x ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/share/gnome \
+ ${PREFIX}/share/gnome/apps \
+ ${PREFIX}/share/gnome/apps/Games \
+ ${PREFIX}/share/gnome/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/gsnes9x.desktop \
+ ${PREFIX}/share/gnome/apps/Games/gsnes9x.desktop
+ ${INSTALL_DATA} ${WRKSRC}/pixmaps/gsnesdefault.png \
+ ${PREFIX}/share/gnome/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/pixmaps/gsnes9x-icon.png \
+ ${PREFIX}/share/gnome/pixmaps
+.else
+pre-install:
+ ${INSTALL_DATA} ${FILESDIR}/PLIST.docs ${PKGDIR}/PLIST
+.endif
+
+.include <bsd.port.mk>
diff --git a/emulators/gsnes9x/distinfo b/emulators/gsnes9x/distinfo
new file mode 100644
index 000000000000..4e7ca4e1fbf6
--- /dev/null
+++ b/emulators/gsnes9x/distinfo
@@ -0,0 +1 @@
+MD5 (GSnes9x-3.0.tar.gz) = 79cb2dfcd4aff46ca58f6a4527ff1ebe
diff --git a/emulators/gsnes9x/files/PLIST.docs b/emulators/gsnes9x/files/PLIST.docs
new file mode 100644
index 000000000000..930395b6160c
--- /dev/null
+++ b/emulators/gsnes9x/files/PLIST.docs
@@ -0,0 +1,31 @@
+bin/GSnes9x
+share/gnome/help/GSnes9x/C/index.html
+share/gnome/help/GSnes9x/C/topic.dat
+share/gnome/help/GSnes9x/C/addrom.png
+share/gnome/help/GSnes9x/C/cheat.png
+share/gnome/help/GSnes9x/C/codes.png
+share/gnome/help/GSnes9x/C/format.png
+share/gnome/help/GSnes9x/C/info.png
+share/gnome/help/GSnes9x/C/joystick.png
+share/gnome/help/GSnes9x/C/main.png
+share/gnome/help/GSnes9x/C/pop.png
+share/gnome/help/GSnes9x/C/system.png
+share/gnome/help/GSnes9x/C/tooltips.png
+share/gnome/help/GSnes9x/es/index.html
+share/gnome/help/GSnes9x/es/topic.dat
+share/gnome/help/GSnes9x/es/addrom.png
+share/gnome/help/GSnes9x/es/cheat.png
+share/gnome/help/GSnes9x/es/codes.png
+share/gnome/help/GSnes9x/es/format.png
+share/gnome/help/GSnes9x/es/info.png
+share/gnome/help/GSnes9x/es/joystick.png
+share/gnome/help/GSnes9x/es/main.png
+share/gnome/help/GSnes9x/es/pop.png
+share/gnome/help/GSnes9x/es/system.png
+share/gnome/help/GSnes9x/es/tooltips.png
+share/gnome/apps/Games/gsnes9x.desktop
+share/gnome/pixmaps/gsnesdefault.png
+share/gnome/pixmaps/gsnes9x-icon.png
+@dirrm share/gnome/help/GSnes9x/C
+@dirrm share/gnome/help/GSnes9x/es
+@dirrm share/gnome/help/GSnes9x
diff --git a/emulators/gsnes9x/files/PLIST.nodocs b/emulators/gsnes9x/files/PLIST.nodocs
new file mode 100644
index 000000000000..e525849d96d4
--- /dev/null
+++ b/emulators/gsnes9x/files/PLIST.nodocs
@@ -0,0 +1,4 @@
+bin/GSnes9x
+share/gnome/apps/Games/gsnes9x.desktop
+share/gnome/pixmaps/gsnesdefault.png
+share/gnome/pixmaps/gsnes9x-icon.png
diff --git a/emulators/gsnes9x/files/patch-aa b/emulators/gsnes9x/files/patch-aa
new file mode 100644
index 000000000000..07efe2dcc369
--- /dev/null
+++ b/emulators/gsnes9x/files/patch-aa
@@ -0,0 +1,46 @@
+--- src/util.c.orig Sun Jun 18 17:34:30 2000
++++ src/util.c Sun Jun 18 18:06:56 2000
+@@ -79,7 +79,7 @@
+ if (!names)
+ return list;
+
+- getline (&str, &size, names);
++ fgets (str, size, names);
+ str[strlen (str)-1] = '\0'; /* Rip out the '\n'. */
+
+ while (!feof (names)) {
+@@ -102,7 +102,7 @@
+ if (rom_info)
+ list = g_list_prepend (list, (gpointer)rom_info);
+
+- getline (&str, &size, names);
++ fgets (str, size, names);
+ str[strlen(str)-1] = '\0';
+ }
+
+@@ -314,7 +314,7 @@
+ if (!file)
+ return list;
+
+- getline (&str, &size, file);
++ fgets (str, size, file);
+ str[strlen (str)-1] = '\0'; /* Rip out '\n' */
+ if (!strcmp (str, ""))
+ return list;
+@@ -322,13 +322,13 @@
+ do {
+ cheat_code = g_new (CheatCode, 1);
+ cheat_code->code = g_strdup (str);
+- getline (&str, &size, file);
++ fgets (str, size, file);
+ str[strlen (str)-1] = '\0'; /* Rip out '\n' */
+ cheat_code->name = g_strdup (str);
+- getline (&str, &size, file);
++ fgets (str, size, file);
+ str[strlen (str)-1] = '\0'; /* Rip out '\n' */
+ cheat_code->descr = g_strdup (str);
+- getline (&str, &size, file);
++ fgets (str, size, file);
+
+ if (strcmp (str, cheat_code->descr))
+ str[strlen (str)-1] = '\0'; /* Rip out '\n' */
diff --git a/emulators/gsnes9x/files/patch-ab b/emulators/gsnes9x/files/patch-ab
new file mode 100644
index 000000000000..235c38fd8a70
--- /dev/null
+++ b/emulators/gsnes9x/files/patch-ab
@@ -0,0 +1,38 @@
+--- src/confiles.c.orig Sun Jun 18 17:34:23 2000
++++ src/confiles.c Sun Jun 18 18:06:27 2000
+@@ -81,7 +81,7 @@
+ file = fopen (conf, "r");
+ }
+
+- getline (&str, &size, file);
++ fgets (str, size, file);
+ str[strlen (str)-1] = '\0';
+
+ while (!feof (file)) {
+@@ -142,7 +142,7 @@
+ }
+ }
+
+- getline (&str, &size, file);
++ fgets (str, size, file);
+ str[strlen (str)-1] = '\0';
+
+ if (lval)
+@@ -179,7 +179,7 @@
+ return NULL;
+ }
+
+- getline (&str, &size, file);
++ fgets (str, size, file);
+ str[strlen (str)-1] = '\0';
+
+ while (!feof (file)) {
+@@ -237,7 +237,7 @@
+ }
+ }
+
+- getline (&str, &size, file);
++ fgets (str, size, file);
+ str[strlen (str)-1] = '\0';
+
+ if (lval)
diff --git a/emulators/gsnes9x/files/patch-ac b/emulators/gsnes9x/files/patch-ac
new file mode 100644
index 000000000000..b3fe10d1b18a
--- /dev/null
+++ b/emulators/gsnes9x/files/patch-ac
@@ -0,0 +1,11 @@
+--- pixmaps/Makefile.in.orig Sun Jun 18 18:54:02 2000
++++ pixmaps/Makefile.in Sun Jun 18 18:54:55 2000
+@@ -99,7 +99,7 @@
+ ZVT_LIBS = @ZVT_LIBS@
+ l = @l@
+
+-pixmapdir = $(datadir)/pixmaps
++pixmapdir = $(datadir)/gnome/pixmaps
+
+ pixmap_DATA = gsnesdefault.png gsnes9x-icon.png
+
diff --git a/emulators/gsnes9x/pkg-comment b/emulators/gsnes9x/pkg-comment
new file mode 100644
index 000000000000..7b561356951d
--- /dev/null
+++ b/emulators/gsnes9x/pkg-comment
@@ -0,0 +1 @@
+A GTK front-end for the Snes9X SNES emulator
diff --git a/emulators/gsnes9x/pkg-descr b/emulators/gsnes9x/pkg-descr
new file mode 100644
index 000000000000..d2d3b110d63f
--- /dev/null
+++ b/emulators/gsnes9x/pkg-descr
@@ -0,0 +1,10 @@
+GSnes9x is a GNOME front-end for the Snes9X SNES emulator. It
+allows you to set and preserve the options for a particular ROM
+when running it, and to set global options for new ROMs being
+included. It also keeps a Cheat Codes database for each ROM, where
+you can save as many codes as you want.
+
+WWW: http://abulafia.fciencias.unam.mx/~canek/gsnes9x/
+
+ -Kelly
+ kbyanc@posi.net
diff --git a/emulators/gsnes9x/pkg-plist b/emulators/gsnes9x/pkg-plist
new file mode 100644
index 000000000000..930395b6160c
--- /dev/null
+++ b/emulators/gsnes9x/pkg-plist
@@ -0,0 +1,31 @@
+bin/GSnes9x
+share/gnome/help/GSnes9x/C/index.html
+share/gnome/help/GSnes9x/C/topic.dat
+share/gnome/help/GSnes9x/C/addrom.png
+share/gnome/help/GSnes9x/C/cheat.png
+share/gnome/help/GSnes9x/C/codes.png
+share/gnome/help/GSnes9x/C/format.png
+share/gnome/help/GSnes9x/C/info.png
+share/gnome/help/GSnes9x/C/joystick.png
+share/gnome/help/GSnes9x/C/main.png
+share/gnome/help/GSnes9x/C/pop.png
+share/gnome/help/GSnes9x/C/system.png
+share/gnome/help/GSnes9x/C/tooltips.png
+share/gnome/help/GSnes9x/es/index.html
+share/gnome/help/GSnes9x/es/topic.dat
+share/gnome/help/GSnes9x/es/addrom.png
+share/gnome/help/GSnes9x/es/cheat.png
+share/gnome/help/GSnes9x/es/codes.png
+share/gnome/help/GSnes9x/es/format.png
+share/gnome/help/GSnes9x/es/info.png
+share/gnome/help/GSnes9x/es/joystick.png
+share/gnome/help/GSnes9x/es/main.png
+share/gnome/help/GSnes9x/es/pop.png
+share/gnome/help/GSnes9x/es/system.png
+share/gnome/help/GSnes9x/es/tooltips.png
+share/gnome/apps/Games/gsnes9x.desktop
+share/gnome/pixmaps/gsnesdefault.png
+share/gnome/pixmaps/gsnes9x-icon.png
+@dirrm share/gnome/help/GSnes9x/C
+@dirrm share/gnome/help/GSnes9x/es
+@dirrm share/gnome/help/GSnes9x