aboutsummaryrefslogtreecommitdiff
path: root/emulators/gxemul
diff options
context:
space:
mode:
authorWarner Losh <imp@FreeBSD.org>2008-10-03 22:53:29 +0000
committerWarner Losh <imp@FreeBSD.org>2008-10-03 22:53:29 +0000
commit86cd1dc1418aa4ef1c8450ff8d906238a87aeca1 (patch)
tree2f057f9fabd9fed91293f4e48c5465195cb57b57 /emulators/gxemul
parent05aa8cef7f844c1425dcfbf74b890eefaca574f5 (diff)
Notes
Diffstat (limited to 'emulators/gxemul')
-rw-r--r--emulators/gxemul/Makefile3
-rw-r--r--emulators/gxemul/files/patch-bus_pci.c11
2 files changed, 13 insertions, 1 deletions
diff --git a/emulators/gxemul/Makefile b/emulators/gxemul/Makefile
index fbe26c44955a..50236ba887b6 100644
--- a/emulators/gxemul/Makefile
+++ b/emulators/gxemul/Makefile
@@ -7,11 +7,12 @@
PORTNAME= gxemul
PORTVERSION= 0.4.6.5
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://gxemul.sourceforge.net/src/ \
http://gavare.se/gxemul/src/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= imp@FreeBSD.org
COMMENT= Instruction-level machine emulator
OPTIONS= X11 "X11 support" on
diff --git a/emulators/gxemul/files/patch-bus_pci.c b/emulators/gxemul/files/patch-bus_pci.c
new file mode 100644
index 000000000000..023dee43bac6
--- /dev/null
+++ b/emulators/gxemul/files/patch-bus_pci.c
@@ -0,0 +1,11 @@
+--- src/devices/bus_pci.c.orig 2008-10-03 14:11:25.000000000 -0700
++++ src/devices/bus_pci.c 2008-10-03 14:11:34.000000000 -0700
+@@ -776,6 +776,8 @@
+ void *wdc1 = ((struct piix_ide_extra *)pd->extra)->wdc1;
+ int enabled = 0;
+
++ PCI_SET_DATA(reg, value);
++
+ switch (reg) {
+ case PCI_COMMAND_STATUS_REG:
+ if (value & PCI_COMMAND_IO_ENABLE)