aboutsummaryrefslogtreecommitdiff
path: root/emulators/gxemul
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2006-09-02 15:31:21 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2006-09-02 15:31:21 +0000
commit1284cd2c016abfaa8afcac850e255024ebf875d1 (patch)
treee9fe2cad81a5855061a5570c465a28747becce59 /emulators/gxemul
parent8a6df95308fae3c7284befe8442a1f4808db5a61 (diff)
downloadports-1284cd2c016abfaa8afcac850e255024ebf875d1.tar.gz
ports-1284cd2c016abfaa8afcac850e255024ebf875d1.zip
Notes
Diffstat (limited to 'emulators/gxemul')
-rw-r--r--emulators/gxemul/Makefile1
-rw-r--r--emulators/gxemul/files/patch-src-machines-machine_evbmips.c14
2 files changed, 15 insertions, 0 deletions
diff --git a/emulators/gxemul/Makefile b/emulators/gxemul/Makefile
index 06552d82dbd3..51ab16e0c9bc 100644
--- a/emulators/gxemul/Makefile
+++ b/emulators/gxemul/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gxemul
PORTVERSION= 0.4.2
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://gavare.se/gxemul/src/ \
${MASTER_SITE_LOCAL}
diff --git a/emulators/gxemul/files/patch-src-machines-machine_evbmips.c b/emulators/gxemul/files/patch-src-machines-machine_evbmips.c
new file mode 100644
index 000000000000..6fc61effca98
--- /dev/null
+++ b/emulators/gxemul/files/patch-src-machines-machine_evbmips.c
@@ -0,0 +1,14 @@
+--- src/machines/machine_evbmips.c.orig Mon Jul 17 17:33:05 2006
++++ src/machines/machine_evbmips.c Mon Jul 17 17:35:04 2006
+@@ -176,6 +176,11 @@
+ snprintf(tmps, sizeof(tmps), "0x%08x", machine->physical_ram_in_mb<<20);
+ add_environment_string_dual(cpu, &env, &tmpptr, "memsize", tmps);
+
++#if 1 /* XXX: FreeBSD wants this to figure out the clock speed. */
++ snprintf(tmps, sizeof(tmps), "%d", machine->emulated_hz/1000);
++ add_environment_string_dual(cpu, &env, &tmpptr, "khz", tmps);
++#endif
++
+ add_environment_string_dual(cpu, &env, &tmpptr, "yamonrev", "02.06");
+
+ /* End of env: */