aboutsummaryrefslogtreecommitdiff
path: root/emulators/hatari
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2018-02-21 16:24:53 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2018-02-21 16:24:53 +0000
commit6747cb9b4e52c875e3a9ca4d7d79407c101b0670 (patch)
treeb63cd55e9deac0f11169f04c64d04dd84d68b3b5 /emulators/hatari
parent9050c8e414cba36ceda4084dba51377cf6b95a30 (diff)
Notes
Diffstat (limited to 'emulators/hatari')
-rw-r--r--emulators/hatari/Makefile8
-rw-r--r--emulators/hatari/files/patch-tools_atari-hd-image.sh24
2 files changed, 28 insertions, 4 deletions
diff --git a/emulators/hatari/Makefile b/emulators/hatari/Makefile
index cc59c09992a0..80abc5e0c8a6 100644
--- a/emulators/hatari/Makefile
+++ b/emulators/hatari/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hatari
PORTVERSION= 2.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= emulators
MASTER_SITES= http://download.tuxfamily.org/hatari/${PORTVERSION}/
@@ -15,14 +15,11 @@ LICENSE_FILE= ${WRKSRC}/gpl.txt
LIB_DEPENDS= libportaudio.so:audio/portaudio \
libpng.so:graphics/png
-BUILD_DEPENDS= python:lang/python
-RUN_DEPENDS= python:lang/python
USES= cmake desktop-file-utils python:2.7 readline shared-mime-info \
shebangfix tar:bzip2
SHEBANG_FILES= python-ui/*.py tools/atari-convert-dir.py \
tools/debugger/hatari_profile.py tools/hconsole/*.py
-python_OLD_CMD= /usr/bin/python2
USE_GNOME= pygtk2
CMAKE_ARGS= -DETCDIR:PATH="${PREFIX}/etc" \
-DMANDIR:PATH="man/man1" \
@@ -53,6 +50,9 @@ post-patch:
.endfor
@${REINPLACE_CMD} -e \
's|-Wno-maybe-uninitialized||' ${WRKSRC}/src/cpu/CMakeLists.txt
+ @${REINPLACE_CMD} -e \
+ 's|%%PYTHON_CMD%%|${PYTHON_CMD}| ; \
+ s|%%PYTHON_VERSION%%|${PYTHON_VERSION}|' ${WRKSRC}/tools/atari-hd-image.sh
post-install:
@${MKDIR} ${STAGEDIR}${MANPREFIX}/man/fr/man1
diff --git a/emulators/hatari/files/patch-tools_atari-hd-image.sh b/emulators/hatari/files/patch-tools_atari-hd-image.sh
new file mode 100644
index 000000000000..3aa918524042
--- /dev/null
+++ b/emulators/hatari/files/patch-tools_atari-hd-image.sh
@@ -0,0 +1,24 @@
+--- tools/atari-hd-image.sh.orig 2018-02-20 07:08:43 UTC
++++ tools/atari-hd-image.sh
+@@ -33,8 +33,8 @@ PATH=/sbin:$PATH
+ export PATH
+
+ # check tools
+-if [ -z $(which mkdosfs) ] || [ -z $(which python) ]; then
+- echo "ERROR: either mkdosfs or python tool missing!"
++if [ -z $(which mkdosfs) ] || [ -z $(which %%PYTHON_VERSION%%) ]; then
++ echo "ERROR: either mkdosfs or %%PYTHON_VERSION%% tool missing!"
+ exit 1
+ fi
+
+@@ -147,8 +147,8 @@ echo "$step) Create DOS Master Boot Reco
+ # - http://en.wikipedia.org/wiki/File_Allocation_Table#Boot_Sector
+ # For DOS MBR, the values are little endian.
+ # -----------
+-python << EOF
+-#!/usr/bin/env python
++%%PYTHON_CMD%% << EOF
++#!%%PYTHON_CMD%%
+ mbr = bytearray(512)
+
+ def set_long(idx, value):