aboutsummaryrefslogtreecommitdiff
path: root/emulators/hfsplusutils
diff options
context:
space:
mode:
authorSergei Kolobov <sergei@FreeBSD.org>2003-11-15 21:51:46 +0000
committerSergei Kolobov <sergei@FreeBSD.org>2003-11-15 21:51:46 +0000
commit6a5d39ccfb24c29c0166dd4e378e95fcf1001c93 (patch)
tree7de24f6676e0ad326e406814cda15f34cacae543 /emulators/hfsplusutils
parentd1ab45d44381bdcde6c86918977ce5c0c441e0c3 (diff)
downloadports-6a5d39ccfb24c29c0166dd4e378e95fcf1001c93.tar.gz
ports-6a5d39ccfb24c29c0166dd4e378e95fcf1001c93.zip
Notes
Diffstat (limited to 'emulators/hfsplusutils')
-rw-r--r--emulators/hfsplusutils/Makefile60
-rw-r--r--emulators/hfsplusutils/distinfo1
-rw-r--r--emulators/hfsplusutils/files/patch-swab.h16
-rw-r--r--emulators/hfsplusutils/files/patch-unicode.c14
-rw-r--r--emulators/hfsplusutils/pkg-descr7
-rw-r--r--emulators/hfsplusutils/pkg-plist24
6 files changed, 122 insertions, 0 deletions
diff --git a/emulators/hfsplusutils/Makefile b/emulators/hfsplusutils/Makefile
new file mode 100644
index 000000000000..62584e4bbd35
--- /dev/null
+++ b/emulators/hfsplusutils/Makefile
@@ -0,0 +1,60 @@
+# New ports collection makefile for: hfsplusutils
+# Date created: 2003-11-11
+# Whom: Josh Elsasser <jre@vineyard.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hfsplusutils
+PORTVERSION= 1.0.4
+CATEGORIES= emulators
+MASTER_SITES= ftp://ftp.penguinppc.org/users/hasi/
+DISTNAME= hfsplus_${PORTVERSION}.src
+
+MAINTAINER= jre@vineyard.net
+COMMENT= Utilities for accessing HFS+ filesystems
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+USE_AUTOMAKE_VER= 15
+AUTOMAKE_ARGS= --add-missing
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+WRKSRC= ${WRKDIR}/hfsplus-${PORTVERSION}
+
+MAN1= hfsp.1
+DOCS= AUTHORS ChangeLog NEWS README index.html doc/*.html
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's/^CFLAGS.*/CFLAGS=@CFLAGS@/' \
+ ${WRKSRC}/src/Makefile.am ${WRKSRC}/libhfsp/src/Makefile.am
+ @${REINPLACE_CMD} -e 's,doc/,,' ${WRKSRC}/index.html
+
+# it would really be best if the patch-libtool target was run just
+# after pre-configure instead of just before. To get around this, we
+# touch LIBTOOLFILES so patch-libtool doesn't barf, then run
+# patch-libtool again after running aclocal and autoheader. Hopefully
+# future changes to bsd.port.mk won't cause this to break.
+post-patch:
+ @cd ${WRKSRC} && ${TOUCH} ${LIBTOOLFILES}
+
+pre-configure:
+ @cd ${WRKSRC} && ${ACLOCAL} && ${AUTOHEADER}
+ @${MAKE} patch-libtool
+
+post-install:
+ ${INSTALL_MAN} ${WRKSRC}/doc/man/hfsp.man ${MAN1PREFIX}/man/man1/hfsp.1
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "Does not build on FreeBSD 4.x or earlier"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/emulators/hfsplusutils/distinfo b/emulators/hfsplusutils/distinfo
new file mode 100644
index 000000000000..1d2ef29c4b02
--- /dev/null
+++ b/emulators/hfsplusutils/distinfo
@@ -0,0 +1 @@
+MD5 (hfsplus_1.0.4.src.tar.bz2) = 18fa1efb5432469357ffa6bfa7c08fcd
diff --git a/emulators/hfsplusutils/files/patch-swab.h b/emulators/hfsplusutils/files/patch-swab.h
new file mode 100644
index 000000000000..46fa7cbe271c
--- /dev/null
+++ b/emulators/hfsplusutils/files/patch-swab.h
@@ -0,0 +1,16 @@
+--- libhfsp/src/swab.h.orig Tue Mar 5 14:50:29 2002
++++ libhfsp/src/swab.h Tue Nov 11 14:53:14 2003
+@@ -24,8 +24,11 @@
+ * $Id: swab.h,v 1.1.1.1 2002/03/05 19:50:29 klaus Exp $
+ */
+
+-#include <endian.h>
+-#include <byteswap.h>
++#include <sys/endian.h>
++
++#define bswap_16 bswap16
++#define bswap_32 bswap32
++#define bswap_64 bswap64
+
+ /* basic fuction:
+ value = swab_inc(ptr);
diff --git a/emulators/hfsplusutils/files/patch-unicode.c b/emulators/hfsplusutils/files/patch-unicode.c
new file mode 100644
index 000000000000..ed62d322f55d
--- /dev/null
+++ b/emulators/hfsplusutils/files/patch-unicode.c
@@ -0,0 +1,14 @@
+--- libhfsp/src/unicode.c.orig Tue Mar 5 14:50:29 2002
++++ libhfsp/src/unicode.c Tue Nov 11 14:53:25 2003
+@@ -14,9 +14,8 @@
+ # endif
+
+ #include <stdlib.h>
+-#include <endian.h>
+-#include <byteswap.h>
+-#include <linux/string.h>
++#include <sys/endian.h>
++#include <string.h>
+
+ #define __USE_GNU
+ /* need wcsrtomb */
diff --git a/emulators/hfsplusutils/pkg-descr b/emulators/hfsplusutils/pkg-descr
new file mode 100644
index 000000000000..71a54235c7ac
--- /dev/null
+++ b/emulators/hfsplusutils/pkg-descr
@@ -0,0 +1,7 @@
+This is a set of tools that allow access to HFS+ formatted
+volumes. HFS+ is a modernized version of Apple Computers HFS
+Filesystem. In addition in contains the library "libhfsp" which you
+may use for your own experiments, all the tools are based on this
+library. (A bit of understanding is still needed however).
+
+Author: Klaus Halfmann <klaus.halfmann@t-online.de>
diff --git a/emulators/hfsplusutils/pkg-plist b/emulators/hfsplusutils/pkg-plist
new file mode 100644
index 000000000000..4896fd97f4c0
--- /dev/null
+++ b/emulators/hfsplusutils/pkg-plist
@@ -0,0 +1,24 @@
+@comment $FreeBSD$
+bin/hpcd
+bin/hpcopy
+bin/hpfsck
+bin/hpls
+bin/hpmkdir
+bin/hpmount
+bin/hppwd
+bin/hprm
+bin/hpumount
+lib/libhfsp.a
+lib/libhfsp.la
+lib/libhfsp.so
+lib/libhfsp.so.0
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/bugs.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/hfsp.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/libhfsp.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%