aboutsummaryrefslogtreecommitdiff
path: root/emulators/hugo/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-05-27 15:24:20 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-05-27 15:24:20 +0000
commitcce58bca30e27652863ee03144e8815c0042974f (patch)
treeed8908899b8e7fdd2a0a7b41de1cfef3129120dd /emulators/hugo/Makefile
parente529d3fa56cd99baf460710bb719d3269e1435f4 (diff)
downloadports-cce58bca30e27652863ee03144e8815c0042974f.tar.gz
ports-cce58bca30e27652863ee03144e8815c0042974f.zip
Notes
Diffstat (limited to 'emulators/hugo/Makefile')
-rw-r--r--emulators/hugo/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/emulators/hugo/Makefile b/emulators/hugo/Makefile
new file mode 100644
index 000000000000..01ac24a73d1d
--- /dev/null
+++ b/emulators/hugo/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: Hu-Go!
+# Date created: 18 May 2006
+# Whom: Li-Lun Wang <llwang@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hugo
+PORTVERSION= 2.12
+CATEGORIES= emulators
+MASTER_SITES= http://www.zeograd.com/download/
+
+MAINTAINER= llwang@infor.org
+COMMENT= A PC Engine (TurboGrafx 16) emulator
+
+BUILD_DEPENDS= ${LOCALBASE}/include/argp.h:${PORTSDIR}/devel/argp-standalone
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV+= SDL_CONFIG="${SDL_CONFIG}" LDFLAGS="${LDFLAGS}"
+
+.if !defined(WITHOUT_NETPLAY)
+USE_SDL+= net
+.else
+CONFIGURE_ARGS+= --enable-netplay=no
+.endif
+
+.if defined(WITHOUT_GUI)
+CONFIGURE_ARGS+= --enable-gui=no --disable-gtktest
+.else
+USE_GNOME= gtk20
+.endif
+
+.if defined(WITH_OGG_SUPPORT)
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
+WITH_SDL_MIXER= yes
+CONFIGURE_ARGS+= --with-ogg-support
+.endif
+
+.if defined(WITH_SDL_MIXER)
+USE_SDL+= mixer
+CONFIGURE_ARGS+= --with-sdl-mixer
+.endif
+
+MAKE_ENV+= DOCSDIR="${DOCSDIR}"
+
+.if defined(NOPORTDOCS)
+MAKE_ENV+= PORTDOCS=false
+.else
+MAKE_ENV+= PORTDOCS=true
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/configure
+
+.include <bsd.port.mk>