aboutsummaryrefslogtreecommitdiff
path: root/emulators/ia64sim
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-01 10:13:45 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-02-01 10:13:45 +0000
commitd57bb05fb397c327fdb5fc0a54bd4ff174323112 (patch)
tree2355e5b9fe1a647c7efb7e859db75c11d7bbf4af /emulators/ia64sim
parent7001383d1db85bbc62effdce9b3e2cc4f56f28cf (diff)
downloadports-d57bb05fb397c327fdb5fc0a54bd4ff174323112.tar.gz
ports-d57bb05fb397c327fdb5fc0a54bd4ff174323112.zip
Notes
Diffstat (limited to 'emulators/ia64sim')
-rw-r--r--emulators/ia64sim/Makefile6
-rw-r--r--emulators/ia64sim/files/patch-ia64sim.c14
-rw-r--r--emulators/ia64sim/files/patch-include_ia64.h (renamed from emulators/ia64sim/files/patch-ia64.h)10
-rw-r--r--emulators/ia64sim/files/patch-makefile.unx16
4 files changed, 29 insertions, 17 deletions
diff --git a/emulators/ia64sim/Makefile b/emulators/ia64sim/Makefile
index 3a2d5cee493f..2dc43b7c5492 100644
--- a/emulators/ia64sim/Makefile
+++ b/emulators/ia64sim/Makefile
@@ -11,6 +11,8 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= IA64 simulator (Intel(R) Architecture 64)
+LICENSE= PD
+
USES= gmake zip
MAKEFILE= makefile.unx
MAKE_ARGS= CC="${CC}"
@@ -23,10 +25,12 @@ PORTDOCS= ia64user.txt readme
OPTIONS_DEFINE= DOCS
pre-build:
- ${RM} -f ${WRKSRC}/obj/*.o ${WRKSRC}/ia64sim
+ @${RM} -f ${WRKSRC}/obj/*.o ${WRKSRC}/ia64sim
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ia64sim ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/ia64user.txt ${WRKSRC}/readme \
${STAGEDIR}${DOCSDIR}
diff --git a/emulators/ia64sim/files/patch-ia64sim.c b/emulators/ia64sim/files/patch-ia64sim.c
index 2a71349740a6..f656556b4b17 100644
--- a/emulators/ia64sim/files/patch-ia64sim.c
+++ b/emulators/ia64sim/files/patch-ia64sim.c
@@ -1,6 +1,6 @@
---- ia64sim.c.orig Sun Feb 27 17:20:26 2000
-+++ ia64sim.c Sun May 6 11:51:41 2001
-@@ -779,7 +779,7 @@
+--- ia64sim.c.orig 2000-02-28 01:20:26 UTC
++++ ia64sim.c
+@@ -779,7 +779,7 @@ int main(int argc, char **argv) {
uint32 i;
@@ -9,13 +9,13 @@
printf("Memory limits: 0x%08x-0x%08x\n", 0, MEMSIZE-1);
printf("Try 'h' for help\n\n");
-@@ -810,6 +810,9 @@
- while(1) {
+@@ -811,6 +811,9 @@ int main(int argc, char **argv) {
printf("IA64sim>> ");
fgets(cmd,sizeof(cmd),stdin);
-+
+
+ if (feof(stdin))
+ return 0;
-
++
nextchar = cmd;
while(*nextchar) *nextchar++ = tolower(*nextchar);
+
diff --git a/emulators/ia64sim/files/patch-ia64.h b/emulators/ia64sim/files/patch-include_ia64.h
index 761610a4626e..4c3b43814fe4 100644
--- a/emulators/ia64sim/files/patch-ia64.h
+++ b/emulators/ia64sim/files/patch-include_ia64.h
@@ -1,6 +1,6 @@
---- include/ia64.h.orig Sun May 6 11:39:29 2001
-+++ include/ia64.h Sun May 6 11:35:10 2001
-@@ -29,6 +29,7 @@
+--- include/ia64.h.orig 2000-03-09 00:57:11 UTC
++++ include/ia64.h
+@@ -29,6 +29,7 @@ benefit from your work.
#include <ctype.h>
#include <string.h>
#include <elf.h>
@@ -8,7 +8,7 @@
#define TRUE 1
#define FALSE 0
-@@ -38,7 +39,7 @@
+@@ -38,7 +39,7 @@ benefit from your work.
0<=lo,hi<=63 and lo<=hi */
#define BITS(x,lo,hi) ( \
@@ -17,7 +17,7 @@
( (1<<(hi-lo+1)) - 1 ) \
)
-@@ -72,8 +73,8 @@
+@@ -72,8 +73,8 @@ typedef union {
uint8 b[8];
} qword;
diff --git a/emulators/ia64sim/files/patch-makefile.unx b/emulators/ia64sim/files/patch-makefile.unx
index c13fc41cae36..8ad9d9e2d989 100644
--- a/emulators/ia64sim/files/patch-makefile.unx
+++ b/emulators/ia64sim/files/patch-makefile.unx
@@ -1,8 +1,16 @@
---- makefile.unx.orig Sat Feb 12 22:25:47 2000
-+++ makefile.unx Sun May 6 11:48:13 2001
-@@ -21 +21 @@
+--- makefile.unx.orig 2000-02-13 06:25:47 UTC
++++ makefile.unx
+@@ -18,11 +18,11 @@ EXECDIR = execute
+ OBJDIR = obj
+ INCDIR = include
+ CC = gcc
-CFLAGS = -O3 -m486 -fomit-frame-pointer -s -I$(INCDIR)
+CFLAGS += -s -I$(INCDIR)
-@@ -25 +25 @@
+
+ ASMSRCS= assemble.c bundle.c asmfunc.c jumptbl.c decode.c symbols.c
+
-EXECSRCS = execute.c utils.c f_unit.c b_unit.c x_unit.c \
+EXECSRCS = elf.c execute.c utils.c f_unit.c b_unit.c x_unit.c \
+ m_unit.c i_alu.c i_cmp.c i_shft.c globals.c
+
+ ASMOBJS = $(ASMSRCS:.c=.o)