aboutsummaryrefslogtreecommitdiff
path: root/emulators/ia64sim
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2003-10-07 09:09:32 +0000
committerPeter Pentchev <roam@FreeBSD.org>2003-10-07 09:09:32 +0000
commite42b10e8759fe9a3a3527f12f712b8108ed4cc93 (patch)
tree0f68d31e1bcccc4a8f66d42f81622f99246e70da /emulators/ia64sim
parentdb1610752a5cec4b3e200dbe2711beabfdbff2df (diff)
downloadports-e42b10e8759fe9a3a3527f12f712b8108ed4cc93.tar.gz
ports-e42b10e8759fe9a3a3527f12f712b8108ed4cc93.zip
Notes
Diffstat (limited to 'emulators/ia64sim')
-rw-r--r--emulators/ia64sim/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/emulators/ia64sim/Makefile b/emulators/ia64sim/Makefile
index 9fc5fea35bce..e5647ed939f6 100644
--- a/emulators/ia64sim/Makefile
+++ b/emulators/ia64sim/Makefile
@@ -12,20 +12,27 @@ CATEGORIES= emulators
MASTER_SITES= http://www.pacificsites.com/~ccrayne/ \
http://www.glue.umd.edu/~jasonp/ \
http://www.boo.net/~jasonp/
-DISTFILES= ${PORTNAME}${EXTRACT_SUFX}
+DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= IA64 simulator (Intel(R) Architecture 64)
+USE_ZIP= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 501103
+BROKEN= "does not build with latest gcc"
+.endif
+
EXTRACT_BEFORE_ARGS= -qLa
WRKSRC= ${WRKDIR}/home/chuck/ia64simcc
-USE_ZIP= yes
USE_GMAKE= yes
MAKEFILE= makefile.unx
pre-build:
- rm -f ${WRKSRC}/obj/*.o
- rm -f ${WRKSRC}/ia64sim
+ ${RM} -f ${WRKSRC}/obj/*.o
+ ${RM} -f ${WRKSRC}/ia64sim
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ia64sim ${PREFIX}/bin
@@ -34,4 +41,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/doc/ia64user.txt ${WRKSRC}/readme ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>