aboutsummaryrefslogtreecommitdiff
path: root/emulators/kqemu-kmod
diff options
context:
space:
mode:
authorJuergen Lock <nox@FreeBSD.org>2010-07-27 16:43:37 +0000
committerJuergen Lock <nox@FreeBSD.org>2010-07-27 16:43:37 +0000
commit68b5a8f71042f04a374fb39dd15799799d675e86 (patch)
treee09284691472cb47e642f065685b2771ed640719 /emulators/kqemu-kmod
parent49a746ede788f5fcf95cd62f98fd891625d15840 (diff)
downloadports-68b5a8f71042f04a374fb39dd15799799d675e86.tar.gz
ports-68b5a8f71042f04a374fb39dd15799799d675e86.zip
Notes
Diffstat (limited to 'emulators/kqemu-kmod')
-rw-r--r--emulators/kqemu-kmod/Makefile3
-rw-r--r--emulators/kqemu-kmod/files/patch-common-kqemu_int.h19
2 files changed, 21 insertions, 1 deletions
diff --git a/emulators/kqemu-kmod/Makefile b/emulators/kqemu-kmod/Makefile
index 31c025bfbfed..3f0d8b722a0e 100644
--- a/emulators/kqemu-kmod/Makefile
+++ b/emulators/kqemu-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kqemu
PORTVERSION= 1.3.0.p11
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= emulators kld
MASTER_SITES= http://bellard.org/qemu/ \
http://qemu.org/ \
@@ -76,6 +76,7 @@ post-patch:
.endif
do-build:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} beforedepend && ${LN} -s @/sys sys)
@(cd ${BUILD_WRKSRC}/common; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} Makefile ${MAKE_ARGS} ${ALL_TARGET})
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
diff --git a/emulators/kqemu-kmod/files/patch-common-kqemu_int.h b/emulators/kqemu-kmod/files/patch-common-kqemu_int.h
new file mode 100644
index 000000000000..1d5edf76be9d
--- /dev/null
+++ b/emulators/kqemu-kmod/files/patch-common-kqemu_int.h
@@ -0,0 +1,19 @@
+--- common/kqemu_int.h.orig
++++ common/kqemu_int.h
+@@ -17,8 +17,16 @@
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+ #ifndef __ASSEMBLY__
++#ifdef __FreeBSD__
++#include <sys/stddef.h>
++#include <machine/stdarg.h>
++#include <sys/cdefs.h>
++#include <machine/_types.h>
++typedef __size_t size_t;
++#else
+ #include <stddef.h>
+ #include <stdarg.h>
++#endif
+
+ #ifndef NO_STD_TYPES
+