aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux-ePSXe
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
commit23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d (patch)
treefa03305e656151ebe33c7e94eacc947b13d1c273 /emulators/linux-ePSXe
parentb347391f9ad81dd1ebc74b80d713888404b304bd (diff)
downloadports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.tar.gz
ports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.zip
Notes
Diffstat (limited to 'emulators/linux-ePSXe')
-rw-r--r--emulators/linux-ePSXe/Makefile16
1 files changed, 6 insertions, 10 deletions
diff --git a/emulators/linux-ePSXe/Makefile b/emulators/linux-ePSXe/Makefile
index a76e73d80f1a..4d328358dc62 100644
--- a/emulators/linux-ePSXe/Makefile
+++ b/emulators/linux-ePSXe/Makefile
@@ -16,26 +16,21 @@ MAINTAINER= jylefort@FreeBSD.org
COMMENT= A Sony Playstation emulator (Linux version)
# The binary is built against glibc 2.3, so we need linux_base-8.
-RUN_DEPENDS= ${LINUXBASE}/lib/libc-2.3.2.so:${PORTSDIR}/emulators/linux_base-8 \
- ${LINUXBASE}/usr/X11R6/lib/libX11.so.6:${PORTSDIR}/x11/linux-XFree86-libs \
- ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk
+USE_LINUX= yes
USE_X_PREFIX= yes
USE_ZIP= yes
NO_WRKSUBDIR= yes
ONLY_FOR_ARCHS= i386
-# Linux binary should not be stripped by INSTALL_PROGRAM
-# because as a side effect it brands the binary as FreeBSD.
-STRIP=
-
.include <bsd.port.pre.mk>
EPSXE= ${PREFIX}/libexec/epsxe
-PSEMUPRO_PLUGINS_DIR= ${LOCALBASE}/lib/psemupro/plugins
-PSEMUPRO_CFGBINS_DIR= ${LOCALBASE}/libexec/psemupro/cfg
-PSEMUPRO_CFGFILES_DIR= ${LOCALBASE}/share/psemupro/cfg
+PSEMUPRO_PLUGINS_DIR= ${PREFIX}/lib/psemupro/plugins
+PSEMUPRO_CFGBINS_DIR= ${PREFIX}/libexec/psemupro/cfg
+PSEMUPRO_CFGFILES_DIR= ${PREFIX}/share/psemupro/cfg
do-build:
${MKDIR} ${WRKSRC}/FreeBSD
@@ -57,6 +52,7 @@ do-install:
${MKDIR} ${PREFIX}/libexec
${INSTALL_PROGRAM} ${WRKSRC}/epsxe ${EPSXE}
+ ${BRANDELF} -t Linux ${EPSXE}
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/keycodes.lst ${DATADIR}