aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux-padjoy/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-13 09:16:23 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-04-13 09:16:23 +0000
commite43af4f8368973dc85aba55a9e14cc3dcf04ce0e (patch)
tree5c525dfc69201cf974803542fe0b450ebf37fe8b /emulators/linux-padjoy/Makefile
parent9045d474fd6de1cd7a1382b8338bb14457e83266 (diff)
downloadports-e43af4f8368973dc85aba55a9e14cc3dcf04ce0e.tar.gz
ports-e43af4f8368973dc85aba55a9e14cc3dcf04ce0e.zip
Notes
Diffstat (limited to 'emulators/linux-padjoy/Makefile')
-rw-r--r--emulators/linux-padjoy/Makefile51
1 files changed, 51 insertions, 0 deletions
diff --git a/emulators/linux-padjoy/Makefile b/emulators/linux-padjoy/Makefile
new file mode 100644
index 000000000000..97a01d3dfbe8
--- /dev/null
+++ b/emulators/linux-padjoy/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: linux-padjoy
+# Date created: 13 Apr 2006
+# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= padjoy
+PORTVERSION= 0.8.1
+CATEGORIES= emulators linux
+MASTER_SITES= http://members.chello.at/erich.kitzmueller/ammoq/
+PKGNAMEPREFIX= linux-
+DISTNAME= padJoy${MAJOR}${MINOR}${MICRO}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= jylefort@FreeBSD.org
+COMMENT= A PSEmu Pro joystick plugin (Linux version)
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libgtk-1.2.so.0:${PORTSDIR}/x11-toolkits/linux-gtk \
+ /boot/modules/linux_js.ko:${PORTSDIR}/devel/linux-js
+
+WRKSRC= ${WRKDIR}/padJoy
+NO_BUILD= yes
+USE_LINUX= yes
+USE_X_PREFIX= yes
+
+ONLY_FOR_ARCHS= i386 amd64
+
+MAJOR= ${PORTVERSION:R:R}
+MINOR= ${PORTVERSION:R:E}
+MICRO= ${PORTVERSION:E}
+PLIST_SUB= MAJOR=${MAJOR} MINOR=${MINOR}
+
+PSEMUPRO_PLUGINS_DIR= ${PREFIX}/lib/psemupro/plugins
+PSEMUPRO_CFGBINS_DIR= ${PREFIX}/libexec/psemupro/cfg
+
+do-install:
+ ${MKDIR} ${PSEMUPRO_PLUGINS_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/libpadJoy-${MAJOR}.${MINOR}.so ${PSEMUPRO_PLUGINS_DIR}
+
+ ${MKDIR} ${PSEMUPRO_CFGBINS_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/cfgPadJoy ${PSEMUPRO_CFGBINS_DIR}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+.endif
+
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>