aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux-peops-softgpu/Makefile
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-12-01 00:37:20 +0000
committerRene Ladan <rene@FreeBSD.org>2013-12-01 00:37:20 +0000
commit39edf56f0933f7c5f614aad7fca76ecb6470fe23 (patch)
tree1f76ce335d709053111226d0016b68e447fbd0ab /emulators/linux-peops-softgpu/Makefile
parentaafa744d0fba9c50a8846ab406390c74cd0e9937 (diff)
downloadports-39edf56f0933f7c5f614aad7fca76ecb6470fe23.tar.gz
ports-39edf56f0933f7c5f614aad7fca76ecb6470fe23.zip
Notes
Diffstat (limited to 'emulators/linux-peops-softgpu/Makefile')
-rw-r--r--emulators/linux-peops-softgpu/Makefile54
1 files changed, 0 insertions, 54 deletions
diff --git a/emulators/linux-peops-softgpu/Makefile b/emulators/linux-peops-softgpu/Makefile
deleted file mode 100644
index 28df45d3cd3e..000000000000
--- a/emulators/linux-peops-softgpu/Makefile
+++ /dev/null
@@ -1,54 +0,0 @@
-# Created by: Jean-Yves Lefort <jylefort@brutele.be>
-# $FreeBSD$
-
-PORTNAME= peops-softgpu
-PORTVERSION= ${SOFTGPU_VERSION}
-CATEGORIES= emulators linux
-MASTER_SITES= http://www.pbernert.com/
-PKGNAMEPREFIX= linux-
-DISTFILES= gpupeopssoftx${MAJOR}${MINOR}${EXTRACT_SUFX} \
- ${CFG_DISTFILE}
-
-MAINTAINER= cyberbotx@cyberbotx.com
-COMMENT= PSEmu Pro GPU plugin using a software X11 renderer (Linux version)
-
-DEPRECATED= Depends on deprecated Linux GTK1
-EXPIRATION_DATE=2013-12-01
-
-NO_WRKSUBDIR= yes
-NO_BUILD= yes
-USE_LINUX= yes
-USE_LINUX_APPS= gtk xorglibs
-PORTDOCS= *
-
-ONLY_FOR_ARCHS= i386 amd64
-
-MAJOR= ${PORTVERSION:R}
-MINOR= ${PORTVERSION:E}
-PLIST_SUB+= MAJOR=${MAJOR} MINOR=${MINOR}
-
-PSEMUPRO_PLUGINS_DIR= ${PREFIX}/lib/psemupro/plugins
-PSEMUPRO_CFGBINS_DIR= ${PREFIX}/libexec/psemupro/cfg
-PSEMUPRO_CFGFILES_DIR= ${PREFIX}/share/psemupro/cfg
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.include "${.CURDIR}/../linux-pete-xgl2gpu/Makefile.inc"
-
-do-install:
- ${MKDIR} ${PSEMUPRO_PLUGINS_DIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/libgpuPeopsSoftX.so.${MAJOR}.0.${MINOR} ${PSEMUPRO_PLUGINS_DIR}
-
- ${MKDIR} ${PSEMUPRO_CFGBINS_DIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/cfg/cfgPeopsSoft ${PSEMUPRO_CFGBINS_DIR}
-
- ${MKDIR} ${PSEMUPRO_CFGFILES_DIR}
- ${INSTALL_DATA} ${WRKSRC}/gpuPeopsSoftX.cfg ${PSEMUPRO_CFGFILES_DIR}
-
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
-.endif
-
-.include <bsd.port.mk>