aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux-pete-xgl2gpu
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-05-20 07:31:35 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-05-20 07:31:35 +0000
commita103bf3dfcc8f5e58bcf8ae4599b22140940404a (patch)
tree171d8a881c359af41a40e1feeabcedb947e574ec /emulators/linux-pete-xgl2gpu
parentbb6f87baa42065bb53fae2f77606f6734efd55a3 (diff)
downloadports-a103bf3dfcc8f5e58bcf8ae4599b22140940404a.tar.gz
ports-a103bf3dfcc8f5e58bcf8ae4599b22140940404a.zip
Notes
Diffstat (limited to 'emulators/linux-pete-xgl2gpu')
-rw-r--r--emulators/linux-pete-xgl2gpu/Makefile42
-rw-r--r--emulators/linux-pete-xgl2gpu/Makefile.inc7
-rw-r--r--emulators/linux-pete-xgl2gpu/distinfo6
-rw-r--r--emulators/linux-pete-xgl2gpu/pkg-plist3
4 files changed, 35 insertions, 23 deletions
diff --git a/emulators/linux-pete-xgl2gpu/Makefile b/emulators/linux-pete-xgl2gpu/Makefile
index a8d5aec27ede..c841ab22c93f 100644
--- a/emulators/linux-pete-xgl2gpu/Makefile
+++ b/emulators/linux-pete-xgl2gpu/Makefile
@@ -1,32 +1,28 @@
-# New ports collection makefile for: linux-pete-xgl2gpu
-# Date created: 16 Jul 2005
-# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
-#
+# Created by: Jean-Yves Lefort <jylefort@FreeBSD.org>
# $FreeBSD$
-#
-PORTNAME= linux-pete-xgl2gpu
-PORTVERSION= 2.8
+PORTNAME= pete-xgl2gpu
+PORTVERSION= ${XGL2GPU_VERSION}
CATEGORIES= emulators linux
MASTER_SITES= http://www.pbernert.com/
-DISTNAME= gpupetexgl${MAJOR}0${MINOR}
+PKGNAMEPREFIX= linux-
+DISTFILES= gpupetexgl${MAJOR}0${MINOR}${EXTRACT_SUFX} \
+ ${CFG_DISTFILE}
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A PSEmu Pro GPU plugin using a modern OpenGL renderer (Linux version)
-
-.if defined(WITH_NVIDIA_GL)
-RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
-.else
-USE_LINUX_APPS+=dri
-.endif
+MAINTAINER= cyberbotx@cyberbotx.com
+COMMENT= PSEmu Pro GPU plugin using a modern OpenGL renderer (Linux version)
NO_WRKSUBDIR= yes
NO_BUILD= yes
USE_LINUX= yes
USE_LINUX_APPS= gtk xorglibs
+PORTDOCS= *
ONLY_FOR_ARCHS= i386 amd64
+OPTIONS_DEFINE= NVIDIA_GL
+NVIDIA_GL_DESC= Use nVidia OpenGL driver
+
MAJOR= ${PORTVERSION:R}
MINOR= ${PORTVERSION:E}
PLIST_SUB+= MAJOR=${MAJOR} MINOR=${MINOR}
@@ -35,6 +31,16 @@ PSEMUPRO_PLUGINS_DIR= ${PREFIX}/lib/psemupro/plugins
PSEMUPRO_CFGBINS_DIR= ${PREFIX}/libexec/psemupro/cfg
PSEMUPRO_CFGFILES_DIR= ${PREFIX}/share/psemupro/cfg
+.include <bsd.port.options.mk>
+
+.include "${.CURDIR}/../linux-pete-xgl2gpu/Makefile.inc"
+
+.if ${PORT_OPTIONS:MNVIDIA_GL}
+RUN_DEPENDS+= ${LINUXBASE}/usr/lib/libGL.so.1:${PORTSDIR}/x11/nvidia-driver
+.else
+USE_LINUX_APPS+=dri
+.endif
+
# by default, disable options which may crash the plugin
post-patch:
@${REINPLACE_CMD} -e '/^TWinShader/ s|= 1|= 0|' \
@@ -45,12 +51,12 @@ do-install:
${INSTALL_PROGRAM} ${WRKSRC}/libgpuPeteXGL2.so.${MAJOR}.0.${MINOR} ${PSEMUPRO_PLUGINS_DIR}
${MKDIR} ${PSEMUPRO_CFGBINS_DIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/cfgPeteXGL2 ${PSEMUPRO_CFGBINS_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/cfg/cfgPeteXGL2 ${PSEMUPRO_CFGBINS_DIR}
${MKDIR} ${PSEMUPRO_CFGFILES_DIR}
${INSTALL_DATA} ${WRKSRC}/gpuPeteXGL2.cfg ${PSEMUPRO_CFGFILES_DIR}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/*.txt ${DOCSDIR}
.endif
diff --git a/emulators/linux-pete-xgl2gpu/Makefile.inc b/emulators/linux-pete-xgl2gpu/Makefile.inc
new file mode 100644
index 000000000000..e77e550d85d6
--- /dev/null
+++ b/emulators/linux-pete-xgl2gpu/Makefile.inc
@@ -0,0 +1,7 @@
+# $FreeBSD$
+
+XGL2GPU_VERSION= 2.9
+MESAGPU_VERSION= 1.77
+SOFTGPU_VERSION= 1.18
+
+CFG_DISTFILE= petegpucfg_V${XGL2GPU_VERSION:C/\./-/}_V${MESAGPU_VERSION:C/\./-/}_V${SOFTGPU_VERSION:C/\./-/}${EXTRACT_SUFX}
diff --git a/emulators/linux-pete-xgl2gpu/distinfo b/emulators/linux-pete-xgl2gpu/distinfo
index f08161f75422..4d59adfac6ac 100644
--- a/emulators/linux-pete-xgl2gpu/distinfo
+++ b/emulators/linux-pete-xgl2gpu/distinfo
@@ -1,2 +1,4 @@
-SHA256 (gpupetexgl208.tar.gz) = 01486fd9c644e44abd7aa303cbdccd4139d2a133b75f53436b6b8e5fb14dc9d0
-SIZE (gpupetexgl208.tar.gz) = 189449
+SHA256 (gpupetexgl209.tar.gz) = 83427665c31bbae16c1fbd7c695d0bc9acc4cfcf911302c031f852c850c9cc5d
+SIZE (gpupetexgl209.tar.gz) = 173744
+SHA256 (petegpucfg_V2-9_V1-77_V1-18.tar.gz) = 1488750fb2f158b68ef11b693fc1f45948ec41e84b1329315703adc91679fd91
+SIZE (petegpucfg_V2-9_V1-77_V1-18.tar.gz) = 59589
diff --git a/emulators/linux-pete-xgl2gpu/pkg-plist b/emulators/linux-pete-xgl2gpu/pkg-plist
index c29af3aeb653..3d43741e4340 100644
--- a/emulators/linux-pete-xgl2gpu/pkg-plist
+++ b/emulators/linux-pete-xgl2gpu/pkg-plist
@@ -7,6 +7,3 @@ share/psemupro/cfg/gpuPeteXGL2.cfg
@dirrmtry libexec/psemupro
@dirrmtry share/psemupro/cfg
@dirrmtry share/psemupro
-%%PORTDOCS%%%%DOCSDIR%%/readme.txt
-%%PORTDOCS%%%%DOCSDIR%%/version.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%