aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux_base-c6/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2019-07-10 14:40:02 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2019-07-10 14:40:02 +0000
commit7003875294fc8b811ffe452c376f66a855494f60 (patch)
tree9754e52797ffd2ab1caf7b83b3fa360ba5db8a85 /emulators/linux_base-c6/Makefile
parentb3ec6fb0fe1868f49bc3ae82909a818a4d043678 (diff)
downloadports-7003875294fc8b811ffe452c376f66a855494f60.tar.gz
ports-7003875294fc8b811ffe452c376f66a855494f60.zip
Notes
Diffstat (limited to 'emulators/linux_base-c6/Makefile')
-rw-r--r--emulators/linux_base-c6/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/emulators/linux_base-c6/Makefile b/emulators/linux_base-c6/Makefile
index 1c3db80ff1d4..9da76b6ee37a 100644
--- a/emulators/linux_base-c6/Makefile
+++ b/emulators/linux_base-c6/Makefile
@@ -121,9 +121,9 @@ REMOVE_DIRS= boot home media mnt proc root sys tmp var/log var/run var/tmp
REMOVE_FILES= bin/df bin/su etc/exports etc/group etc/gshadow etc/motd \
etc/passwd etc/printcap etc/protocols etc/services etc/shadow
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${LINUX_ARCH} == x86_64
+.if ${ARCH} == amd64
SYSCTLMIB= kern.features.linux64
.else
SYSCTLMIB= compat.linux.osrelease
@@ -135,7 +135,7 @@ post-patch:
@${FIND} ${WRKSRC}/lib -type d -empty -delete
@${FIND} ${WRKSRC}/usr -type d -empty -delete
@${BRANDELF} -t Linux ${WRKSRC}/lib/ld-2.12.so
-.if ${LINUX_ARCH} == x86_64
+.if ${ARCH} == amd64
@${FIND} ${WRKSRC}/lib64 -type d -empty -delete
@${BRANDELF} -t Linux ${WRKSRC}/lib64/ld-2.12.so
.endif
@@ -155,8 +155,8 @@ post-install:
${LN} -sf usr/bin ${STAGEDIR}${PREFIX}
${LN} -sf usr/lib ${STAGEDIR}${PREFIX}
${LN} -sf usr/sbin ${STAGEDIR}${PREFIX}
-.if ${LINUX_ARCH} == x86_64
+.if ${ARCH} == amd64
${LN} -sf usr/lib64 ${STAGEDIR}${PREFIX}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>