aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux_base-fc6/Makefile
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2006-07-10 22:48:01 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2006-07-10 22:48:01 +0000
commit110fdaf7b5ea676a9fb22c4247d2289d09e25569 (patch)
tree87955b11ef62245bc1732a259c495518b8ee4d77 /emulators/linux_base-fc6/Makefile
parent13ed7d59465e87e9187499b04f88e7416da7db18 (diff)
downloadports-110fdaf7b5ea676a9fb22c4247d2289d09e25569.tar.gz
ports-110fdaf7b5ea676a9fb22c4247d2289d09e25569.zip
Notes
Diffstat (limited to 'emulators/linux_base-fc6/Makefile')
-rw-r--r--emulators/linux_base-fc6/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/emulators/linux_base-fc6/Makefile b/emulators/linux_base-fc6/Makefile
index 0727b80f92ad..89de6b55fdac 100644
--- a/emulators/linux_base-fc6/Makefile
+++ b/emulators/linux_base-fc6/Makefile
@@ -172,11 +172,17 @@ do-build:
#
@${MV} ${WRKSRC}/etc/nsswitch.conf ${WRKSRC}/etc/nsswitch.conf.dist
+# Fix usr/bin/*db4* permissions to allow "portupgrade -s"
+ @${CHMOD} u+w ${WRKSRC}/usr/bin/*db4*
+
@${FIND} ${WRKSRC}/bin ${WRKSRC}/sbin/ ${WRKSRC}/usr/bin \
${WRKSRC}/usr/sbin -type f -print0 | ${XARGS} -0 ${FILE} \
| ${GREP} ELF | ${CUT} -d : -f 1 \
| ${XARGS} ${BRANDELF} -t Linux
+# Restore the status quo for usr/bin/*db4* files
+ @${CHMOD} u-w ${WRKSRC}/usr/bin/*db4*
+
do-install:
#
# Handle the loading of the linux loadable kernel module if required.