aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux_base-suse-9.2/Makefile
diff options
context:
space:
mode:
authorSheldon Hearn <sheldonh@FreeBSD.org>2000-08-15 10:22:36 +0000
committerSheldon Hearn <sheldonh@FreeBSD.org>2000-08-15 10:22:36 +0000
commit4e28d4de05080ad0b7b8856a3d4b645e47378d55 (patch)
treea7c667b9dd9e0be60fd47ff3bf6068ea94e1b149 /emulators/linux_base-suse-9.2/Makefile
parentbd9d1979dda9036d0ce5451e12ac694a83fc8880 (diff)
downloadports-4e28d4de05080ad0b7b8856a3d4b645e47378d55.tar.gz
ports-4e28d4de05080ad0b7b8856a3d4b645e47378d55.zip
Notes
Diffstat (limited to 'emulators/linux_base-suse-9.2/Makefile')
-rw-r--r--emulators/linux_base-suse-9.2/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/emulators/linux_base-suse-9.2/Makefile b/emulators/linux_base-suse-9.2/Makefile
index 3d81d0ed718c..80aa0bd30fa2 100644
--- a/emulators/linux_base-suse-9.2/Makefile
+++ b/emulators/linux_base-suse-9.2/Makefile
@@ -124,17 +124,14 @@ NEEDLOADLINK= true
do-patch:
@${DO_NADA}
+pre-install:
+#
+# Handle the loading of the linux loadable kernel module if
+# required.
+#
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
do-install:
- @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
- ${ECHO} 'Linux mode is not enabled.\
- Loading linux kernel module...' | fmt; \
- linux || { \
- ${ECHO} 'The linux kernel module could not be loaded.\
- Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
- ${FALSE}; \
- };\
- fi
@${MKDIR} ${PREFIX}/${DBPATH}
@${MKDIR} ${PREFIX}/var/tmp
@rpm --initdb --root ${PREFIX} --dbpath ${DBPATH}